Add picocom package, move serial comm. stuff to its section in Config.in
authorNicolas Thill <nico@openwrt.org>
Fri, 10 Jun 2005 17:12:46 +0000 (17:12 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 10 Jun 2005 17:12:46 +0000 (17:12 +0000)
SVN-Revision: 1187

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/picocom/Config.in [new file with mode: 0644]
openwrt/package/picocom/Makefile [new file with mode: 0644]
openwrt/package/picocom/ipkg/picocom.control [new file with mode: 0644]

index c098c995d567064574fcb982e51018a924664c7e..aa7c6470ce62b7f324f3cf47b1d576b95bd9d75b 100644 (file)
@@ -113,10 +113,13 @@ source "package/libusb/Config.in"
 source "package/uclibc++/Config.in"
 source "package/zlib/Config.in"
 
-comment "Utilities ---"
+comment "Serial communications & terminal emulation ---"
 source "package/microcom/Config.in"
-source "package/usbutils/Config.in"  # lsusb
+source "package/picocom/Config.in"
 source "package/setserial/Config.in"
+
+comment "Utilities ---"
+source "package/usbutils/Config.in"  # lsusb
 source "package/strace/Config.in"
 
 # what are we going to do with both of you
index 183c44bf9fc11c74ea8016d134adc290745b847c..4399f2f14383182480a8fc6fa6b2ae4eee231dbe 100644 (file)
@@ -71,6 +71,7 @@ package-$(BR2_PACKAGE_OPENSWAN) += openswan
 package-$(BR2_PACKAGE_OPENVPN) += openvpn
 package-$(BR2_PACKAGE_OSIRIS) += osiris
 package-$(BR2_PACKAGE_PCRE) += pcre
+package-$(BR2_PACKAGE_PICOCOM) += picocom
 package-$(BR2_PACKAGE_PMACCT) += pmacct
 package-$(BR2_PACKAGE_POPT) += popt
 package-$(BR2_PACKAGE_PORTMAP) += portmap
diff --git a/openwrt/package/picocom/Config.in b/openwrt/package/picocom/Config.in
new file mode 100644 (file)
index 0000000..5ed558d
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_PICOCOM
+       tristate "picocom - minimal dumb-terminal emulation program"
+#      default m if CONFIG_DEVEL
+       default n
+       help
+         As its name suggests, picocom is a minimal dumb-terminal emulation 
+         program. It is, in principle, very much like minicom, only it's pico 
+         instead of mini! It was designed to serve as a simple, manual, modem 
+         configuration, testing, and debugging tool. It has also served (quite 
+         well) as a low-tech "terminal-window" to allow operator intervention 
+         in PPP connection scripts. It could also prove useful in many other 
+         similar tasks.
+         
+         http://efault.net/npat/hacks/picocom/
+         
\ No newline at end of file
diff --git a/openwrt/package/picocom/Makefile b/openwrt/package/picocom/Makefile
new file mode 100644 (file)
index 0000000..1f07c61
--- /dev/null
@@ -0,0 +1,33 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=picocom
+PKG_VERSION:=1.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=08fcc5f6bb9e7676a2569386d5ea9f70
+
+PKG_SOURCE_URL:=http://efault.net/npat/hacks/picocom/dist/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PICOCOM,picocom,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+               CFLAGS="$(TARGET_CFLAGS) -L$(STAGING_DIR)/usr/lib" \
+               picocom
+       touch $@
+
+$(IPKG_PICOCOM):
+       install -d -m0755 $(IDIR_PICOCOM)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/picocom $(IDIR_PICOCOM)/usr/bin/
+       $(RSTRIP) $(IDIR_PICOCOM)
+       $(IPKG_BUILD) $(IDIR_PICOCOM) $(PACKAGE_DIR)
diff --git a/openwrt/package/picocom/ipkg/picocom.control b/openwrt/package/picocom/ipkg/picocom.control
new file mode 100644 (file)
index 0000000..17e705f
--- /dev/null
@@ -0,0 +1,6 @@
+Package: picocom
+Priority: optional
+Section: console
+Maintainer: bugs@openwrt.org
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/picocom/
+Description: minimal dumb-terminal emulation program