ar71xx: add initial support for the Atheros DB120 board
authorGabor Juhos <juhosg@openwrt.org>
Thu, 7 Apr 2011 20:53:19 +0000 (20:53 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 7 Apr 2011 20:53:19 +0000 (20:53 +0000)
Signed-off-by: Jaiganesh Narayanan <jnarayanan@atheros.com>
SVN-Revision: 26518

target/linux/ar71xx/config-2.6.37
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-db120.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/machtype.h

index 35ed6d8ace648c1b2ff19bc424c2d8ca835a801f..13ce22bdceca420eeaa478496bfdc04bb2f9f7da 100644 (file)
@@ -16,6 +16,7 @@ CONFIG_AR71XX_MACH_AP81=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AP96=y
 CONFIG_AR71XX_MACH_AW_NR580=y
+CONFIG_AR71XX_MACH_DB120=y
 CONFIG_AR71XX_MACH_DIR_600_A1=y
 CONFIG_AR71XX_MACH_DIR_615_C1=y
 CONFIG_AR71XX_MACH_DIR_825_B1=y
index 78c4aa1c954276e97ab8ffb9af665fc8589bd7ed..79f308b13e14cf0f4f9143c77b4e905843f2ff79 100644 (file)
@@ -28,6 +28,13 @@ config AR71XX_MACH_AP96
        select AR71XX_DEV_USB
        default n
 
+config AR71XX_MACH_DB120
+       bool "Atheros DB120 board support"
+       select AR71XX_DEV_GPIO_BUTTONS
+       select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
+       default n
+
 config AR71XX_MACH_DIR_600_A1
        bool "D-Link DIR-600 rev. A1 support"
        select AR71XX_DEV_AP91_PCI if PCI
index 8ced1269e3b524de55417a86b46431d4d30a83a6..b0747b43970fefcbf8cec1558f1a1ba82642f369 100644 (file)
@@ -31,6 +31,7 @@ obj-$(CONFIG_AR71XX_MACH_AP81)                += mach-ap81.o
 obj-$(CONFIG_AR71XX_MACH_AP83)         += mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AP96)         += mach-ap96.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
+obj-$(CONFIG_AR71XX_MACH_DB120)        += mach-db120.o
 obj-$(CONFIG_AR71XX_MACH_DIR_600_A1)   += mach-dir-600-a1.o
 obj-$(CONFIG_AR71XX_MACH_DIR_615_C1)   += mach-dir-615-c1.o
 obj-$(CONFIG_AR71XX_MACH_DIR_825_B1)   += mach-dir-825-b1.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-db120.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-db120.c
new file mode 100644 (file)
index 0000000..aff108f
--- /dev/null
@@ -0,0 +1,121 @@
+/*
+ *  Atheros DB120 board (WASP SoC) support
+ *
+ *  Copyright (C) 2010-2011 Jaiganesh Narayanan <jnarayanan@atheros.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "machtype.h"
+#include "devices.h"
+#include "dev-m25p80.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-usb.h"
+
+#define DB120_GPIO_LED_USB     11
+#define DB120_GPIO_LED_WLAN_5G 12
+#define DB120_GPIO_LED_WLAN_2G 13
+#define DB120_GPIO_LED_STATUS  14
+#define DB120_GPIO_LED_WPS     15
+
+#define DB120_GPIO_BTN_SW1     16
+
+#define DB120_BUTTONS_POLL_INTERVAL    20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition db120_partitions[] = {
+       {
+               .name           = "u-boot",
+               .offset         = 0,
+               .size           = 0x040000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "u-boot-env",
+               .offset         = 0x040000,
+               .size           = 0x010000,
+       }, {
+               .name           = "rootfs",
+               .offset         = 0x050000,
+               .size           = 0x630000,
+       }, {
+               .name           = "uImage",
+               .offset         = 0x680000,
+               .size           = 0x160000,
+       }, {
+               .name           = "NVRAM",
+               .offset         = 0x7E0000,
+               .size           = 0x010000,
+       }, {
+               .name           = "ART",
+               .offset         = 0x7F0000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data db120_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .parts          = db120_partitions,
+       .nr_parts       = ARRAY_SIZE(db120_partitions),
+#endif
+};
+
+static struct gpio_led db120_leds_gpio[] __initdata = {
+       {
+               .name           = "db120:green:status",
+               .gpio           = DB120_GPIO_LED_STATUS,
+               .active_low     = 1,
+       }, {
+               .name           = "db120:green:wps",
+               .gpio           = DB120_GPIO_LED_WPS,
+               .active_low     = 1,
+       }, {
+               .name           = "db120:green:wlan-5g",
+               .gpio           = DB120_GPIO_LED_WLAN_5G,
+               .active_low     = 1,
+       }, {
+               .name           = "db120:green:wlan-2g",
+               .gpio           = DB120_GPIO_LED_WLAN_2G,
+               .active_low     = 1,
+       }, {
+               .name           = "db120:green:usb",
+               .gpio           = DB120_GPIO_LED_USB,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_button db120_gpio_buttons[] __initdata = {
+       {
+               .desc           = "sw1",
+               .type           = EV_KEY,
+               .code           = BTN_0,
+               .threshold      = 3,
+               .gpio           = DB120_GPIO_BTN_SW1,
+               .active_low     = 1,
+       }
+};
+
+static void __init db120_setup(void)
+{
+       ar71xx_add_device_usb();
+
+       ar71xx_add_device_m25p80(&db120_flash_data);
+
+       ar71xx_add_device_leds_gpio(-1, ARRAY_SIZE(db120_leds_gpio),
+                                       db120_leds_gpio);
+
+       ar71xx_add_device_gpio_buttons(-1, DB120_BUTTONS_POLL_INTERVAL,
+                                       ARRAY_SIZE(db120_gpio_buttons),
+                                       db120_gpio_buttons);
+}
+
+MIPS_MACHINE(AR71XX_MACH_DB120, "DB120", "Atheros DB120", db120_setup);
index 53de5b13fd357629798fcc78eccc21102d7eee65..e7e57956b22272bde9103fd1367eaf7a3d60c1c0 100644 (file)
@@ -66,6 +66,7 @@ enum ar71xx_mach_type {
        AR71XX_MACH_ZCN_1523H_5, /* Zcomax ZCN-1523H-5-xx */
        AR71XX_MACH_AP96,       /* Atheros AP96 */
        AR71XX_MACH_UBNT_UNIFI, /* Unifi */
+       AR71XX_MACH_DB120,      /* Atheros DB120 (AR934x based) */
 };
 
 #endif /* _AR71XX_MACHTYPE_H */