toolchain/gcc: fix build on arm with clang as host gcc replacement
authorFelix Fietkau <nbd@openwrt.org>
Thu, 15 May 2014 20:11:54 +0000 (20:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 15 May 2014 20:11:54 +0000 (20:11 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 40772

toolchain/gcc/common.mk

index af971ba78e31e878b4d14515228058210cb4f802..5dfbc488cd46d66ff1c8f9800c61f36be6645812 100644 (file)
@@ -95,6 +95,10 @@ endif
 
 GCC_CONFIGURE:= \
        SHELL="$(BASH)" \
+       $(if $(shell gcc --version 2>&1 | grep LLVM), \
+               CFLAGS="-O2 -fbracket-depth=512 -pipe" \
+               CXXFLAGS="-O2 -fbracket-depth=512 -pipe" \
+       ) \
        $(HOST_SOURCE_DIR)/configure \
                --with-bugurl=$(BUGURL) \
                --with-pkgversion="$(PKGVERSION)" \