ipv6-support: Fix default RA settings for dnsmasq
authorSteven Barth <cyrus@openwrt.org>
Sun, 23 Dec 2012 18:22:48 +0000 (18:22 +0000)
committerSteven Barth <cyrus@openwrt.org>
Sun, 23 Dec 2012 18:22:48 +0000 (18:22 +0000)
SVN-Revision: 34873

package/network/ipv6/ipv6-support/Makefile
package/network/ipv6/ipv6-support/files/support.sh

index 6bc3f79b395a242c3e8b344b354cf001222658e5..76c97c209818a106073677cb6ae00253d2e05d55 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipv6-support
-PKG_VERSION:=2012-12-22
+PKG_VERSION:=2012-12-23
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 8cd044f99004a7e68e11d47ca186b324b1bfa9ea..261ff1e8b396a231af740b1c46c4094f44ad9a3a 100644 (file)
@@ -438,12 +438,12 @@ enable_router() {
 
        if [ "$router_service" == "dnsmasq" ]; then
                local dnsmasq_opts
-               config_get dnsmasq_opts global dnsmasq_opts
-               [ -z "$dnsmasq_opts" ] && dnsmasq_opts="ra-stateful,ra-names"
+               config_get dnsmasq_opts "$network" dnsmasq_opts
+               [ -z "$dnsmasq_opts" ] && dnsmasq_opts="ra-names,24h"
 
                local conf="/var/etc/dnsmasq.d/ipv6-router-$network.conf"
                mkdir -p $(dirname $conf)
-               echo "dhcp-range=::1,constructor:$device,$dnsmasq_opts" > $conf
+               echo "dhcp-range=::00ff,::ffff,constructor:$device,$dnsmasq_opts" > $conf
                echo "enable-ra" >> $conf
                /etc/init.d/dnsmasq restart
        else