add pcmcia support for 2.4/brcm and serial_cs kernel module
authorNicolas Thill <nico@openwrt.org>
Tue, 15 Nov 2005 01:57:38 +0000 (01:57 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 15 Nov 2005 01:57:38 +0000 (01:57 +0000)
SVN-Revision: 2490

openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-pcmcia-serial.control [new file with mode: 0644]
openwrt/target/linux/linux-2.4/Makefile
openwrt/target/linux/linux-2.4/config/brcm

index 9d402130a5c5e9e64e02635dc960dad8d4917c2c..0c8d38a36836dafb7dc1d00c0e14c356b1235368 100644 (file)
@@ -634,6 +634,12 @@ config BR2_PACKAGE_KMOD_PCMCIA_CORE
        tristate
        default m
 
+config BR2_PACKAGE_KMOD_PCMCIA_SERIAL
+       prompt   "kmod-pcmcia-serial.............. PCMCIA/CardBus serial device support"
+       tristate
+       default m
+       depends BR2_PACKAGE_KMOD_PCMCIA_CORE
+
 comment "USB support"
 
 config BR2_PACKAGE_KMOD_USB
diff --git a/openwrt/target/linux/control/kmod-pcmcia-serial.control b/openwrt/target/linux/control/kmod-pcmcia-serial.control
new file mode 100644 (file)
index 0000000..7e8a03c
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-pcmcia-serial
+Priority: optional
+Section: sys
+Description: PCMCIA/CardBus serial device support
index 5a16a7ed6a8292d740be3933e23d56015bfae2b8..a42ba73d65e742dea7aace057fe7338638d45162 100644 (file)
@@ -287,6 +287,10 @@ $(eval $(call KMOD_template,PCMCIA_CORE,pcmcia-core,\
        $(MODULES_DIR)/kernel/drivers/pcmcia/yenta_socket.o \
 ,CONFIG_PCMCIA,,50,pcmcia_core))
 
+$(eval $(call KMOD_template,PCMCIA_SERIAL,pcmcia-serial,\
+       $(MODULES_DIR)/kernel/drivers/char/pcmcia/serial_cs.o \
+,CONFIG_PCMCIA_SERIAL_CS,kmod-pcmcia-core,51,serial_cs))
+
 
 # USB
 
index 5e7626523ec9eec4935844cbca467ed10b97bec5..3ddadba06ebcbdbba2f1e691b18104d7b397370b 100644 (file)
@@ -145,7 +145,11 @@ CONFIG_HOTPLUG=y
 #
 # PCMCIA/CardBus support
 #
-# CONFIG_PCMCIA is not set
+CONFIG_PCMCIA=m
+CONFIG_CARDBUS=y
+# CONFIG_TCIC is not set
+# CONFIG_I82092 is not set
+# CONFIG_I82365 is not set
 
 #
 # PCI Hotplug Support
@@ -695,6 +699,11 @@ CONFIG_SCSI_MULTI_LUN=y
 # CONFIG_SCSI_NSP32 is not set
 # CONFIG_SCSI_DEBUG is not set
 
+#
+# PCMCIA SCSI adapter support
+#
+# CONFIG_SCSI_PCMCIA is not set
+
 #
 # Fusion MPT device support
 #
@@ -834,6 +843,13 @@ CONFIG_WL=m
 # CONFIG_TMD_HERMES is not set
 # CONFIG_PCI_HERMES is not set
 
+#
+# Wireless Pcmcia cards support
+#
+# CONFIG_PCMCIA_HERMES is not set
+# CONFIG_AIRO_CS is not set
+# CONFIG_PCMCIA_ATMEL is not set
+
 #
 # Prism54 PCI/PCMCIA GT/Duette Driver - 802.11(a/b/g)
 #
@@ -853,6 +869,11 @@ CONFIG_SHAPER=m
 #
 # CONFIG_WAN is not set
 
+#
+# PCMCIA network device support
+#
+# CONFIG_NET_PCMCIA is not set
+
 #
 # Amateur Radio support
 #
@@ -994,6 +1015,12 @@ CONFIG_SOFT_WATCHDOG=y
 #
 # CONFIG_DRM is not set
 
+#
+# PCMCIA character devices
+#
+CONFIG_PCMCIA_SERIAL_CS=m
+# CONFIG_SYNCLINK_CS is not set
+
 #
 # File systems
 #