[toolchain] gcc: add --with-long-double-128 for SPARC toolchain
authorFlorian Fainelli <florian@openwrt.org>
Fri, 12 Oct 2012 14:42:41 +0000 (14:42 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 12 Oct 2012 14:42:41 +0000 (14:42 +0000)
This is required in order to build the final compiler.

SVN-Revision: 33739

toolchain/gcc/common.mk

index c18a330f343ed16e165a2e43b6118b9266a051aa..53e4635df4c39dc522a385b54c16fda0eb955e7f 100644 (file)
@@ -123,6 +123,7 @@ GCC_CONFIGURE:= \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
                $(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
+               $(if $(CONFIG_sparc),--with-long-double-128) \
 
 ifeq ($(CONFIG_GCC_LLVM),)
   GCC_BUILD_TARGET_LIBGCC:=y