package/grub: play it safe, cross compile everywhere
authorAlexandros C. Couloumbis <alex@ozo.com>
Wed, 7 Apr 2010 21:23:09 +0000 (21:23 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Wed, 7 Apr 2010 21:23:09 +0000 (21:23 +0000)
SVN-Revision: 20739

package/grub/Makefile

index 94695ec9708d6a1464cd726b39b0bb699158ca7b..338dbcac1de22b32dfb84c6a2ba77a9315dc3f38 100644 (file)
@@ -31,20 +31,10 @@ define Package/grub
   URL:=http://www.gnu.org/software/grub/
 endef
 
-ifeq ($(HOST_OS),Linux)
-  NATIVEGRUB-i386:=1
-  NATIVEGRUB-i686:=1
-  NATIVEGRUB:=$(NATIVEGRUB-$(HOST_ARCH))
-endif
-
-ifeq ($(NATIVEGRUB),)
 CONFIGURE_FLAGS:= \
        --target=$(GNU_TARGET_NAME) \
        --host=$(GNU_TARGET_NAME) \
        --build=$(GNU_HOST_NAME)
-else
-CONFIGURE_FLAGS:=
-endif
 
 ifneq ($(HOST_OS),Darwin)
 define Build/Configure