tools/mkimage: add back a fixed version of 040-include_order.patch to fix build error...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 18 Jun 2013 21:53:46 +0000 (21:53 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 18 Jun 2013 21:53:46 +0000 (21:53 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 36967

tools/mkimage/patches/040-include_order.patch [new file with mode: 0644]

diff --git a/tools/mkimage/patches/040-include_order.patch b/tools/mkimage/patches/040-include_order.patch
new file mode 100644 (file)
index 0000000..9432466
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -165,9 +165,9 @@ NOPEDOBJS := $(addprefix $(obj),$(NOPED_
+ # Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
+ #
+ HOSTCPPFLAGS =        -include $(SRCTREE)/include/libfdt_env.h \
+-              -idirafter $(SRCTREE)/include \
++              -I $(SRCTREE)/include \
+               -idirafter $(OBJTREE)/include2 \
+-              -idirafter $(OBJTREE)/include \
++              -I $(OBJTREE)/include \
+               -I $(SRCTREE)/lib/libfdt \
+               -I $(SRCTREE)/tools \
+               -DCONFIG_SYS_TEXT_BASE=$(CONFIG_SYS_TEXT_BASE) \