openssl does not compile with uml and arch x86_64
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 18 Jun 2012 23:54:08 +0000 (23:54 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 18 Jun 2012 23:54:08 +0000 (23:54 +0000)
Hi,

I found that openssl did not compile on the uml target under x86_64. The
attached patch should
correct this and is working for me. Is this the right way to do it?

thanks,
Thomas

SVN-Revision: 32443

package/openssl/Makefile

index a696dd7cd414752cff3d7f606f80eb8b387df5cb..7043aeeb1880cb051cf60e64a29a596f92457ffa 100644 (file)
@@ -82,11 +82,16 @@ else
   OPENSSL_OPTIONS += no-engines
 endif
 
-OPENSSL_OPTIONS += no-perlasm
+ifeq ($(CONFIG_x86_64),y)
+  OPENSSL_TARGET:=linux-x86_64
+else
+  OPENSSL_TARGET:=linux-openwrt
+  OPENSSL_OPTIONS+=no-perlasm no-sse2
+endif
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
-               ./Configure linux-openwrt \
+               ./Configure $(OPENSSL_TARGET) \
                        --prefix=/usr \
                        --openssldir=/etc/ssl \
                        $(TARGET_CPPFLAGS) \