modules/usb: cleanup remove old module names
authorJohn Crispin <john@openwrt.org>
Sat, 23 May 2015 15:28:26 +0000 (15:28 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 23 May 2015 15:28:26 +0000 (15:28 +0000)
delete cases for Kernel <3.10 (nop-usb-xceiv), <3.12 (phy-nop)

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 45733

package/kernel/linux/modules/usb.mk

index 589894bcd1a95b0aa976c7aa68748654aba3a262..f3c84e6f107972531bc9b1c480707e75645e37c8 100644 (file)
@@ -103,18 +103,8 @@ define KernelPackage/usb-phy-nop
   TITLE:=Support for USB NOP transceiver
   KCONFIG:=CONFIG_NOP_USB_XCEIV
   HIDDEN:=1
-ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/phy/phy-generic.ko),)
   FILES:=$(LINUX_DIR)/drivers/usb/phy/phy-generic.ko
   AUTOLOAD:=$(call AutoLoad,43,phy-generic)
-else
-ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/phy/phy-nop.ko),)
-  FILES:=$(LINUX_DIR)/drivers/usb/phy/phy-nop.ko
-  AUTOLOAD:=$(call AutoLoad,43,phy-nop)
-else
-  FILES:=$(LINUX_DIR)/drivers/usb/otg/nop-usb-xceiv.ko
-  AUTOLOAD:=$(call AutoLoad,43,nop-usb-xceiv)
-endif
-endif
   $(call AddDepends/usb)
 endef