kernel: fix kmod-usb2-omap usb module
authorJohn Crispin <john@openwrt.org>
Thu, 2 Apr 2015 14:31:44 +0000 (14:31 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 2 Apr 2015 14:31:44 +0000 (14:31 +0000)
CONFIG_MFD_OMAP_USB_HOST is needed for working USB on BeagleBoard

tested on BeagleBoard C4 (EBVBeagle)

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 45236

package/kernel/linux/modules/usb.mk

index bfe952ff7852ed21e4ab152d81d47419d9606cf1..38b75a32a9332576d879d6681074ae3e88fb64f1 100644 (file)
@@ -389,7 +389,9 @@ $(eval $(call KernelPackage,usb2-fsl))
 define KernelPackage/usb2-omap
   TITLE:=Support for USB2 for OMAP
   DEPENDS:=@TARGET_omap +kmod-usb-phy-nop +kmod-usb-phy-am335x +kmod-usb2
-  KCONFIG:=CONFIG_USB_EHCI_HCD_OMAP
+  KCONFIG:=\
+       CONFIG_MFD_OMAP_USB_HOST=y \
+       CONFIG_USB_EHCI_HCD_OMAP
   FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-omap.ko
   AUTOLOAD:=$(call AutoLoad,39,ehci-omap)
   $(call AddDepends/usb)