gcc: enable non-PIC for mips targets in gcc 4.4+ to reduce code size
authorFelix Fietkau <nbd@openwrt.org>
Mon, 20 Sep 2010 20:49:34 +0000 (20:49 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 20 Sep 2010 20:49:34 +0000 (20:49 +0000)
SVN-Revision: 23103

toolchain/gcc/common.mk

index 645cf60d1dad8299926574b9b25b62e08adda349..e2277207b8b4fe7f15c2eb609ff76e3c26f96f47 100644 (file)
@@ -122,6 +122,12 @@ GCC_CONFIGURE:= \
                $(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
                $(if $(CONFIG_GCC_VERSION_4_3_3_CS)$(CONFIG_GCC_VERSION_4_4_1_CS)$(CONFIG_GCC_VERSION_4_4_3_CS),--enable-poison-system-directories)
 
+ifneq ($(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),)
+  ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
+    GCC_CONFIGURE += --with-mips-plt
+  endif
+endif
+
 ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),)
   GCC_BUILD_TARGET_LIBGCC:=y
   GCC_CONFIGURE+= \