[package] broadcom-wl: remove an erroneous BUG() call in the glue driver
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 24 Feb 2012 13:36:46 +0000 (13:36 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 24 Feb 2012 13:36:46 +0000 (13:36 +0000)
SVN-Revision: 30709

package/broadcom-wl/Makefile
package/broadcom-wl/src/glue/wl_glue.c

index 0439f1f72f751aaf2122b4202aec4ae8f10c443d..a2bd679d16a92d2afa3bc660778c6cf97801410b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=broadcom-wl
 PKG_VERSION:=5.10.56.27.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)_$(ARCH).tar.bz2
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
index 638a65321a765ed1dbae641ca4526ad861f13dfd..0504232a96a9678fa97fa078fb0aaa5d7a7c4986 100644 (file)
@@ -235,12 +235,6 @@ struct device * wl_glue_get_dmadev(void *dev)
 {
        struct device *dma_dev;
 
-       if (!wl_glue_attached)
-       {
-               BUG();
-               return NULL;
-       }
-
        switch (active_bus_type)
        {
 #ifdef CONFIG_SSB