Added vnc-reflector, corrected typo in vpnc/Config.in added then to menuconfig
authorFlorian Fainelli <florian@openwrt.org>
Tue, 13 Dec 2005 10:22:15 +0000 (10:22 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 13 Dec 2005 10:22:15 +0000 (10:22 +0000)
SVN-Revision: 2648

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/vnc-reflector/Config.in [new file with mode: 0755]
openwrt/package/vnc-reflector/Makefile [new file with mode: 0755]
openwrt/package/vnc-reflector/ipkg/vnc-reflector.control [new file with mode: 0755]
openwrt/package/vnc-reflector/patches/01-honor_include_lib_path.patch [new file with mode: 0644]
openwrt/package/vpnc/Config.in

index b8f4d6b00cef7a2e0f4182a9f4283f32bd6595e5..5cd589491c2c91abaf562f55b66554e860f8f35d 100644 (file)
@@ -130,6 +130,7 @@ source "package/ttcp/Config.in"
 source "package/ulogd/Config.in"
 source "package/updatedd/Config.in"
 source "package/vgp/Config.in"
+source "package/vnc-reflector/Config.in"
 source "package/vpnc/Config.in"
 source "package/vrrpd/Config.in"
 source "package/vsftpd/Config.in"
index af04601fe2c27cc0ff6b65e0346fbb3758a2e5d9..f906df6074adff4491a8e7d5b7d73daec981ebf9 100644 (file)
@@ -206,6 +206,7 @@ package-$(BR2_PACKAGE_USTL) += ustl
 package-$(BR2_COMPILE_UTIL_LINUX) += util-linux
 package-$(BR2_PACKAGE_UDEV) += udev
 package-$(BR2_PACKAGE_VGP) += vgp
+package_$(BR2_PACKAGE_VNC_REFLECTOR) += vnc-reflector
 package-$(BR2_PACKAGE_VPNC) += vpnc
 package-$(BR2_PACKGE_VRRPD) += vrrpd
 package-$(BR2_PACKAGE_VTUN) += vtun
@@ -315,6 +316,7 @@ tcpdump-compile: libpcap-compile
 tinc-compile: zlib-compile openssl-compile liblzo-compile
 tor-compile: libevent-compile openssl-compile zlib-compile
 usbutils-compile: libusb-compile
+vnc-reflector-compile: jpeg-compile zlib-compile
 vpnc-compile: libgcrypt-compile libgpg-error-compile
 vtun-compile: zlib-compile openssl-compile liblzo-compile
 wificonf-compile: wireless-tools-compile nvram-compile
diff --git a/openwrt/package/vnc-reflector/Config.in b/openwrt/package/vnc-reflector/Config.in
new file mode 100755 (executable)
index 0000000..84a158c
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_VNC_REFLECTOR
+        tristate "vnc-reflector....................... VNC proxy for multiple clients"
+       default m if CONFIG_DEVEL
+       depends on BR2_PACKAGE_JPEG
+       depends on BR2_PACKAGE_ZLIB
+       help
+               VNC Reflector is a specialized VNC server which acts as a proxy sitting between real VNC server (a host) and a number of VNC clients. It was designed to work efficiently with large number of clients.
diff --git a/openwrt/package/vnc-reflector/Makefile b/openwrt/package/vnc-reflector/Makefile
new file mode 100755 (executable)
index 0000000..6d58abb
--- /dev/null
@@ -0,0 +1,31 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=vnc-reflector
+PKG_VERSION:=1.2.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=
+PKG_SOURCE_URL:=@SF/vnc-reflector
+PKG_SOURCE:=vnc_reflector-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/vnc_reflector
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,VNC_REFLECTOR,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) STAGING_DIR=$(STAGING_DIR) CC=$(TARGET_CC) -C $(PKG_BUILD_DIR)
+       install -d $(PKG_INSTALL_DIR)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/vncreflector $(PKG_INSTALL_DIR)/usr/sbin/
+       touch $@
+
+$(IPKG_VNC_REFLECTOR):
+       mkdir -p $(IDIR_VNC_REFLECTOR)
+       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VNC_REFLECTOR)/
+       $(RSTRIP) $(IDIR_VNC_REFLECTOR)
+       $(IPKG_BUILD) $(IDIR_VNC_REFLECTOR) $(PACKAGE_DIR)
diff --git a/openwrt/package/vnc-reflector/ipkg/vnc-reflector.control b/openwrt/package/vnc-reflector/ipkg/vnc-reflector.control
new file mode 100755 (executable)
index 0000000..293a0a0
--- /dev/null
@@ -0,0 +1,6 @@
+Package: vnc-reflector
+Depends: jpeg, zlib
+Section: net
+Architecture: mipsel
+Priority: optional
+Description: VNC Reflector is a specialized VNC server which acts as a proxy sitting between real VNC server (a host) and a number of VNC clients. It was designed to work efficiently with large number of clients.
diff --git a/openwrt/package/vnc-reflector/patches/01-honor_include_lib_path.patch b/openwrt/package/vnc-reflector/patches/01-honor_include_lib_path.patch
new file mode 100644 (file)
index 0000000..8bc04c2
--- /dev/null
@@ -0,0 +1,21 @@
+diff -urN orig/vnc_reflector/Makefile vnc_reflector/Makefile
+--- orig/vnc_reflector/Makefile        2003-04-16 19:32:42.000000000 +0200
++++ vnc_reflector/Makefile     2005-12-13 11:08:09.000000000 +0100
+@@ -14,7 +14,7 @@
+ #
+ # Variables you might want to edit: CFLAGS, CONFFLAGS
+-IFLAGS =      -I.
++IFLAGS =      -I. -I$(STAGING_DIR)/usr/include
+ # Production
+ CFLAGS =      -O2 $(IFLAGS)
+@@ -29,7 +29,7 @@
+ CONFFLAGS =   -DUSE_POLL
+ # Link with zlib and JPEG libraries
+-LDFLAGS =     -L/usr/local/lib -lz -ljpeg
++LDFLAGS =     -L$(STAGING_DIR)/usr/lib -lz -ljpeg
+ PROG =        vncreflector
index 2b3a42356eb10c5df62a04cea82e9307577337d3..03d909a9b0697898606b479e4af789a42e2b5f29 100755 (executable)
@@ -1,5 +1,5 @@
 config BR2_PACKAGE_VPNC
-       tristate "vpnc............................. client for cisco3000 VPN Concentrator."
+       tristate "vpnc............................. VPN client for Cisco 3000"
        default m if CONFIG_DEVEL
        depends on BR2_PACKAGE_KMOD_TUN
        depends on BR2_PACKAGE_LIBGPG_ERROR