[adm5120] add ids for Edimax BR-6104Wg boards
authorGabor Juhos <juhosg@openwrt.org>
Thu, 18 Oct 2007 07:40:01 +0000 (07:40 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 18 Oct 2007 07:40:01 +0000 (07:40 +0000)
SVN-Revision: 9342

target/linux/adm5120/files/arch/mips/adm5120/boards/edimax.c
target/linux/adm5120/files/arch/mips/adm5120/prom.c
target/linux/adm5120/image/lzma-loader/src/config.h
target/linux/adm5120/image/router_le.mk
target/linux/adm5120/patches-2.6.23/001-adm5120.patch
tools/firmware-utils/src/csysimg.h
tools/firmware-utils/src/mkcsysimg.c

index 6b7e7e696a7b3e1ab1377772c3c727020991b28f..e53e8361371e81009f35f6e32c613ed616a17839 100644 (file)
 #include <asm/gpio.h>
 
 #include <adm5120_board.h>
+#include <adm5120_irq.h>
 #include <adm5120_platform.h>
 
-static struct mtd_partition br6104k_partitions[] = {
+static struct adm5120_pci_irq br61xx_pci_irqs[] __initdata = {
+       PCIIRQ(2, 0, 1, ADM5120_IRQ_PCI0),
+};
+
+static struct mtd_partition br61xx_partitions[] = {
        {
                .name   = "admboot",
                .offset = 0,
@@ -54,31 +59,48 @@ static struct platform_device *br6104k_devices[] __initdata = {
        &adm5120_hcd_device,
 };
 
-static void __init br6104k_setup(void) {
+static struct platform_device *br61x4wg_devices[] __initdata = {
+       &adm5120_flash0_device,
+};
+
+static void __init br61xx_setup(void) {
        /* setup data for flash0 device */
-       adm5120_flash0_data.nr_parts = ARRAY_SIZE(br6104k_partitions);
-       adm5120_flash0_data.parts = br6104k_partitions;
+       adm5120_flash0_data.nr_parts = ARRAY_SIZE(br61xx_partitions);
+       adm5120_flash0_data.parts = br61xx_partitions;
 
        /* TODO: setup mac addresses, if possible */
 }
 
-unsigned char br6104k_vlans[6] = {
+unsigned char br61xx_vlans[6] = {
        0x41, 0x42, 0x44, 0x48, 0x50, 0x00
 };
 
 static struct adm5120_board br6104k_board __initdata = {
        .mach_type      = MACH_ADM5120_BR6104K,
-       .name           = "Edimax BR-6104K",
-       .board_setup    = br6104k_setup,
+       .name           = "Edimax BR-6104K/6104KP",
+       .board_setup    = br61xx_setup,
        .eth_num_ports  = 5,
-       .eth_vlans      = br6104k_vlans,
+       .eth_vlans      = br61xx_vlans,
        .num_devices    = ARRAY_SIZE(br6104k_devices),
        .devices        = br6104k_devices,
 };
 
+static struct adm5120_board br61x4wg_board __initdata = {
+       .mach_type      = MACH_ADM5120_BR61x4WG,
+       .name           = "Edimax BR-6104WG/6114WG",
+       .board_setup    = br61xx_setup,
+       .eth_num_ports  = 5,
+       .eth_vlans      = br61xx_vlans,
+       .num_devices    = ARRAY_SIZE(br61x4wg_devices),
+       .devices        = br61x4wg_devices,
+       .pci_nr_irqs    = ARRAY_SIZE(br61xx_pci_irqs),
+       .pci_irq_map    = br61xx_pci_irqs,
+};
+
 static int __init register_boards(void)
 {
        adm5120_board_register(&br6104k_board);
+       adm5120_board_register(&br61x4wg_board);
        return 0;
 }
 
index 2f6fb918c05b2e0d637446a42989ed4e78a52a7a..786668b8d06292a396f35ad44cb37951df0ba0e2 100644 (file)
@@ -62,6 +62,7 @@ static struct board_desc common_boards[] __initdata = {
        /* Edimax boards */
        DEFBOARD("BR-6104K",    MACH_ADM5120_BR6104K),
        DEFBOARD("BR-6104KP",   MACH_ADM5120_BR6104K),
+       DEFBOARD("BR-6104WG",   MACH_ADM5120_BR61x4WG),
        /* Infineon boards */
        DEFBOARD("EASY 5120P-ATA",      MACH_ADM5120_EASY5120PATA),
        DEFBOARD("EASY 5120-RT",        MACH_ADM5120_EASY5120RT),
index 310189c6d6fd3c38dd48caebd2f8a08d18644b7e..74ae9afa204d6851e14beb6df4f37d8943ab3900 100644 (file)
 #  define CONFIG_FLASH_SIZE    FLASH_2M
 #endif
 
+#if defined(CONFIG_BOARD_BR6104WG)
+#  define CONFIG_BOARD_NAME    "BR-6104WG"
+#  define CONFIG_FLASH_SIZE    FLASH_2M
+#endif
+
 /*
  * Infineon boards
  */
index f9109715999c485a3e0d4bf56085fcc54a45d4ca..ec7673f6e36363899dee61650064e739bce7729c 100644 (file)
@@ -203,6 +203,21 @@ define Image/Build/Board/BR6104K/Initramfs
        $(call Image/Build/LZMAKernel/Admboot,br-6104k,gz)
 endef
 
+#
+# Edimax BR-6104WG
+#
+define Image/Build/Board/BR6104WG
+       $(call Image/Build/Edimax,$(1),br-6104wg)
+endef
+
+define Image/Build/Board/BR6104WG/squashfs
+       $(call Image/Build/Board/BR6104WG,squashfs)
+endef
+
+define Image/Build/Board/BR6104WG/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,br-6104wg,gz)
+endef
+
 #
 # Infineon EASY 83000
 #
@@ -254,6 +269,7 @@ endef
 
 define Image/Build/Group/Edimax
        $(call Image/Build/Board/BR6104K/$(1))
+       $(call Image/Build/Board/BR6104WG/$(1))
 endef
 
 define Image/Build/Group/Infineon
index b197b3f6570cfe7e98620d25854642459358d385..c8586eb91bc79abc8f393d4a5b8b8273432894f4 100644 (file)
@@ -54,7 +54,7 @@ Index: linux-2.6.23/include/asm-mips/bootinfo.h
 ===================================================================
 --- linux-2.6.23.orig/include/asm-mips/bootinfo.h
 +++ linux-2.6.23/include/asm-mips/bootinfo.h
-@@ -208,6 +208,58 @@
+@@ -208,6 +208,59 @@
  #define MACH_GROUP_WINDRIVER   28     /* Windriver boards */
  #define MACH_WRPPMC             1
  
@@ -107,8 +107,9 @@ Index: linux-2.6.23/include/asm-mips/bootinfo.h
 +#define MACH_ADM5120_EASY5120RT 43    /* Infineon EASY 5120-RT */
 +#define MACH_ADM5120_EASY5120WVOIP 44 /* Infineon EASY 5120-WVoIP */
 +#define MACH_ADM5120_EASY83000        45      /* Infineon EASY-83000 */
-+#define MACH_ADM5120_BR6104K  46      /* Edimax BR-6104K */
++#define MACH_ADM5120_BR6104K  46      /* Edimax BR-6104K/BR-6104KP */
 +#define MACH_ADM5120_RB_192   47      /* Mikrotik RouterBOARD 192 */
++#define MACH_ADM5120_BR61x4WG 48      /* Edimax BR-6104Wg/BR-6114WG */
 +
  #define CL_SIZE                       COMMAND_LINE_SIZE
  
index 807c86713293220dd30c46dd18be427824bf7889..740a7b8910d9deb30043215c91f9aae18d03c189 100644 (file)
@@ -3,7 +3,7 @@
  *
  *  Copyright (C) 2007 Gabor Juhos <juhosg at openwrt.org>
  *
- *  This program was based on the code found in various Linux 
+ *  This program was based on the code found in various Linux
  *  source tarballs released by Edimax for it's devices.
  *  Original author: David Hsu <davidhsu@realtek.com.tw>
  *
 #define ADM_BOOT_SIG   "\x00\x60\x1A\x40"
 
 
-/* 
+/*
  * Generic signatures
  */
 #define SIG_CSYS       "CSYS"
 #define SIG_CONF       "HS\x00\x00"
 #define SIG_BOOT_RTL   "\x00\x00\x40\x21"
 
-/* 
+/*
  * Web page signatures
  */
 #define SIG_BR6104K    "WB4K"
 #define SIG_BR6104KP   "WBKP"
+#define SIG_BR6104Wg   "WBGW"
 #define SIG_BR6104IPC  "WBIP"
 #define SIG_BR6114WG   SIG_BR6104IPC
 #define SIG_BR6524K    "2-K-"
@@ -66,8 +67,8 @@
 #define SIG_XRT401D    SIG_BR6104K
 #define SIG_XRT402D    SIG_BR6524K
 
-/* 
- * CSYS image file header 
+/*
+ * CSYS image file header
  */
 struct csys_header {
        unsigned char sig[SIG_LEN];
index a1f9b742d838e4057cd8c84c7683c66b12b62528..7df27c48eb2f4b24c298fdc6ee5983474c4f49b9 100644 (file)
@@ -152,6 +152,7 @@ static struct board_info boards[] = {
        /* The original Edimax products */
        BOARD_ADM("BR-6104K", "Edimax BR-6104K", 2, SIG_BR6104K),
        BOARD_ADM("BR-6104KP", "Edimax BR-6104KP", 2, SIG_BR6104KP),
+       BOARD_ADM("BR-6104Wg", "Edimax BR-6104Wg", 2, SIG_BR6104Wg),
        BOARD_ADM("BR-6114WG", "Edimax BR-6114WG", 2, SIG_BR6114WG),
        BOARD_ADM("BR-6524K", "Edimax BR-6524K", 2, SIG_BR6524K),
        BOARD_ADM("BR-6524KP", "Edimax BR-6524KP", 2, SIG_BR6524KP),