Oops! I've copied r7557 instead of r7757, sorry
authorGabor Juhos <juhosg@openwrt.org>
Sat, 30 Jun 2007 15:21:35 +0000 (15:21 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 30 Jun 2007 15:21:35 +0000 (15:21 +0000)
SVN-Revision: 7799

target/linux/adm5120-2.6/patches/001-adm5120.patch [deleted file]
target/linux/adm5120-2.6/patches/002-adm5120_flash.patch [deleted file]
target/linux/adm5120-2.6/patches/003-adm5120_switch.patch [deleted file]
target/linux/adm5120-2.6/patches/004-adm5120_uart.patch [deleted file]
target/linux/adm5120-2.6/patches/005-adm5120_usb.patch [deleted file]
target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch [deleted file]
target/linux/adm5120-2.6/patches/007-adm5120_pci.patch [deleted file]
target/linux/adm5120-2.6/patches/100-mtd-myloder-partition-parser.patch [deleted file]
target/linux/adm5120-2.6/patches/101-mtd-mxflash.patch [deleted file]
target/linux/adm5120-2.6/patches/140-cmdline_hack.patch [deleted file]
target/linux/adm5120-2.6/patches/500-Nand.patch [deleted file]

diff --git a/target/linux/adm5120-2.6/patches/001-adm5120.patch b/target/linux/adm5120-2.6/patches/001-adm5120.patch
deleted file mode 100644 (file)
index 7012937..0000000
+++ /dev/null
@@ -1,89 +0,0 @@
-diff -urN linux-2.6.19.2/arch/mips/Kconfig linux-2.6.19.2.new/arch/mips/Kconfig
---- linux-2.6.19.2/arch/mips/Kconfig   2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2.new/arch/mips/Kconfig       2007-01-23 14:49:38.000000000 +0100
-@@ -12,6 +12,21 @@
-       prompt "System type"
-       default SGI_IP22
-
-+config MIPS_ADM5120
-+      bool "Support for ADM5120 SoC"
-+      select SYS_HAS_CPU_MIPS32_R1
-+      select DMA_NONCOHERENT
-+      select HW_HAS_PCI
-+      select IRQ_CPU
-+      select SYS_SUPPORTS_LITTLE_ENDIAN
-+      select SYS_SUPPORTS_BIG_ENDIAN
-+      select SYS_SUPPORTS_32BIT_KERNEL
-+      select GENERIC_GPIO
-+
-+config PCI_ADM5120
-+      bool "Add PCI control support for ADM5120"
-+      depends on MIPS_ADM5120 && PCI
-+
- config MIPS_MTX1
-       bool "4G Systems MTX-1 board"
-       select DMA_NONCOHERENT
-diff -urN linux-2.6.19.2/arch/mips/Makefile linux-2.6.19.2.new/arch/mips/Makefile
---- linux-2.6.19.2/arch/mips/Makefile  2007-01-23 14:02:57.000000000 +0100
-+++ linux-2.6.19.2.new/arch/mips/Makefile      2007-01-23 14:49:39.000000000 +0100
-@@ -165,6 +165,14 @@
- load-$(CONFIG_MACH_JAZZ)      += 0xffffffff80080000
-
- #
-+# ADMtek 5120
-+#
-+
-+core-$(CONFIG_MIPS_ADM5120)   += arch/mips/adm5120/
-+cflags-$(CONFIG_MIPS_ADM5120) += -Iinclude/asm-mips/mach-adm5120
-+load-$(CONFIG_MIPS_ADM5120)   += 0xffffffff80001000
-+
-+#
- # Common Alchemy Au1x00 stuff
- #
- core-$(CONFIG_SOC_AU1X00)     += arch/mips/au1000/common/
-diff -urN linux-2.6.19.2/include/asm-mips/bootinfo.h linux-2.6.19.2.new/include/asm-mips/bootinfo.h
---- linux-2.6.19.2/include/asm-mips/bootinfo.h 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2.new/include/asm-mips/bootinfo.h     2007-01-23 14:49:40.000000000 +0100
-@@ -212,6 +212,42 @@
- #define MACH_GROUP_NEC_EMMA2RH 25     /* NEC EMMA2RH (was 23)         */
- #define  MACH_NEC_MARKEINS    0       /* NEC EMMA2RH Mark-eins        */
-
-+/*
-+ * Valid machtype for group ADMtek ADM5120
-+ */
-+#define MACH_GROUP_ADM5120    23
-+#define MACH_ADM5120_UNKNOWN  0       /* Unknown board */
-+#define MACH_ADM5120_WP54G_WRT        1       /* Compex WP54G-WRT */
-+#define MACH_ADM5120_WP54G    2       /* Compex WP54G */
-+#define MACH_ADM5120_WP54AG   3       /* Compex WP54AG */
-+#define MACH_ADM5120_WPP54G   4       /* Compex WPP54G */
-+#define MACH_ADM5120_WPP54AG  5       /* Compex WPP54AG */
-+#define MACH_ADM5120_NP28G    6       /* Compex NP28G */
-+#define MACH_ADM5120_NP28GHS  7       /* Compex NP28G HotSpot */
-+#define MACH_ADM5120_NP27G    8       /* Compex NP27G */
-+#define MACH_ADM5120_WP54Gv1C 9       /* Compex WP54G version 1C */
-+#define MACH_ADM5120_RB_111   10      /* Mikrotik RouterBOARD 111 */
-+#define MACH_ADM5120_RB_112   11      /* Mikrotik RouterBOARD 112 */
-+#define MACH_ADM5120_RB_133   12      /* Mikrotik RouterBOARD 133 */
-+#define MACH_ADM5120_RB_133C  13      /* Mikrotik RouterBOARD 133c */
-+#define MACH_ADM5120_RB_150   14      /* Mikrotik RouterBOARD 150 */
-+#define MACH_ADM5120_RB_153   15      /* Mikrotik RouterBOARD 153 */
-+#define MACH_ADM5120_HS100    16      /* ZyXEL HomeSafe 100/100W */
-+#define MACH_ADM5120_P334     17      /* ZyXEL Prestige 334 */
-+#define MACH_ADM5120_P334U    18      /* ZyXEL Prestige 334U */
-+#define MACH_ADM5120_P334W    19      /* ZyXEL Prestige 334W */
-+#define MACH_ADM5120_P334WH   20      /* ZyXEL Prestige 334WH */
-+#define MACH_ADM5120_P334WHD  21      /* ZyXEL Prestige 334WHD */
-+#define MACH_ADM5120_P334WT   22      /* ZyXEL Prestige 334WT */
-+#define MACH_ADM5120_P335     23      /* ZyXEL Prestige 335/335WT */
-+#define MACH_ADM5120_P335PLUS 24      /* ZyXEL Prestige 335Plus */
-+#define MACH_ADM5120_P335U    25      /* ZyXEL Prestige 335U */
-+#define MACH_ADM5120_ES2108   26      /* ZyXEL Ethernet Switch 2108 */
-+#define MACH_ADM5120_ES2108F  27      /* ZyXEL Ethernet Switch 2108-F */
-+#define MACH_ADM5120_ES2108G  28      /* ZyXEL Ethernet Switch 2108-G */
-+#define MACH_ADM5120_ES2108LC 29      /* ZyXEL Ethernet Switch 2108-LC */
-+#define MACH_ADM5120_ES2108PWR        30      /* ZyXEL Ethernet Switch 2108-PWR */
-+
- #define CL_SIZE                       COMMAND_LINE_SIZE
-
- const char *get_system_type(void);
diff --git a/target/linux/adm5120-2.6/patches/002-adm5120_flash.patch b/target/linux/adm5120-2.6/patches/002-adm5120_flash.patch
deleted file mode 100644 (file)
index 503a495..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -urN linux-2.6.19.2/drivers/mtd/maps/Kconfig linux-2.6.19.2-adm5120/drivers/mtd/maps/Kconfig
---- linux-2.6.19.2/drivers/mtd/maps/Kconfig    2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/mtd/maps/Kconfig    2007-01-23 01:13:39.000000000 +0100
-@@ -622,5 +622,10 @@
-         This selection automatically selects the map_ram driver.
-+config MTD_ADM5120
-+      tristate "Map driver for ADMtek ADM5120 boards"
-+      depends on MIPS_ADM5120
-+      select MTD_CFI_AMDSTD
-+
- endmenu
-diff -urN linux-2.6.19.2/drivers/mtd/maps/Makefile linux-2.6.19.2-adm5120/drivers/mtd/maps/Makefile
---- linux-2.6.19.2/drivers/mtd/maps/Makefile   2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/mtd/maps/Makefile   2007-01-23 01:20:52.000000000 +0100
-@@ -43,6 +43,7 @@
- obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
- obj-$(CONFIG_MTD_PCI)         += pci.o
- obj-$(CONFIG_MTD_ALCHEMY)       += alchemy-flash.o
-+obj-$(CONFIG_MTD_ADM5120)             += adm5120_mtd.o
- obj-$(CONFIG_MTD_LASAT)               += lasat.o
- obj-$(CONFIG_MTD_AUTCPU12)    += autcpu12-nvram.o
- obj-$(CONFIG_MTD_EDB7312)     += edb7312.o
diff --git a/target/linux/adm5120-2.6/patches/003-adm5120_switch.patch b/target/linux/adm5120-2.6/patches/003-adm5120_switch.patch
deleted file mode 100644 (file)
index f6fec30..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -urN linux-2.6.19.2/drivers/net/Kconfig linux-2.6.19.2-adm5120/drivers/net/Kconfig
---- linux-2.6.19.2/drivers/net/Kconfig 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/net/Kconfig 2007-01-23 01:13:39.000000000 +0100
-@@ -450,6 +450,10 @@
-         If you have an Alchemy Semi AU1X00 based system
-         say Y.  Otherwise, say N.
-+config MIPS_ADM5120_ENET
-+      tristate "MIPS ADM5120 Ethernet switch support"
-+      depends on NET_ETHERNET && MIPS_ADM5120
-+
- config NET_SB1250_MAC
-       tristate "SB1250 Ethernet support"
-       depends on NET_ETHERNET && SIBYTE_SB1xxx_SOC
-diff -urN linux-2.6.19.2/drivers/net/Makefile linux-2.6.19.2-adm5120/drivers/net/Makefile
---- linux-2.6.19.2/drivers/net/Makefile        2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/net/Makefile        2007-01-23 01:13:39.000000000 +0100
-@@ -164,6 +164,7 @@
- # This is also a 82596 and should probably be merged
- obj-$(CONFIG_LP486E) += lp486e.o
-+obj-$(CONFIG_MIPS_ADM5120_ENET) += adm5120sw.o
- obj-$(CONFIG_ETH16I) += eth16i.o
- obj-$(CONFIG_ZORRO8390) += zorro8390.o 8390.o
- obj-$(CONFIG_HPLANCE) += hplance.o 7990.o
diff --git a/target/linux/adm5120-2.6/patches/004-adm5120_uart.patch b/target/linux/adm5120-2.6/patches/004-adm5120_uart.patch
deleted file mode 100644 (file)
index 6f2ef7b..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-diff -urN linux-2.6.19.2/drivers/serial/Kconfig linux-2.6.19.2-adm5120/drivers/serial/Kconfig
---- linux-2.6.19.2/drivers/serial/Kconfig       2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/serial/Kconfig       2007-01-23 01:13:39.000000000 +0100
-@@ -246,6 +246,22 @@
-
- comment "Non-8250 serial port support"
-
-+config SERIAL_ADM5120
-+       bool "ADM5120 serial port support"
-+       depends on MIPS_ADM5120
-+       select SERIAL_CORE
-+       select SERIAL_CORE_CONSOLE
-+       help
-+         Driver for the on chip UARTs on the ADM5120 SoC
-+
-+config ADM5120_NR_UARTS
-+       int "Maximum number of ADM5120 serial ports"
-+       depends on SERIAL_ADM5120
-+       default "2"
-+       ---help---
-+         Set this to the number of serial ports you want the driver to
-+         support.
-+
- config SERIAL_AMBA_PL010
-        tristate "ARM AMBA PL010 serial port support"
-        depends on ARM_AMBA && (BROKEN || !ARCH_VERSATILE)
-diff -urN linux-2.6.19.2/drivers/serial/Makefile linux-2.6.19.2-adm5120/drivers/serial/Makefile
---- linux-2.6.19.2/drivers/serial/Makefile     2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/serial/Makefile     2007-01-23 01:21:45.000000000 +0100
-@@ -20,6 +20,7 @@
- obj-$(CONFIG_SERIAL_8250_HUB6) += 8250_hub6.o
- obj-$(CONFIG_SERIAL_8250_MCA) += 8250_mca.o
- obj-$(CONFIG_SERIAL_8250_AU1X00) += 8250_au1x00.o
-+obj-$(CONFIG_SERIAL_ADM5120) += adm5120_uart.o
- obj-$(CONFIG_SERIAL_AMBA_PL010) += amba-pl010.o
- obj-$(CONFIG_SERIAL_AMBA_PL011) += amba-pl011.o
- obj-$(CONFIG_SERIAL_CLPS711X) += clps711x.o
-diff -urN linux-2.6.19.2/include/linux/serial_core.h linux-2.6.19.2-adm5120/include/linux/serial_core.h
---- linux-2.6.19.2/include/linux/serial_core.h 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/include/linux/serial_core.h 2007-01-23 01:13:39.000000000 +0100
-@@ -133,6 +133,9 @@
- #define PORT_S3C2412  73
-+/* ADMtek ADM5120 SoC */
-+#define PORT_ADM5120  68
-+
- #ifdef __KERNEL__
- #include <linux/compiler.h>
diff --git a/target/linux/adm5120-2.6/patches/005-adm5120_usb.patch b/target/linux/adm5120-2.6/patches/005-adm5120_usb.patch
deleted file mode 100644 (file)
index 40e4fbe..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -urN linux-2.6.19.2/drivers/usb/core/hub.c linux-2.6.19.2-adm5120/drivers/usb/core/hub.c
---- linux-2.6.19.2/drivers/usb/core/hub.c      2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/usb/core/hub.c      2007-01-23 01:13:39.000000000 +0100
-@@ -2156,6 +2156,8 @@
-                                       USB_DT_DEVICE << 8, 0,
-                                       buf, GET_DESCRIPTOR_BUFSIZE,
-                                       (i ? USB_CTRL_GET_TIMEOUT : 1000));
-+printk(KERN_CRIT "usb_control_msg: %d %d %d (%d)\n", r, buf->bMaxPacketSize0,
-+buf->bDescriptorType, USB_DT_DEVICE);
-                               switch (buf->bMaxPacketSize0) {
-                               case 8: case 16: case 32: case 64: case 255:
-                                       if (buf->bDescriptorType ==
-diff -urN linux-2.6.19.2/drivers/usb/host/Kconfig linux-2.6.19.2-adm5120/drivers/usb/host/Kconfig
---- linux-2.6.19.2/drivers/usb/host/Kconfig    2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/usb/host/Kconfig    2007-01-23 01:13:39.000000000 +0100
-@@ -192,3 +192,6 @@
-         To compile this driver as a module, choose M here: the
-         module will be called "sl811_cs".
-+config USB_ADM5120_HCD
-+      tristate "ADM5120 HCD support"
-+      depends on USB && MIPS_ADM5120
-diff -urN linux-2.6.19.2/drivers/usb/host/Makefile linux-2.6.19.2-adm5120/drivers/usb/host/Makefile
---- linux-2.6.19.2/drivers/usb/host/Makefile   2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/usb/host/Makefile   2007-01-23 01:13:39.000000000 +0100
-@@ -16,3 +16,4 @@
- obj-$(CONFIG_USB_SL811_CS)    += sl811_cs.o
- obj-$(CONFIG_USB_U132_HCD)    += u132-hcd.o
- obj-$(CONFIG_ETRAX_ARCH_V10)  += hc_crisv10.o
-+obj-$(CONFIG_USB_ADM5120_HCD) += adm5120-hcd.o
-diff -urN linux-2.6.19.2/drivers/usb/Kconfig linux-2.6.19.2-adm5120/drivers/usb/Kconfig
---- linux-2.6.19.2/drivers/usb/Kconfig 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/usb/Kconfig 2007-01-23 01:13:39.000000000 +0100
-@@ -91,8 +91,6 @@
- source "drivers/usb/net/Kconfig"
--source "drivers/usb/mon/Kconfig"
--
- comment "USB port drivers"
-       depends on USB
-diff -urN linux-2.6.19.2/drivers/usb/Makefile linux-2.6.19.2-adm5120/drivers/usb/Makefile
---- linux-2.6.19.2/drivers/usb/Makefile        2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/usb/Makefile        2007-01-23 01:22:18.000000000 +0100
-@@ -17,6 +17,7 @@
- obj-$(CONFIG_USB_U132_HCD)    += host/
- obj-$(CONFIG_ETRAX_USB_HOST)  += host/
- obj-$(CONFIG_USB_OHCI_AT91)   += host/
-+obj-$(CONFIG_USB_ADM5120_HCD)         += host/
- obj-$(CONFIG_USB_ACM)         += class/
- obj-$(CONFIG_USB_PRINTER)     += class/
diff --git a/target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch b/target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch
deleted file mode 100644 (file)
index 593743d..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -urN linux-2.6.19.2/drivers/char/Kconfig linux-2.6.19.2-adm5120/drivers/char/Kconfig
---- linux-2.6.19.2/drivers/char/Kconfig        2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/char/Kconfig        2007-01-23 01:13:39.000000000 +0100
-@@ -1034,7 +1034,9 @@
-         The mmtimer device allows direct userspace access to the
-         Altix system timer.
--source "drivers/char/tpm/Kconfig"
-+config ADM5120_GPIO
-+      tristate "ADM5120 GPIO"
-+      depends on MIPS_ADM5120
- config TELCLOCK
-       tristate "Telecom clock driver for MPBL0010 ATCA SBC"
-diff -urN linux-2.6.19.2/drivers/char/Makefile linux-2.6.19.2-adm5120/drivers/char/Makefile
---- linux-2.6.19.2/drivers/char/Makefile       2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-adm5120/drivers/char/Makefile       2007-01-23 01:20:01.000000000 +0100
-@@ -90,6 +90,7 @@
- obj-$(CONFIG_GPIO_VR41XX)     += vr41xx_giu.o
- obj-$(CONFIG_TANBAC_TB0219)   += tb0219.o
- obj-$(CONFIG_TELCLOCK)                += tlclk.o
-+obj-$(CONFIG_ADM5120_GPIO)    += adm5120_gpio.o
- obj-$(CONFIG_WATCHDOG)                += watchdog/
- obj-$(CONFIG_MWAVE)           += mwave/
diff --git a/target/linux/adm5120-2.6/patches/007-adm5120_pci.patch b/target/linux/adm5120-2.6/patches/007-adm5120_pci.patch
deleted file mode 100644 (file)
index 25ec59a..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -urN linux-2.6.21.1/arch/mips/pci/Makefile linux-2.6.21.1-adm5120/arch/mips/pci/Makefile
---- linux-2.6.21.1/arch/mips/pci/Makefile      2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.21.1-adm5120/arch/mips/pci/Makefile      2007-01-23 14:49:40.000000000 +0100
-@@ -53,3 +53,4 @@
- obj-$(CONFIG_VICTOR_MPC30X)   += fixup-mpc30x.o
- obj-$(CONFIG_ZAO_CAPCELLA)    += fixup-capcella.o
- obj-$(CONFIG_WR_PPMC)         += fixup-wrppmc.o
-+obj-$(CONFIG_PCI_ADM5120)     += fixup-adm5120.o ops-adm5120.o pci-adm5120.o
---- linux-2.6.21.1.old/include/linux/pci_ids.h 2007-04-27 23:49:26.000000000 +0200
-+++ linux-2.6.21.1/include/linux/pci_ids.h     2007-05-31 09:36:56.000000000 +0200
-@@ -1701,6 +1701,9 @@
- #define PCI_VENDOR_ID_ESDGMBH         0x12fe
- #define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
-+#define PCI_VENDOR_ID_ADMTEK          0x1317
-+#define PCI_DEVICE_ID_ADMTEK_ADM5120  0x5120
-+
- #define PCI_VENDOR_ID_SIIG            0x131f
- #define PCI_SUBVENDOR_ID_SIIG         0x131f
- #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000
diff --git a/target/linux/adm5120-2.6/patches/100-mtd-myloder-partition-parser.patch b/target/linux/adm5120-2.6/patches/100-mtd-myloder-partition-parser.patch
deleted file mode 100644 (file)
index 81ec37d..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -Nur linux-2.6.19.2/drivers/mtd/Kconfig.old linux-2.6.19.2/drivers/mtd/Kconfig
---- linux-2.6.19.2/drivers/mtd/Kconfig.old     2007-03-25 08:13:02.000000000 +0200
-+++ linux-2.6.19.2/drivers/mtd/Kconfig 2007-03-26 13:37:47.000000000 +0200
-@@ -157,6 +157,22 @@
-         for your particular device. It won't happen automatically. The
-         'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
-+config MTD_MYLOADER_PARTS
-+      tristate "MyLoader partition parsing"
-+      depends on MIPS_ADM5120 && MTD_PARTITIONS
-+      ---help---
-+        MyLoader is a bootloader which allows the user to define partitions
-+        in flash devices, by putting a table in the second erase block
-+        on the device, similar to a partition table. This table gives the 
-+        offsets and lengths of the user defined partitions.
-+
-+        If you need code which can detect and parse these tables, and
-+        register MTD 'partitions' corresponding to each image detected,
-+        enable this option.
-+
-+        You will still need the parsing functions to be called by the driver
-+        for your particular device. It won't happen automatically.
-+
- comment "User Modules And Translation Layers"
-       depends on MTD
-diff -Nur linux-2.6.19.2/drivers/mtd/Makefile.old linux-2.6.19.2/drivers/mtd/Makefile
---- linux-2.6.19.2/drivers/mtd/Makefile.old    2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2/drivers/mtd/Makefile        2007-03-26 13:28:23.000000000 +0200
-@@ -12,6 +12,7 @@
- obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
- obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
- obj-$(CONFIG_MTD_AFS_PARTS)   += afs.o
-+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
- # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_CHAR)                += mtdchar.o
diff --git a/target/linux/adm5120-2.6/patches/101-mtd-mxflash.patch b/target/linux/adm5120-2.6/patches/101-mtd-mxflash.patch
deleted file mode 100755 (executable)
index 754a91e..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- linux-2.6.19.2/drivers/mtd/chips/Kconfig.old       2007-01-11 03:10:36.000000000 +0800
-+++ linux-2.6.19.2/drivers/mtd/chips/Kconfig   2007-03-29 14:43:32.000000000 +0800
-@@ -199,6 +199,14 @@
-         provides support for one of those command sets, used on chips
-         including the AMD Am29LV320.
-+config MTD_CFI_AMDSTD_FORCE_BOTTOM_BOOT
-+      bool "Force bottom boot for Macronix flash chips"
-+      depends on MTD_CFI_AMDSTD
-+      help
-+        Some Macronix flash chips have wrong CFI info, and the driver may
-+        detect the type incorrectly. Select this if the chip part number
-+        ends with BTC.
-+
- config MTD_CFI_STAA
-       tristate "Support for ST (Advanced Architecture) flash chips"
-       depends on MTD_GEN_PROBE
---- linux-2.6.19.2/drivers/mtd/chips/cfi_cmdset_0002.c.old     2007-03-22 16:14:56.000000000 +0800
-+++ linux-2.6.19.2/drivers/mtd/chips/cfi_cmdset_0002.c 2007-03-29 14:07:28.000000000 +0800
-@@ -320,6 +320,11 @@
-               cfi_tell_features(extp);
- #endif
-+#ifdef CONFIG_MTD_CFI_AMDSTD_FORCE_BOTTOM_BOOT
-+              extp->TopBottom = 2;
-+              bootloc = extp->TopBottom;
-+#endif
-+
-               bootloc = extp->TopBottom;
-               if ((bootloc != 2) && (bootloc != 3)) {
-                       printk(KERN_WARNING "%s: CFI does not contain boot "
diff --git a/target/linux/adm5120-2.6/patches/140-cmdline_hack.patch b/target/linux/adm5120-2.6/patches/140-cmdline_hack.patch
deleted file mode 100644 (file)
index 23f377c..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -ur linux.old/arch/mips/kernel/head.S linux.dev/arch/mips/kernel/head.S
---- linux.old/arch/mips/kernel/head.S  2006-12-06 17:30:27.000000000 +0100
-+++ linux.dev/arch/mips/kernel/head.S  2006-12-06 18:34:43.000000000 +0100
-@@ -129,15 +129,20 @@
- #endif
-       .endm
--
-       j kernel_entry
-       nop
--
-+      nop
-+      
-       /*
-        * Reserved space for exception handlers.
-        * Necessary for machines which link their kernels at KSEG0.
-+       * Use as temporary storage for the kernel command line, so that it
-+       * can be updated easily without having to relink the kernel.
-        */
--      .align 10
-+       
-+EXPORT(_image_cmdline)
-+      .ascii "CMDLINE:"
-+      .align 10
- EXPORT(stext)                                 # used for profiling
- EXPORT(_stext)
diff --git a/target/linux/adm5120-2.6/patches/500-Nand.patch b/target/linux/adm5120-2.6/patches/500-Nand.patch
deleted file mode 100644 (file)
index 05beb20..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/drivers/mtd/nand/Kconfig b/drivers/mtd/nand/Kconfig
-index cfe288a..c528024 100644
---- a/drivers/mtd/nand/Kconfig
-+++ b/drivers/mtd/nand/Kconfig
-@@ -55,6 +55,12 @@ config MTD_NAND_TOTO
-       help
-         Support for NAND flash on Texas Instruments Toto platform.
-+config MTD_NAND_RB100
-+      tristate "NAND Flash device on RB100 board"
-+      depends on MTD_NAND
-+      help
-+        Support for NAND flash on RB100 platform.
-+
- config MTD_NAND_IDS
-       tristate
-diff --git a/drivers/mtd/nand/Makefile b/drivers/mtd/nand/Makefile
-index 4174202..2be57c1 100644
---- a/drivers/mtd/nand/Makefile
-+++ b/drivers/mtd/nand/Makefile
-@@ -8,6 +8,7 @@ obj-$(CONFIG_MTD_NAND_IDS)             += nand_ids.
- obj-$(CONFIG_MTD_NAND_SPIA)           += spia.o
- obj-$(CONFIG_MTD_NAND_TOTO)           += toto.o
-+obj-$(CONFIG_MTD_NAND_RB100)          += rbmipsnand.o
- obj-$(CONFIG_MTD_NAND_AUTCPU12)               += autcpu12.o
- obj-$(CONFIG_MTD_NAND_EDB7312)                += edb7312.o
- obj-$(CONFIG_MTD_NAND_AU1550)         += au1550nd.o