adds mountd. There is still much space for improvement, static mounts and fstab are...
authorJohn Crispin <john@openwrt.org>
Sun, 4 Oct 2009 14:01:17 +0000 (14:01 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 4 Oct 2009 14:01:17 +0000 (14:01 +0000)
SVN-Revision: 17853

package/kernel/modules/fs.mk
package/mountd/Makefile [new file with mode: 0644]
package/mountd/files/mountd.config [new file with mode: 0644]
package/mountd/files/mountd.init [new file with mode: 0755]

index bd97a089d49e6bbd286f257b359b89072ca26445..9c7fa17d2132c7ee14f2f40a461be0f8060d648b 100644 (file)
@@ -378,6 +378,20 @@ endef
 
 $(eval $(call KernelPackage,fs-btrfs))
 
+define KernelPackage/fs-autofs4
+  SUBMENU:=$(FS_MENU)
+  TITLE:=AUTOFS4 filesystem support
+  KCONFIG:=CONFIG_AUTOFS4_FS 
+  FILES:=$(LINUX_DIR)/fs/autofs4/autofs4.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,autofs4)
+endef
+
+define KernelPackage/fs-autofs4/description
+  Kernel module for AutoFS4 support
+endef
+
+$(eval $(call KernelPackage,fs-autofs4))
+
 
 define KernelPackage/nls-base
   SUBMENU:=$(FS_MENU)
diff --git a/package/mountd/Makefile b/package/mountd/Makefile
new file mode 100644 (file)
index 0000000..5463384
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright (C) 2009 OpenWrt.org
+# All rights reserved.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mountd
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_MD5SUM:=b77253ee4321d24d200fffc4f7ca3d15
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/mountd
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=OpenWrt automount daemon
+  DEPENDS:=@USB_SUPPORT +uci +kmod-usb-storage +kmod-fs-autofs4
+  URL:=http://www.openwrt.org
+endef
+
+define Package/mountd/description
+  openwrt automount daemon
+endef
+
+define Build/Compile
+       $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(PKG_BUILD_DIR)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Package/mountd/install
+       $(INSTALL_DIR) $(1)/sbin/ $(1)/etc/config/ $(1)/etc/init.d/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mountd $(1)/sbin/
+       $(INSTALL_BIN) ./files/mountd.config $(1)/etc/config/mountd
+       $(INSTALL_DATA) ./files/mountd.init $(1)/etc/init.d/mountd
+endef
+
+$(eval $(call BuildPackage,mountd))
+
diff --git a/package/mountd/files/mountd.config b/package/mountd/files/mountd.config
new file mode 100644 (file)
index 0000000..5610129
--- /dev/null
@@ -0,0 +1,3 @@
+config mountd mountd
+       option  timeout         60
+       option  path            /tmp/mounts/
diff --git a/package/mountd/files/mountd.init b/package/mountd/files/mountd.init
new file mode 100755 (executable)
index 0000000..b861b5d
--- /dev/null
@@ -0,0 +1,12 @@
+#!/bin/sh /etc/rc.common
+START=80
+
+start()
+{
+       /sbin/mountd
+}
+
+stop()
+{
+       killall mountd
+}