lua: use float instead of double, reduces the gc data structure size by 4 byte =...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 26 Oct 2009 03:01:12 +0000 (03:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 26 Oct 2009 03:01:12 +0000 (03:01 +0000)
SVN-Revision: 18159

package/lua/Makefile
package/lua/patches/010-lua-5.1.3-lnum-full-260308.patch

index b418b303efeff4fb1171eeaebdebc61005d09d04..4589cfed2cffadb37a08f00f0f5e901918d0f9d6 100644 (file)
@@ -83,7 +83,7 @@ endef
 define Build/Configure
 endef
 
-TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC)
+TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC) -std=gnu99
 
 ifneq ($(CONFIG_USE_EGLIBC),)
   ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)
index 32c39f3b7c63c9954b90129fb0309c2e70903715..f8d8fc7f1bb90bfb3e1ad996c6909a5e73647213 100644 (file)
@@ -1887,7 +1887,7 @@ Index: lua-5.1.4/src/lnum_config.h
 +** Default number modes
 +*/
 +#if (!defined LNUM_DOUBLE) && (!defined LNUM_FLOAT) && (!defined LNUM_LDOUBLE)
-+# define LNUM_DOUBLE
++# define LNUM_FLOAT
 +#endif
 +#if (!defined LNUM_INT16) && (!defined LNUM_INT32) && (!defined LNUM_INT64)
 +# define LNUM_INT32