[package] nvram: handle nvram at varying offsets within the eraseblock (fixes Edimax...
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 19 Jul 2010 22:20:07 +0000 (22:20 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 19 Jul 2010 22:20:07 +0000 (22:20 +0000)
SVN-Revision: 22299

package/nvram/Makefile
package/nvram/src/cli.c
package/nvram/src/nvram.c
package/nvram/src/nvram.h

index c47f1c7bbb87feac805905b5447dae642b28dd05..7fc9cc8a41b8ec9b1d8f9a105a4825e48953190b 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nvram
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index 44d4b88fdee69d68447d59bc85b573ff1c6f4636..66ef904885854894b3d9dda6b40a1bd3e5c832f2 100644 (file)
@@ -111,6 +111,7 @@ static int do_info(nvram_handle_t *nvram)
        /* Show info */
        printf("Magic:         0x%08X\n",   hdr->magic);
        printf("Length:        0x%08X\n",   hdr->len);
+       printf("Offset:        0x%08X\n",   nvram->offset);
 
        printf("CRC8:          0x%02X (calculated: 0x%02X)\n",
                hdr->crc_ver_init & 0xFF, crc);
index 7ab8c81ab0c489616af66aaa2ce2a3f0a07fcc7e..a0bc006d15322540978f6496c98f8c360ab7d0dd 100644 (file)
@@ -142,7 +142,7 @@ static int _nvram_rehash(nvram_handle_t *h)
 /* Get nvram header. */
 nvram_header_t * nvram_header(nvram_handle_t *h)
 {
-       return (nvram_header_t *) &h->mmap[NVRAM_START(nvram_erase_size)];
+       return (nvram_header_t *) &h->mmap[h->offset];
 }
 
 /* Get the value of an NVRAM variable. */
@@ -337,10 +337,12 @@ int nvram_commit(nvram_handle_t *h)
 /* Open NVRAM and obtain a handle. */
 nvram_handle_t * nvram_open(const char *file, int rdonly)
 {
+       int i;
        int fd;
        char *mtd = NULL;
        nvram_handle_t *h;
        nvram_header_t *header;
+       int offset = -1;
 
        /* If erase size or file are undefined then try to define them */
        if( (nvram_erase_size == 0) || (file == NULL) )
@@ -361,15 +363,28 @@ nvram_handle_t * nvram_open(const char *file, int rdonly)
 
                if( mmap_area != MAP_FAILED )
                {
-                       memset(mmap_area, 0xFF, NVRAM_START(nvram_erase_size));
+                       for( i = 0; i <= ((nvram_erase_size - NVRAM_SPACE) / sizeof(uint32_t)); i++ )
+                       {
+                               if( ((uint32_t *)mmap_area)[i] == NVRAM_MAGIC )
+                               {
+                                       offset = i * sizeof(uint32_t);
+                                       break;
+                               }
+                       }
 
-                       if((h = (nvram_handle_t *) malloc(sizeof(nvram_handle_t))) != NULL)
+                       if( offset < 0 )
+                       {
+                               free(mtd);
+                               return NULL;
+                       }
+                       else if( (h = malloc(sizeof(nvram_handle_t))) != NULL )
                        {
                                memset(h, 0, sizeof(nvram_handle_t));
 
                                h->fd     = fd;
                                h->mmap   = mmap_area;
                                h->length = nvram_erase_size;
+                               h->offset = offset;
 
                                header = nvram_header(h);
 
index e3d64613d488c1842429f9e0bfe010415fc5bfe7..c72f67e9a8a717568a89b9a94f73f90ab1e1170f 100644 (file)
@@ -46,7 +46,8 @@ struct nvram_tuple {
 struct nvram_handle {
        int fd;
        char *mmap;
-       unsigned long length;
+       unsigned int length;
+       unsigned int offset;
        struct nvram_tuple *nvram_hash[257];
        struct nvram_tuple *nvram_dead;
 };
@@ -113,7 +114,6 @@ char * nvram_find_staging(void);
 
 /* NVRAM constants */
 #define NVRAM_SPACE                    0x8000
-#define NVRAM_START(x)         x - NVRAM_SPACE
 #define NVRAM_MAGIC                    0x48534C46      /* 'FLSH' */
 #define NVRAM_VERSION          1