modules: make all led and button modules used during boot priority 1
authorJohn Crispin <john@openwrt.org>
Mon, 10 Jun 2013 08:24:25 +0000 (08:24 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 10 Jun 2013 08:24:25 +0000 (08:24 +0000)
This makes sure the modules are symlinked in /etc/modules-boot.d/

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 36892

package/kernel/modules/input.mk
package/kernel/modules/leds.mk
package/system/button-hotplug/Makefile
package/system/gpio-button-hotplug/Makefile

index db31eb7f914ba8d57147f7826204e06f15f4ce94..78fa9241cd429c10e9ec3083e81338072afa8b53 100644 (file)
@@ -42,7 +42,7 @@ define KernelPackage/input-core
   TITLE:=Input device core
   KCONFIG:=CONFIG_INPUT
   FILES:=$(LINUX_DIR)/drivers/input/input-core.ko
-  AUTOLOAD:=$(call AutoLoad,19,input-core)
+  AUTOLOAD:=$(call AutoLoad,19,input-core,1)
 endef
 
 define KernelPackage/input-core/description
@@ -76,7 +76,7 @@ define KernelPackage/input-gpio-buttons
        CONFIG_INPUT_GPIO_BUTTONS \
        CONFIG_INPUT_MISC=y
   FILES:=$(LINUX_DIR)/drivers/input/misc/gpio_buttons.ko
-  AUTOLOAD:=$(call AutoLoad,62,gpio_buttons)
+  AUTOLOAD:=$(call AutoLoad,62,gpio_buttons,1)
 endef
 
 define KernelPackage/input-gpio-buttons/description
@@ -114,7 +114,7 @@ define KernelPackage/input-gpio-keys-polled
        CONFIG_KEYBOARD_GPIO_POLLED \
        CONFIG_INPUT_KEYBOARD=y
   FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys_polled.ko
-  AUTOLOAD:=$(call AutoLoad,62,gpio_keys_polled)
+  AUTOLOAD:=$(call AutoLoad,62,gpio_keys_polled,1)
   $(call AddDepends/input)
 endef
 
@@ -162,7 +162,7 @@ define KernelPackage/input-polldev
   TITLE:=Polled Input device support
   KCONFIG:=CONFIG_INPUT_POLLDEV
   FILES:=$(LINUX_DIR)/drivers/input/input-polldev.ko
-  AUTOLOAD:=$(call AutoLoad,20,input-polldev)
+  AUTOLOAD:=$(call AutoLoad,20,input-polldev,1)
   $(call AddDepends/input)
 endef
 
index c77c7ed4448bd79d5345818b099ac011f7682591..980d62610ab856d99626550eb276d01f03f1b781 100644 (file)
@@ -14,7 +14,7 @@ define KernelPackage/leds-gpio
   DEPENDS:= @GPIO_SUPPORT
   KCONFIG:=CONFIG_LEDS_GPIO
   FILES:=$(LINUX_DIR)/drivers/leds/leds-gpio.ko
-  AUTOLOAD:=$(call AutoLoad,60,leds-gpio)
+  AUTOLOAD:=$(call AutoLoad,60,leds-gpio,1)
 endef
 
 define KernelPackage/leds-gpio/description
@@ -126,7 +126,7 @@ define KernelPackage/ledtrig-default-on
   TITLE:=LED Default ON Trigger
   KCONFIG:=CONFIG_LEDS_TRIGGER_DEFAULT_ON
   FILES:=$(LINUX_DIR)/drivers/leds/$(if $(call kernel_patchver_ge,3.10),trigger/)ledtrig-default-on.ko
-  AUTOLOAD:=$(call AutoLoad,50,ledtrig-default-on)
+  AUTOLOAD:=$(call AutoLoad,50,ledtrig-default-on,1)
 endef
 
 define KernelPackage/ledtrig-default-on/description
@@ -141,7 +141,7 @@ define KernelPackage/ledtrig-timer
   TITLE:=LED Timer Trigger
   KCONFIG:=CONFIG_LEDS_TRIGGER_TIMER
   FILES:=$(LINUX_DIR)/drivers/leds/$(if $(call kernel_patchver_ge,3.10),trigger/)ledtrig-timer.ko
-  AUTOLOAD:=$(call AutoLoad,50,ledtrig-timer)
+  AUTOLOAD:=$(call AutoLoad,50,ledtrig-timer,1)
 endef
 
 define KernelPackage/ledtrig-timer/description
index 35ea6d411e7112e24cb529b0192199d67d171407..348ea13401163eab27b79d881a8b8adf0099b398 100644 (file)
@@ -17,7 +17,7 @@ define KernelPackage/button-hotplug
   SUBMENU:=Other modules
   TITLE:=Button Hotplug driver
   FILES:=$(PKG_BUILD_DIR)/button-hotplug.ko
-  AUTOLOAD:=$(call AutoLoad,30,button-hotplug)
+  AUTOLOAD:=$(call AutoLoad,30,button-hotplug,1)
   KCONFIG:=
 endef
 
index adb9a452644478005d7f0fb4d84275f283f89267..1778aadf098f37e8c55e5e410e4e4c2fb81c5601 100644 (file)
@@ -17,7 +17,7 @@ define KernelPackage/gpio-button-hotplug
   SUBMENU:=Other modules
   TITLE:=Simple GPIO Button Hotplug driver
   FILES:=$(PKG_BUILD_DIR)/gpio-button-hotplug.ko
-  AUTOLOAD:=$(call AutoLoad,30,gpio-button-hotplug)
+  AUTOLOAD:=$(call AutoLoad,30,gpio-button-hotplug,1)
   KCONFIG:=
 endef