[imagebuilder] populate repositories.conf from version.mk
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 12 Apr 2012 23:08:13 +0000 (23:08 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 12 Apr 2012 23:08:13 +0000 (23:08 +0000)
SVN-Revision: 31268

target/imagebuilder/Makefile
target/imagebuilder/files/repositories.conf

index 30083999e4e73f570f57005b12616bdf9f65ad1a..3d04656250857b0bd4d96adcdabbbce1f0faa780 100644 (file)
@@ -8,6 +8,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/version.mk
 
 override MAKEFLAGS=
 
@@ -34,7 +35,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
                $(TMP_DIR)/.targetinfo \
                $(TMP_DIR)/.packageinfo \
                $(PKG_BUILD_DIR)/
-       $(SED) 's/$$A/$(BOARD)/' $(PKG_BUILD_DIR)/repositories.conf
+       $(VERSION_SED) $(PKG_BUILD_DIR)/repositories.conf
        $(CP) $(PACKAGE_DIR) $(PKG_BUILD_DIR)/packages
        $(CP) $(STAGING_DIR_HOST)/bin $(PKG_BUILD_DIR)/staging_dir/host/
        $(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
index 4a55adb8590b1261a1b286c655316f1885beb343..708855eb8c3475929e3fb1dc3b63169cea477d51 100644 (file)
@@ -1,6 +1,6 @@
 ## Place your custom repositories here, they must match the architecture and version.
-# src/gz snapshots http://downloads.openwrt.org/snapshots/trunk/$A/packages
-# src custom file:///usr/src/openwrt/bin/$A/packages
+# src/gz %n %U
+# src custom file:///usr/src/openwrt/bin/%T/packages
 
 ## This is the local package repository, do not remove!
 src imagebuilder file:packages