Fix lcd4linux package, remove PNG driver
authorNicolas Thill <nico@openwrt.org>
Thu, 19 May 2005 05:49:38 +0000 (05:49 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 19 May 2005 05:49:38 +0000 (05:49 +0000)
SVN-Revision: 948

openwrt/package/lcd4linux/Config.in
openwrt/package/lcd4linux/Makefile

index e04e2f95b7dc738ae6ba717369b92709ad9e30f6..c08212c320493dbe4d0993048b0538917c84a94e 100644 (file)
@@ -1,10 +1,10 @@
 config BR2_PACKAGE_LCD4LINUX
        tristate "lcd4linux - Program to access an external LCD"
        default m if CONFIG_DEVEL
-       select BR2_PACKAGE_NCURSES
+       select BR2_PACKAGE_LIBNCURSES
        help
          LCD4Linux
          
-       https://ssl.bulix.org/projects/lcd4linux/wiki/Howto
+         https://ssl.bulix.org/projects/lcd4linux/wiki/Howto
          
 
index 5586e65f0063b66bf7ef45d321df3f25fd9e02e3..04bde6915cb71872396e2a9753d2d8652d8ac269 100644 (file)
@@ -24,7 +24,6 @@ $(PKG_BUILD_DIR)/.configured:
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               LIBS="-lpng12 -lz" \
                ./configure \
                  --target=$(GNU_TARGET_NAME) \
                  --host=$(GNU_TARGET_NAME) \
@@ -46,7 +45,7 @@ $(PKG_BUILD_DIR)/.configured:
                  $(DISABLE_LARGEFILE) \
                  $(DISABLE_NLS) \
                  --without-x \
-                 --with-drivers='all,!RouterBoard,!X11' \
+                 --with-drivers='all,!PNG,!RouterBoard,!X11' \
                  --with-plugins=wireless \
        )
        touch $@