package/udev: move configuration in submenu, rename udev-config.in to Config.in for...
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 10:03:09 +0000 (10:03 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 10:03:09 +0000 (10:03 +0000)
SVN-Revision: 20908

package/udev/Config.in [new file with mode: 0644]
package/udev/Makefile
package/udev/udev-config.in [deleted file]

diff --git a/package/udev/Config.in b/package/udev/Config.in
new file mode 100644 (file)
index 0000000..9144c40
--- /dev/null
@@ -0,0 +1,92 @@
+# udev package config
+
+menu "Configuration"
+       depends on PACKAGE_udev
+
+config UDEV_DISABLE_LOGGING
+       bool "Disable udev logging to syslog"
+       default n
+       help
+        Disable logging of udev messages to the syslog.  If
+        unsure, choose the default N.
+
+config UDEV_ENABLE_DEBUG
+       bool "Enable debug build of the udev package"
+       default n
+       help
+        Compile in udev debug messages.  If unsure, choose
+        the default N.
+
+config UDEV_EXTRA_ata_id
+       bool "Install udev ata_id callout"
+       default y
+       help
+        ata_id - udev callout to read product/serial number
+        from ATA drives
+
+config UDEV_EXTRA_cdrom_id
+       bool "Install udev cdrom_id callout"
+       default y
+       help
+        cdrom_id - udev callout to determine the capabilities
+        of optical drives and media
+
+config UDEV_EXTRA_collect
+       bool "Install udev collect"
+       default n
+       help
+        Adds ID to the list governed by <checkpoint>
+
+config UDEV_EXTRA_edd_id
+       bool "Install udev edd_id callout"
+       default n
+       help
+        edd_id - udev callout to identify BIOS disk drives
+        via EDD
+
+config UDEV_EXTRA_firmware
+       bool "Install firmware support"
+       default n
+       help
+        udev firmware loader
+        via EDD
+
+config UDEV_EXTRA_floppy
+       bool "Install create_floppy_devices callout"
+       default n
+       help
+        create_floppy_devices - udev callout to create all
+        possible floppy device based on the CMOS type
+
+config UDEV_EXTRA_fstab_import
+       bool "Install fstab import"
+       default y
+       help
+        find matching entry in fstab and export it
+
+config UDEV_EXTRA_path_id
+       bool "Install udev path_id callout"
+       default y
+       help
+        path_id - udev callout to create a device path based
+        unique name for a device to implement the Linux
+        Persistent Device Naming scheme
+
+config UDEV_EXTRA_rule_generator
+       bool "Install udev rule_generator"
+       default y
+       help
+
+config UDEV_EXTRA_scsi_id
+       bool "Install udev scsi_id callout"
+       default y
+       help
+        scsi_id - retrieve and generate a unique SCSI identifier
+
+config UDEV_EXTRA_usb_id
+       bool "Install udev usb_id callout"
+       default y
+       help
+         usb_id - can find the unique id of USB devices
+
+endmenu
index f14fb3b8af879a5056a371650e696b6dcfd501a9..26bfe8bba2f1e24501bb12a002033adfc4eea619 100644 (file)
@@ -26,6 +26,7 @@ define Package/udev
   TITLE:=Dynamic device management subsystem
   URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
   MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
+  MENU:=1
 endef
 
 define Package/udev/description
@@ -34,7 +35,7 @@ define Package/udev/description
 endef
 
 define Package/udev/config
-       source "$(SOURCE)/udev-config.in"
+       source "$(SOURCE)/Config.in"
 endef
 
 udev-args-$(CONFIG_UDEV_DISABLE_LOGGING) += --disable-logging
diff --git a/package/udev/udev-config.in b/package/udev/udev-config.in
deleted file mode 100644 (file)
index c10bb9c..0000000
+++ /dev/null
@@ -1,94 +0,0 @@
-# udev package config
-
-menu "udev configuration"
-depends on PACKAGE_udev
-
-config UDEV_DISABLE_LOGGING
-       bool "Disable udev logging to syslog"
-       depends on PACKAGE_udev
-       default n
-       help
-        Disable logging of udev messages to the syslog.  If
-        unsure, choose the default N.
-
-config UDEV_ENABLE_DEBUG
-       bool "Enable debug build of the udev package"
-       depends on PACKAGE_udev
-       default n
-       help
-        Compile in udev debug messages.  If unsure, choose
-        the default N.
-
-config UDEV_EXTRA_ata_id
-       bool "Install udev ata_id callout"
-       default y
-       help
-        ata_id - udev callout to read product/serial number
-        from ATA drives
-
-config UDEV_EXTRA_cdrom_id
-       bool "Install udev cdrom_id callout"
-       default y
-       help
-        cdrom_id - udev callout to determine the capabilities
-        of optical drives and media
-
-config UDEV_EXTRA_collect
-       bool "Install udev collect"
-       default n
-       help
-        Adds ID to the list governed by <checkpoint>
-
-config UDEV_EXTRA_edd_id
-       bool "Install udev edd_id callout"
-       default n
-       help
-        edd_id - udev callout to identify BIOS disk drives
-        via EDD
-
-config UDEV_EXTRA_firmware
-       bool "Install firmware support"
-       default n
-       help
-        udev firmware loader
-        via EDD
-
-config UDEV_EXTRA_floppy
-       bool "Install create_floppy_devices callout"
-       default n
-       help
-        create_floppy_devices - udev callout to create all
-        possible floppy device based on the CMOS type
-
-config UDEV_EXTRA_fstab_import
-       bool "Install fstab import"
-       default y
-       help
-        find matching entry in fstab and export it
-
-config UDEV_EXTRA_path_id
-       bool "Install udev path_id callout"
-       default y
-       help
-        path_id - udev callout to create a device path based
-        unique name for a device to implement the Linux
-        Persistent Device Naming scheme
-
-config UDEV_EXTRA_rule_generator
-       bool "Install udev rule_generator"
-       default y
-       help
-
-config UDEV_EXTRA_scsi_id
-       bool "Install udev scsi_id callout"
-       default y
-       help
-        scsi_id - retrieve and generate a unique SCSI identifier
-
-config UDEV_EXTRA_usb_id
-       bool "Install udev usb_id callout"
-       default y
-       help
-         usb_id - can find the unique id of USB devices
-
-endmenu