Remove .la libtool library files
authorNicolas Thill <nico@openwrt.org>
Fri, 8 Apr 2005 15:40:28 +0000 (15:40 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 8 Apr 2005 15:40:28 +0000 (15:40 +0000)
SVN-Revision: 584

openwrt/package/glib/Makefile
openwrt/package/pcre/ipkg/rules
openwrt/package/popt/ipkg/rules

index c3a0e6a6794f138536663dd54435eb322aa54029..64646c41cd0788731bf8290ca7dc2d7e8b867065 100644 (file)
@@ -80,6 +80,7 @@ $(STAGING_DIR)/lib/libglib.so: $(PKG_BUILD_DIR)/libglib.so
          DESTDIR="$(STAGING_DIR)" \
          install
        cp $(PKG_BUILD_DIR)/glibconfig-sysdefs.h $(STAGING_DIR)/usr/include/glib-1.2/
+       rm -f $(STAGING_DIR)/usr/lib/libg{lib,module,thread}.la
 
 $(PKG_IPK): $(STAGING_DIR)/lib/libglib.so
        mkdir -p $(PACKAGE_DIR)
index c5d1d335baf7bf6d480184ef2e0d38882f742464..ead5116d80a5e2b59a1aaa29ce189ef481aa775d 100644 (file)
@@ -78,6 +78,8 @@ $(INSTALL_DIR)/usr/include/pcre.h: .stamp-built
          DESTDIR="$(INSTALL_DIR)" \
         install
 
+       rm -f $(INSTALL_DIR)/usr/lib/libpcre*.la
+
 
 configure: .stamp-configured
 
index 2ab310b2e54419d7ba49b48fba76742defa2f054..7a615a5f2cf1824b0b9c252e019cc34e6e70075d 100644 (file)
@@ -72,6 +72,8 @@ $(INSTALL_DIR)/usr/include/popt.h: .stamp-built
          DESTDIR="$(INSTALL_DIR)" \
         install
 
+       rm -f $(INSTALL_DIR)/usr/lib/libpopt.la
+
 
 configure: .stamp-configured