[package] mountd: Rename uci_add_history to uci_add_delta (#8084)
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Sat, 16 Oct 2010 13:57:55 +0000 (13:57 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Sat, 16 Oct 2010 13:57:55 +0000 (13:57 +0000)
SVN-Revision: 23474

package/mountd/Makefile
package/mountd/patches/010-uci_rename_history_to_delta.patch [new file with mode: 0644]

index 8cecc15335fab7bdbef987286c71295bb23a02c9..f7a68242ac47c7679e722a9b0f62ec1c386441d0 100644 (file)
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mountd
 PKG_VERSION:=0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
diff --git a/package/mountd/patches/010-uci_rename_history_to_delta.patch b/package/mountd/patches/010-uci_rename_history_to_delta.patch
new file mode 100644 (file)
index 0000000..65b2f84
--- /dev/null
@@ -0,0 +1,27 @@
+---
+ lib/uci.c  |    2 +-
+ lib/ucix.c |    2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- a/lib/uci.c
++++ b/lib/uci.c
+@@ -28,7 +28,7 @@ struct uci_package *p = NULL;
+ struct uci_context* uci_init(char *config_file)
+ {
+       struct uci_context *ctx = uci_alloc_context();
+-      uci_add_history_path(ctx, "/var/state");
++      uci_add_delta_path(ctx, "/var/state");
+       if(uci_load(ctx, config_file, &p) != UCI_OK)
+       {
+               log_printf("/etc/config/%s is missing or corrupt\n", config_file);
+--- a/lib/ucix.c
++++ b/lib/ucix.c
+@@ -18,7 +18,7 @@ static inline int ucix_get_ptr(struct uc
+ struct uci_context* ucix_init(const char *config_file)
+ {
+       struct uci_context *ctx = uci_alloc_context();
+-      uci_add_history_path(ctx, "/var/state");
++      uci_add_delta_path(ctx, "/var/state");
+       if(uci_load(ctx, config_file, NULL) != UCI_OK)
+       {
+               printf("%s/%s is missing or corrupt\n", ctx->savedir, config_file);