Convert nfs-server to new packaging style
authorNicolas Thill <nico@openwrt.org>
Wed, 18 May 2005 13:28:02 +0000 (13:28 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 18 May 2005 13:28:02 +0000 (13:28 +0000)
SVN-Revision: 931

openwrt/package/Makefile
openwrt/package/nfs-server/Config.in
openwrt/package/nfs-server/Makefile
openwrt/package/nfs-server/files/etc/exports [deleted file]
openwrt/package/nfs-server/files/etc/init.d/S60nfsd [deleted file]
openwrt/package/nfs-server/files/nfsd.exports [new file with mode: 0644]
openwrt/package/nfs-server/files/nfsd.init [new file with mode: 0644]
openwrt/package/nfs-server/ipkg/nfs-server.control [new file with mode: 0644]
openwrt/package/nfs-server/nfs-server.control [deleted file]

index b5573a14e3418f0e1bbb0581edb37ee7fe663449..62718f773b08b8234f5d79128afe372eb9438c15 100644 (file)
@@ -38,7 +38,7 @@ package-$(BR2_PACKAGE_MARADNS) += maradns
 package-$(BR2_PACKAGE_MICROPERL) += microperl
 package-$(BR2_PACKAGE_MONIT) += monit
 package-$(BR2_PACKAGE_NCURSES) += ncurses
-package-$(BR2_PACKAGE_NFSD) += nfs-server
+package-$(BR2_PACKAGE_NFS_SERVER) += nfs-server
 package-$(BR2_PACKAGE_NMAP) += nmap
 package-$(BR2_PACKAGE_NOCATSPLASH) += nocatsplash
 package-$(BR2_PACKAGE_NTPCLIENT) += ntpclient
index 9ace94cb1a8cad868b2051155ffe1d983a9228ab..5f410d6cb1c5ee4749ed40b1a122e78d79a7c874 100644 (file)
@@ -1,5 +1,5 @@
-config BR2_PACKAGE_NFSD
-       tristate "NFS Server"
+config BR2_PACKAGE_NFS_SERVER
+       tristate "nfs-server - User Space NFS server"
        default m if CONFIG_DEVEL
        select BR2_PACKAGE_PORTMAP
        help
index 2d584513718ac1ca4256e5ba85b4a8b1f1624294..1f72ddfca30b54a585706a432d70ff193daf5053 100644 (file)
@@ -9,63 +9,52 @@ PKG_MD5SUM:=79a29fe9f79b2f3241d4915767b8c511
 
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/n/nfs-user-server
 PKG_SOURCE:=nfs-user-server_$(PKG_VERSION).orig.tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
-$(DL_DIR)/$(PKG_SOURCE):
-       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
 
-$(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(PATCH) $(PKG_BUILD_DIR) ./patches
-       touch $(PKG_BUILD_DIR)/.patched
+$(eval $(call PKG_template,NFS_SERVER,nfs-server,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.patched
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                ./configure \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --prefix=/usr \
-               --exec-prefix=/usr \
-               --bindir=/usr/bin \
-               --sbindir=/usr/sbin \
-               --libexecdir=/usr/lib \
-               --sysconfdir=/etc \
-               --datadir=/usr/share \
-               --localstatedir=/var \
-               --mandir=/usr/man \
-               --infodir=/usr/info \
-               $(DISABLE_NLS) \
-               $(DISABLE_LARGEFILE) \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
        );
        touch $(PKG_BUILD_DIR)/.configured
 
-$(PKG_BUILD_DIR)/rpc.nfsd: $(PKG_BUILD_DIR)/.configured
-       $(MAKE) CC=$(TARGET_CC) -C $(PKG_BUILD_DIR)
-
-$(PKG_IPK): $(PKG_BUILD_DIR)/rpc.nfsd
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(PKG_IPK_DIR)/usr/sbin
-       cp $(PKG_BUILD_DIR)/rpc.* $(PKG_IPK_DIR)/usr/sbin/
-       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
-       cp -a ./files/* $(PKG_IPK_DIR)/
-       mkdir -p $(PACKAGE_DIR)
-       find $(PKG_IPK_DIR) -name CVS | xargs rm -rf
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.patched
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
-
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       touch $(PKG_BUILD_DIR)/.built
+
+$(IPKG_NFS_SERVER):
+       install -d -m0755 $(IDIR_NFS_SERVER)/etc
+       install -m0644 ./files/nfsd.exports $(IDIR_NFS_SERVER)/etc/exports
+       install -d -m0755 $(IDIR_NFS_SERVER)/etc/init.d
+       install -m0644 ./files/nfsd.init $(IDIR_NFS_SERVER)/etc/init.d/S60nfsd
+       install -d -m0755 $(IDIR_NFS_SERVER)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/rpc.* $(IDIR_NFS_SERVER)/usr/sbin/
+       $(RSTRIP) $(IDIR_NFS_SERVER)
+       $(IPKG_BUILD) $(IDIR_NFS_SERVER) $(PACKAGE_DIR)
diff --git a/openwrt/package/nfs-server/files/etc/exports b/openwrt/package/nfs-server/files/etc/exports
deleted file mode 100644 (file)
index 75a387a..0000000
+++ /dev/null
@@ -1 +0,0 @@
-/mnt   (ro,all_squash,insecure)
diff --git a/openwrt/package/nfs-server/files/etc/init.d/S60nfsd b/openwrt/package/nfs-server/files/etc/init.d/S60nfsd
deleted file mode 100755 (executable)
index 1b1e1bd..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-/usr/sbin/portmap
-/usr/sbin/rpc.mountd -r
-/usr/sbin/rpc.nfsd
diff --git a/openwrt/package/nfs-server/files/nfsd.exports b/openwrt/package/nfs-server/files/nfsd.exports
new file mode 100644 (file)
index 0000000..75a387a
--- /dev/null
@@ -0,0 +1 @@
+/mnt   (ro,all_squash,insecure)
diff --git a/openwrt/package/nfs-server/files/nfsd.init b/openwrt/package/nfs-server/files/nfsd.init
new file mode 100644 (file)
index 0000000..1b1e1bd
--- /dev/null
@@ -0,0 +1,4 @@
+#!/bin/sh
+/usr/sbin/portmap
+/usr/sbin/rpc.mountd -r
+/usr/sbin/rpc.nfsd
diff --git a/openwrt/package/nfs-server/ipkg/nfs-server.control b/openwrt/package/nfs-server/ipkg/nfs-server.control
new file mode 100644 (file)
index 0000000..72a6cf9
--- /dev/null
@@ -0,0 +1,16 @@
+Package: nfs-server
+Section: net
+Priority: optional
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Depends: portmap
+Description: User space NFS server
+ This package contains all necessary programs to make your Linux machine act
+ as an NFS server, being an NFS daemon (rpc.nfsd), a mount daemon (rpc.mountd).
+ .
+ Unlike other NFS daemons, this NFS server runs entirely in user space.  This
+ makes it a tad slower than other NFS implementations, and also introduces
+ some awkwardnesses in the semantics (for instance, moving a file to a
+ different directory will render its file handle invalid).
+ .
+ There is currently no support for file locking.
diff --git a/openwrt/package/nfs-server/nfs-server.control b/openwrt/package/nfs-server/nfs-server.control
deleted file mode 100644 (file)
index 72a6cf9..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-Package: nfs-server
-Section: net
-Priority: optional
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Depends: portmap
-Description: User space NFS server
- This package contains all necessary programs to make your Linux machine act
- as an NFS server, being an NFS daemon (rpc.nfsd), a mount daemon (rpc.mountd).
- .
- Unlike other NFS daemons, this NFS server runs entirely in user space.  This
- makes it a tad slower than other NFS implementations, and also introduces
- some awkwardnesses in the semantics (for instance, moving a file to a
- different directory will render its file handle invalid).
- .
- There is currently no support for file locking.