hostapd: update to 20120428, fixes some radius issues and wds ap mac address issues
authorFelix Fietkau <nbd@openwrt.org>
Sun, 29 Apr 2012 11:14:53 +0000 (11:14 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 29 Apr 2012 11:14:53 +0000 (11:14 +0000)
SVN-Revision: 31515

19 files changed:
package/hostapd/Makefile
package/hostapd/patches/100-pending_work.patch
package/hostapd/patches/300-nl80211_multicall_fixes.patch
package/hostapd/patches/310-multicall_bridge_fix.patch
package/hostapd/patches/400-scan_wait.patch
package/hostapd/patches/410-multicall.patch
package/hostapd/patches/430-rescan_immediately.patch
package/hostapd/patches/440-optional_rfkill.patch
package/hostapd/patches/450-reload_freq_change.patch
package/hostapd/patches/451-nl80211_del_beacon_bss.patch
package/hostapd/patches/453-ap_sta_support.patch
package/hostapd/patches/460-disable_ctrl_iface_mib.patch
package/hostapd/patches/480-terminate_on_setup_failure.patch
package/hostapd/patches/510-bring_down_interface.patch
package/hostapd/patches/530-wps_single_auth_enc_type.patch
package/hostapd/patches/540-dynamic_20_40_mhz.patch
package/hostapd/patches/550-limit_debug_messages.patch
package/hostapd/patches/560-indicate-features.patch
package/hostapd/patches/580-fix_bss_addr.patch [new file with mode: 0644]

index 1e472ef40685fe468c1e628a78c04e706ce7ad7d..4fedd1b9379901d42a68acc55fbaf790154ce2a7 100644 (file)
@@ -8,16 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_VERSION:=20120326
+PKG_VERSION:=20120428
 PKG_RELEASE:=1
-PKG_REV:=f4329aa2d08192640532b712936f5221580e9f8c
+PKG_REV:=1f0cc27eb98f7d1af9c64d0752238184cbdb9a24
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=git://w1.fi/srv/git/hostap.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=git
-PKG_MIRROR_MD5SUM:=2650d83c1d4649a5df9fe265f8a5775f
+PKG_MIRROR_MD5SUM:=2732dbca58b0aaaebdad69e13588d058
 
 PKG_BUILD_DEPENDS:= \
        PACKAGE_kmod-madwifi:madwifi \
index 4f9dfbec8330f3ce82c896e748070cdd5652ec20..49e5b45f44b2078d08ae309dc9be2e8426429fe9 100644 (file)
@@ -58,7 +58,7 @@
                                   "STA " MACSTR " (aid %u)",
 --- a/src/drivers/driver_nl80211.c
 +++ b/src/drivers/driver_nl80211.c
-@@ -2588,10 +2588,10 @@ static int wpa_driver_nl80211_capa(struc
+@@ -2601,10 +2601,10 @@ static int wpa_driver_nl80211_capa(struc
        drv->data_tx_status = info.data_tx_status;
  
        /*
@@ -72,7 +72,7 @@
  
        if (drv->device_ap_sme && drv->use_monitor) {
                /*
-@@ -6267,8 +6267,8 @@ static int wpa_driver_nl80211_hapd_send_
+@@ -6286,8 +6286,8 @@ static int wpa_driver_nl80211_hapd_send_
        pos = (u8 *) (hdr + 1);
  
        if (qos) {
@@ -83,7 +83,7 @@
                pos[1] = 0;
                pos += 2;
        }
-@@ -7533,6 +7533,10 @@ static int i802_set_wds_sta(void *priv, 
+@@ -7564,6 +7564,10 @@ static int i802_set_wds_sta(void *priv, 
                linux_set_iface_flags(drv->global->ioctl_sock, name, 1);
                return i802_set_sta_vlan(priv, addr, name, 0);
        } else {
@@ -94,7 +94,7 @@
                i802_set_sta_vlan(priv, addr, bss->ifname, 0);
                return wpa_driver_nl80211_if_remove(priv, WPA_IF_AP_VLAN,
                                                    name);
-@@ -7900,7 +7904,12 @@ static int wpa_driver_nl80211_if_remove(
+@@ -7931,7 +7935,12 @@ static int wpa_driver_nl80211_if_remove(
        if (ifindex <= 0)
                return -1;
  
        if (bss->added_if_into_bridge) {
                if (linux_br_del_if(drv->global->ioctl_sock, bss->brname,
                                    bss->ifname) < 0)
-@@ -7914,13 +7923,6 @@ static int wpa_driver_nl80211_if_remove(
+@@ -7945,13 +7954,6 @@ static int wpa_driver_nl80211_if_remove(
                                   "bridge %s: %s",
                                   bss->brname, strerror(errno));
        }
index cb96ec29a7b42434656e08f1c920437e2d000f4f..e0135df160a77ecd4fa6da285aa4df1275b2df0c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/drivers/driver_nl80211.c
 +++ b/src/drivers/driver_nl80211.c
-@@ -2918,6 +2918,7 @@ static void * wpa_driver_nl80211_init(vo
+@@ -2931,6 +2931,7 @@ static void * wpa_driver_nl80211_init(vo
        drv->monitor_sock = -1;
        drv->eapol_tx_sock = -1;
        drv->ap_scan_as_station = NL80211_IFTYPE_UNSPECIFIED;
@@ -8,7 +8,7 @@
  
        if (wpa_driver_nl80211_init_nl(drv)) {
                os_free(drv);
-@@ -3232,17 +3233,12 @@ static void wpa_driver_nl80211_send_rfki
+@@ -3245,17 +3246,12 @@ static void wpa_driver_nl80211_send_rfki
        wpa_supplicant_event(timeout_ctx, EVENT_INTERFACE_DISABLED, NULL);
  }
  
@@ -28,7 +28,7 @@
        /*
         * Make sure the interface starts up in station mode unless this is a
         * dynamically added interface (e.g., P2P) that was already configured
-@@ -3261,7 +3257,7 @@ wpa_driver_nl80211_finish_drv_init(struc
+@@ -3274,7 +3270,7 @@ wpa_driver_nl80211_finish_drv_init(struc
                                   "interface '%s' due to rfkill",
                                   bss->ifname);
                        drv->if_disabled = 1;
@@ -37,7 +37,7 @@
                } else {
                        wpa_printf(MSG_ERROR, "nl80211: Could not set "
                                   "interface '%s' UP", bss->ifname);
-@@ -3271,7 +3267,19 @@ wpa_driver_nl80211_finish_drv_init(struc
+@@ -3284,7 +3280,19 @@ wpa_driver_nl80211_finish_drv_init(struc
  
        netlink_send_oper_ifla(drv->global->netlink, drv->ifindex,
                               1, IF_OPER_DORMANT);
index 2ee198a173238aac104adc1bdbfd4958e58f9700..711f890e250504ab0874de44c33aa483fde97dff 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/drivers/driver_nl80211.c
 +++ b/src/drivers/driver_nl80211.c
-@@ -886,6 +886,10 @@ static void wpa_driver_nl80211_event_rtm
+@@ -887,6 +887,10 @@ static void wpa_driver_nl80211_event_rtm
                return;
        }
  
@@ -11,7 +11,7 @@
        wpa_printf(MSG_DEBUG, "RTM_NEWLINK: operstate=%d ifi_flags=0x%x "
                   "(%s%s%s%s)",
                   drv->operstate, ifi->ifi_flags,
-@@ -993,6 +997,10 @@ static void wpa_driver_nl80211_event_rtm
+@@ -994,6 +998,10 @@ static void wpa_driver_nl80211_event_rtm
        attrlen = len;
        attr = (struct rtattr *) buf;
  
@@ -22,7 +22,7 @@
        rta_len = RTA_ALIGN(sizeof(struct rtattr));
        while (RTA_OK(attr, attrlen)) {
                if (attr->rta_type == IFLA_IFNAME) {
-@@ -2920,6 +2928,11 @@ static void * wpa_driver_nl80211_init(vo
+@@ -2933,6 +2941,11 @@ static void * wpa_driver_nl80211_init(vo
        drv->ap_scan_as_station = NL80211_IFTYPE_UNSPECIFIED;
        drv->nlmode = NL80211_IFTYPE_STATION;
  
@@ -34,7 +34,7 @@
        if (wpa_driver_nl80211_init_nl(drv)) {
                os_free(drv);
                return NULL;
-@@ -7654,8 +7667,6 @@ static void *i802_init(struct hostapd_da
+@@ -7685,8 +7698,6 @@ static void *i802_init(struct hostapd_da
                br_ifindex = 0;
        }
  
index 530eca914e3195436df4449bffb2357d3e45082b..8f16fe8ca81bcda49a840624c13770ada3af585e 100644 (file)
@@ -10,7 +10,7 @@
  /* hostapd.c */
 --- a/src/ap/hostapd.c
 +++ b/src/ap/hostapd.c
-@@ -851,6 +851,9 @@ int hostapd_setup_interface_complete(str
+@@ -852,6 +852,9 @@ int hostapd_setup_interface_complete(str
        wpa_printf(MSG_DEBUG, "%s: Setup of interface done.",
                   iface->bss[0]->conf->iface);
  
        if (log_file)
 --- a/hostapd/config_file.c
 +++ b/hostapd/config_file.c
-@@ -1941,6 +1941,8 @@ static int hostapd_config_fill(struct ho
+@@ -1947,6 +1947,8 @@ static int hostapd_config_fill(struct ho
                        }
  #endif /* CONFIG_IEEE80211W */
  #ifdef CONFIG_IEEE80211N
        int require_ht;
 --- a/src/ap/hw_features.c
 +++ b/src/ap/hw_features.c
-@@ -451,7 +451,7 @@ static int ieee80211n_check_40mhz(struct
+@@ -491,7 +491,7 @@ static int ieee80211n_check_40mhz(struct
  {
        struct wpa_driver_scan_params params;
  
index b9495de462ed02c4a0b59ef54bb8eb97d1f6946f..b653769329752ed746a91bf953ce9dbe24fe38af 100644 (file)
  NEED_AES_WRAP=y
  OBJS += ../src/ap/wpa_auth.o
  OBJS += ../src/ap/wpa_auth_ie.o
-@@ -1415,6 +1430,12 @@ wpa_priv: $(BCHECK) $(OBJS_priv)
+@@ -1419,6 +1434,12 @@ wpa_priv: $(BCHECK) $(OBJS_priv)
  
  $(OBJS_c) $(OBJS_t) $(OBJS_t2) $(OBJS) $(BCHECK) $(EXTRA_progs): .config
  
  wpa_supplicant: $(BCHECK) $(OBJS) $(EXTRA_progs)
        $(Q)$(LDO) $(LDFLAGS) -o wpa_supplicant $(OBJS) $(LIBS) $(EXTRALIBS)
        @$(E) "  LD " $@
-@@ -1481,6 +1502,12 @@ eap_ikev2.so: ../src/eap_peer/eap_ikev2.
+@@ -1485,6 +1506,12 @@ eap_ikev2.so: ../src/eap_peer/eap_ikev2.
  %@.service: %.service.arg.in
        sed -e 's|\@BINDIR\@|$(BINDIR)|g' $< >$@
  
  wpa_cli.exe: wpa_cli
 --- a/src/drivers/driver.h
 +++ b/src/drivers/driver.h
-@@ -3541,8 +3541,8 @@ union wpa_event_data {
+@@ -3572,8 +3572,8 @@ union wpa_event_data {
   * Driver wrapper code should call this function whenever an event is received
   * from the driver.
   */
  /*
 --- a/src/ap/drv_callbacks.c
 +++ b/src/ap/drv_callbacks.c
-@@ -459,8 +459,8 @@ static void hostapd_event_eapol_rx(struc
+@@ -467,8 +467,8 @@ static void hostapd_event_eapol_rx(struc
  }
  
  
        u16 reason_code = 0;
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -2680,6 +2680,9 @@ static void wpa_supplicant_deinit_iface(
+@@ -2704,6 +2704,9 @@ static void wpa_supplicant_deinit_iface(
        }
  }
  
  
  /**
   * wpa_supplicant_add_iface - Add a new network interface
-@@ -2871,6 +2874,7 @@ struct wpa_global * wpa_supplicant_init(
+@@ -2895,6 +2898,7 @@ struct wpa_global * wpa_supplicant_init(
        wpa_msg_register_ifname_cb(wpa_supplicant_msg_ifname_cb);
  #endif /* CONFIG_NO_WPA_MSG */
  
index 42600ceaa40532089caaf25c5fd53a8b1f3d4bb7..5332c9cea88929b06bdce513399a62b1308006b8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -2191,7 +2191,7 @@ static struct wpa_supplicant * wpa_suppl
+@@ -2215,7 +2215,7 @@ static struct wpa_supplicant * wpa_suppl
        if (wpa_s == NULL)
                return NULL;
        wpa_s->scan_req = 1;
index 0b29cad7b3635241bb12e9dc8ad0fa8189ea6178..e7b172944e42bc1f7bf4c3d78893781e1f700724 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/drivers/driver_nl80211.c
 +++ b/src/drivers/driver_nl80211.c
-@@ -211,7 +211,9 @@ struct wpa_driver_nl80211_data {
+@@ -212,7 +212,9 @@ struct wpa_driver_nl80211_data {
        int if_removed;
        int if_disabled;
        int ignore_if_down_event;
@@ -10,7 +10,7 @@
        struct wpa_driver_capa capa;
        int has_capability;
  
-@@ -2755,7 +2757,7 @@ static int wpa_driver_nl80211_init_nl(st
+@@ -2768,7 +2770,7 @@ static int wpa_driver_nl80211_init_nl(st
        return 0;
  }
  
@@ -19,7 +19,7 @@
  static void wpa_driver_nl80211_rfkill_blocked(void *ctx)
  {
        wpa_printf(MSG_DEBUG, "nl80211: RFKILL blocked");
-@@ -2778,6 +2780,7 @@ static void wpa_driver_nl80211_rfkill_un
+@@ -2791,6 +2793,7 @@ static void wpa_driver_nl80211_rfkill_un
        }
        /* rtnetlink ifup handler will report interface as enabled */
  }
@@ -27,7 +27,7 @@
  
  
  static void nl80211_get_phy_name(struct wpa_driver_nl80211_data *drv)
-@@ -2909,7 +2912,9 @@ static void * wpa_driver_nl80211_init(vo
+@@ -2922,7 +2925,9 @@ static void * wpa_driver_nl80211_init(vo
                                      void *global_priv)
  {
        struct wpa_driver_nl80211_data *drv;
@@ -37,7 +37,7 @@
        struct i802_bss *bss;
  
        if (global_priv == NULL)
-@@ -2943,6 +2948,7 @@ static void * wpa_driver_nl80211_init(vo
+@@ -2956,6 +2961,7 @@ static void * wpa_driver_nl80211_init(vo
  
        nl80211_get_phy_name(drv);
  
@@ -45,7 +45,7 @@
        rcfg = os_zalloc(sizeof(*rcfg));
        if (rcfg == NULL)
                goto failed;
-@@ -2955,6 +2961,7 @@ static void * wpa_driver_nl80211_init(vo
+@@ -2968,6 +2974,7 @@ static void * wpa_driver_nl80211_init(vo
                wpa_printf(MSG_DEBUG, "nl80211: RFKILL status not available");
                os_free(rcfg);
        }
@@ -53,7 +53,7 @@
  
        if (wpa_driver_nl80211_finish_drv_init(drv))
                goto failed;
-@@ -3241,10 +3248,12 @@ static void nl80211_mgmt_unsubscribe(str
+@@ -3254,10 +3261,12 @@ static void nl80211_mgmt_unsubscribe(str
  }
  
  
@@ -66,7 +66,7 @@
  
  static int
  wpa_driver_nl80211_finish_drv_init_sta(struct wpa_driver_nl80211_data *drv,
-@@ -3265,13 +3274,16 @@ wpa_driver_nl80211_finish_drv_init_sta(s
+@@ -3278,13 +3287,16 @@ wpa_driver_nl80211_finish_drv_init_sta(s
        }
  
        if (linux_set_iface_flags(drv->global->ioctl_sock, bss->ifname, 1)) {
@@ -84,7 +84,7 @@
                        wpa_printf(MSG_ERROR, "nl80211: Could not set "
                                   "interface '%s' UP", bss->ifname);
                        return -1;
-@@ -3302,8 +3314,10 @@ wpa_driver_nl80211_finish_drv_init(struc
+@@ -3315,8 +3327,10 @@ wpa_driver_nl80211_finish_drv_init(struc
                return -1;
  
        if (send_rfkill_event) {
@@ -95,7 +95,7 @@
        }
  
        return 0;
-@@ -3389,7 +3403,9 @@ static void wpa_driver_nl80211_deinit(vo
+@@ -3403,7 +3417,9 @@ static void wpa_driver_nl80211_deinit(vo
  
        netlink_send_oper_ifla(drv->global->netlink, drv->ifindex, 0,
                               IF_OPER_UP);
index 7d30bf720f47d756b901ff8c20f86ec87048b572..b83410be3a1e8283162376603aac15c2e5f89c97 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/ap/hostapd.c
 +++ b/src/ap/hostapd.c
-@@ -136,6 +136,10 @@ int hostapd_reload_config(struct hostapd
+@@ -137,6 +137,10 @@ int hostapd_reload_config(struct hostapd
        oldconf = hapd->iconf;
        iface->conf = newconf;
  
index eea4e654188ea2465545cc70ddf673eadf99e4e8..9f0eae3bd47a6e63b20170b2885adbc1c2448baf 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/drivers/driver_nl80211.c
 +++ b/src/drivers/driver_nl80211.c
-@@ -3324,16 +3324,18 @@ wpa_driver_nl80211_finish_drv_init(struc
+@@ -3337,16 +3337,18 @@ wpa_driver_nl80211_finish_drv_init(struc
  }
  
  
@@ -21,7 +21,7 @@
  
        return send_and_recv_msgs(drv, msg, NULL, NULL);
   nla_put_failure:
-@@ -3341,6 +3343,21 @@ static int wpa_driver_nl80211_del_beacon
+@@ -3354,6 +3356,21 @@ static int wpa_driver_nl80211_del_beacon
        return -ENOBUFS;
  }
  
@@ -43,7 +43,7 @@
  
  /**
   * wpa_driver_nl80211_deinit - Deinitialize nl80211 driver interface
-@@ -9054,4 +9071,5 @@ const struct wpa_driver_ops wpa_driver_n
+@@ -9099,4 +9116,5 @@ const struct wpa_driver_ops wpa_driver_n
        .send_tdls_mgmt = nl80211_send_tdls_mgmt,
        .tdls_oper = nl80211_tdls_oper,
  #endif /* CONFIG_TDLS */
  };
 --- a/src/drivers/driver.h
 +++ b/src/drivers/driver.h
-@@ -2002,6 +2002,9 @@ struct wpa_driver_ops {
+@@ -2007,6 +2007,9 @@ struct wpa_driver_ops {
         */
-       int (*deinit_ap)(void *priv);
+       int (*probe_req_report)(void *priv, int report);
  
 +
 +      int (*stop_ap)(void *priv);
 +
        /**
-        * suspend - Notification on system suspend/hibernate event
+        * deinit_ap - Deinitialize AP mode
         * @priv: Private driver interface data
index a02a3873888081b6d12b64c4e5a0222e617b2afe..795bead50a213d331b4067bd00ae0d78aeb3afc1 100644 (file)
@@ -9,7 +9,7 @@
  };
  
  /**
-@@ -263,6 +265,8 @@ struct wpa_supplicant {
+@@ -271,6 +273,8 @@ struct wpa_supplicant {
  #endif /* CONFIG_CTRL_IFACE_DBUS_NEW */
        char bridge_ifname[16];
  
                wpa_s->new_connection = 1;
                wpa_drv_set_operstate(wpa_s, 0);
  #ifndef IEEE8021X_EAPOL
-@@ -2498,6 +2555,21 @@ static int wpa_supplicant_init_iface(str
+@@ -2522,6 +2579,21 @@ static int wpa_supplicant_init_iface(str
                os_strlcpy(wpa_s->bridge_ifname, iface->bridge_ifname,
                           sizeof(wpa_s->bridge_ifname));
        }
               "[-p<driver_param>] \\\n"
               "        [-b<br_ifname>] [-f<debug file>] [-e<entropy file>] "
               "\\\n"
-@@ -63,6 +63,7 @@ static void usage(void)
- #endif /* CONFIG_DEBUG_SYSLOG */
+@@ -67,6 +67,7 @@ static void usage(void)
+ #endif /* CONFIG_DEBUG_LINUX_TRACING */
        printf("  -t = include timestamp in debug messages\n"
               "  -h = show this help text\n"
 +                 "  -H = connect to a hostapd instance to manage state changes\n"
               "  -L = show license (BSD)\n"
               "  -o = override driver parameter for new interfaces\n"
               "  -O = override ctrl_interface parameter for new interfaces\n"
-@@ -139,7 +140,7 @@ int main(int argc, char *argv[])
-       wpa_supplicant_fd_workaround();
+@@ -144,7 +145,7 @@ int main(int argc, char *argv[])
  
        for (;;) {
--              c = getopt(argc, argv, "b:Bc:C:D:de:f:g:hi:KLNo:O:p:P:qstuvW");
-+              c = getopt(argc, argv, "b:Bc:C:D:de:f:g:hH:i:KLNo:O:p:P:qstuvW");
+               c = getopt(argc, argv,
+-                         "b:Bc:C:D:de:f:g:hi:KLNo:O:p:P:qsTtuvW");
++                         "b:Bc:C:D:de:f:g:hH:i:KLNo:O:p:P:qsTtuvW");
                if (c < 0)
                        break;
                switch (c) {
-@@ -183,6 +184,9 @@ int main(int argc, char *argv[])
+@@ -188,6 +189,9 @@ int main(int argc, char *argv[])
                        usage();
                        exitcode = 0;
                        goto out;
index 05f15785700549fc7ca92bc738e39b093b6da727..b6b9182f5fd347c55ea4c9d616e868cbfbbf5b7b 100644 (file)
@@ -55,7 +55,7 @@
  
 --- a/wpa_supplicant/ctrl_iface.c
 +++ b/wpa_supplicant/ctrl_iface.c
-@@ -3665,6 +3665,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -3770,6 +3770,7 @@ char * wpa_supplicant_ctrl_iface_process
                        reply_len = -1;
        } else if (os_strncmp(buf, "NOTE ", 5) == 0) {
                wpa_printf(MSG_INFO, "NOTE: %s", buf + 5);
@@ -63,7 +63,7 @@
        } else if (os_strcmp(buf, "MIB") == 0) {
                reply_len = wpa_sm_get_mib(wpa_s->wpa, reply, reply_size);
                if (reply_len >= 0) {
-@@ -3676,6 +3677,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -3781,6 +3782,7 @@ char * wpa_supplicant_ctrl_iface_process
                        else
                                reply_len += res;
                }
@@ -71,7 +71,7 @@
        } else if (os_strncmp(buf, "STATUS", 6) == 0) {
                reply_len = wpa_supplicant_ctrl_iface_status(
                        wpa_s, buf + 6, reply, reply_size);
-@@ -4020,6 +4022,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -4135,6 +4137,7 @@ char * wpa_supplicant_ctrl_iface_process
                reply_len = wpa_supplicant_ctrl_iface_bss(
                        wpa_s, buf + 4, reply, reply_size);
  #ifdef CONFIG_AP
@@ -79,7 +79,7 @@
        } else if (os_strcmp(buf, "STA-FIRST") == 0) {
                reply_len = ap_ctrl_iface_sta_first(wpa_s, reply, reply_size);
        } else if (os_strncmp(buf, "STA ", 4) == 0) {
-@@ -4028,6 +4031,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -4143,6 +4146,7 @@ char * wpa_supplicant_ctrl_iface_process
        } else if (os_strncmp(buf, "STA-NEXT ", 9) == 0) {
                reply_len = ap_ctrl_iface_sta_next(wpa_s, buf + 9, reply,
                                                   reply_size);
 +
 --- a/src/ap/ieee802_1x.c
 +++ b/src/ap/ieee802_1x.c
-@@ -1912,6 +1912,7 @@ static const char * bool_txt(Boolean boo
+@@ -1922,6 +1922,7 @@ static const char * bool_txt(Boolean boo
        return bool ? "TRUE" : "FALSE";
  }
  
  
  int ieee802_1x_get_mib(struct hostapd_data *hapd, char *buf, size_t buflen)
  {
-@@ -2064,6 +2065,7 @@ int ieee802_1x_get_mib_sta(struct hostap
+@@ -2074,6 +2075,7 @@ int ieee802_1x_get_mib_sta(struct hostap
        return len;
  }
  
index 2735a49838ef2a4bcb03d17a3fdca138b29ea804..13a7cdb80f665bebcaf6dcd2ab64c8100f0a1489 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/ap/hostapd.c
 +++ b/src/ap/hostapd.c
-@@ -767,11 +767,8 @@ int hostapd_setup_interface_complete(str
+@@ -768,11 +768,8 @@ int hostapd_setup_interface_complete(str
        size_t j;
        u8 *prev_addr;
  
@@ -14,7 +14,7 @@
  
        wpa_printf(MSG_DEBUG, "Completing interface initialization");
        if (hapd->iconf->channel) {
-@@ -787,7 +784,7 @@ int hostapd_setup_interface_complete(str
+@@ -788,7 +785,7 @@ int hostapd_setup_interface_complete(str
                                     hapd->iconf->secondary_channel)) {
                        wpa_printf(MSG_ERROR, "Could not set channel for "
                                   "kernel driver");
@@ -23,7 +23,7 @@
                }
        }
  
-@@ -798,7 +795,7 @@ int hostapd_setup_interface_complete(str
+@@ -799,7 +796,7 @@ int hostapd_setup_interface_complete(str
                        hostapd_logger(hapd, NULL, HOSTAPD_MODULE_IEEE80211,
                                       HOSTAPD_LEVEL_WARNING,
                                       "Failed to prepare rates table.");
@@ -32,7 +32,7 @@
                }
        }
  
-@@ -806,14 +803,14 @@ int hostapd_setup_interface_complete(str
+@@ -807,14 +804,14 @@ int hostapd_setup_interface_complete(str
            hostapd_set_rts(hapd, hapd->iconf->rts_threshold)) {
                wpa_printf(MSG_ERROR, "Could not set RTS threshold for "
                           "kernel driver");
@@ -49,7 +49,7 @@
        }
  
        prev_addr = hapd->own_addr;
-@@ -823,7 +820,7 @@ int hostapd_setup_interface_complete(str
+@@ -824,7 +821,7 @@ int hostapd_setup_interface_complete(str
                if (j)
                        os_memcpy(hapd->own_addr, prev_addr, ETH_ALEN);
                if (hostapd_setup_bss(hapd, j == 0))
@@ -58,7 +58,7 @@
                if (hostapd_mac_comp_empty(hapd->conf->bssid) == 0)
                        prev_addr = hapd->own_addr;
        }
-@@ -835,7 +832,7 @@ int hostapd_setup_interface_complete(str
+@@ -836,7 +833,7 @@ int hostapd_setup_interface_complete(str
        if (hostapd_driver_commit(hapd) < 0) {
                wpa_printf(MSG_ERROR, "%s: Failed to commit driver "
                           "configuration", __func__);
@@ -67,7 +67,7 @@
        }
  
        /*
-@@ -859,6 +856,11 @@ int hostapd_setup_interface_complete(str
+@@ -860,6 +857,11 @@ int hostapd_setup_interface_complete(str
                iface->init_complete(iface);
  
        return 0;
index 1ebb006b8d3041854a1daab361a8a83ddbe517a9..da213131487fb9324aed2ca4b5a865a98074258a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/drivers/driver_nl80211.c
 +++ b/src/drivers/driver_nl80211.c
-@@ -6995,8 +6995,6 @@ static int wpa_driver_nl80211_set_mode(s
+@@ -7026,8 +7026,6 @@ static int wpa_driver_nl80211_set_mode(s
                        ret = nl80211_set_mode(drv, drv->ifindex, nlmode);
                        if (ret == -EACCES)
                                break;
@@ -9,7 +9,7 @@
                        if (res && !ret)
                                ret = -1;
                        else if (ret != -EBUSY)
-@@ -7012,6 +7010,7 @@ static int wpa_driver_nl80211_set_mode(s
+@@ -7043,6 +7041,7 @@ static int wpa_driver_nl80211_set_mode(s
                           "interface is down");
                drv->nlmode = nlmode;
                drv->ignore_if_down_event = 1;
index e75f30cf6b1f16545c2ef6137acaa460e32a32e1..c6477a3548e55b12c930fd705934f5407467277c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/ap/wps_hostapd.c
 +++ b/src/ap/wps_hostapd.c
-@@ -855,11 +855,9 @@ int hostapd_init_wps(struct hostapd_data
+@@ -856,11 +856,9 @@ int hostapd_init_wps(struct hostapd_data
  
                if (conf->rsn_pairwise & WPA_CIPHER_CCMP)
                        wps->encr_types |= WPS_ENCR_AES;
@@ -14,7 +14,7 @@
                if (conf->wpa_key_mgmt & WPA_KEY_MGMT_PSK)
                        wps->auth_types |= WPS_AUTH_WPAPSK;
                if (conf->wpa_key_mgmt & WPA_KEY_MGMT_IEEE8021X)
-@@ -867,7 +865,7 @@ int hostapd_init_wps(struct hostapd_data
+@@ -868,7 +866,7 @@ int hostapd_init_wps(struct hostapd_data
  
                if (conf->wpa_pairwise & WPA_CIPHER_CCMP)
                        wps->encr_types |= WPS_ENCR_AES;
index 296bdd3c22cabcc4727e55fba4154b899b58f9ad..08750b0158fd635ab4a7e1ef8d45beb18ff4db21 100644 (file)
@@ -1,6 +1,6 @@
 --- a/hostapd/config_file.c
 +++ b/hostapd/config_file.c
-@@ -1951,6 +1951,10 @@ static int hostapd_config_fill(struct ho
+@@ -1957,6 +1957,10 @@ static int hostapd_config_fill(struct ho
                                           "ht_capab", line);
                                errors++;
                        }
@@ -31,7 +31,7 @@
  #include "ieee802_11_auth.h"
  #include "vlan_init.h"
  #include "wpa_auth.h"
-@@ -306,6 +307,7 @@ static void hostapd_cleanup_iface_pre(st
+@@ -307,6 +308,7 @@ static void hostapd_cleanup_iface_pre(st
  
  static void hostapd_cleanup_iface_partial(struct hostapd_iface *iface)
  {
index ca8abe47f3055545c35663e0f89a04a154264b5a..659e980112b1528954fc9b3c3b9c5b37dc5b95f0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/utils/wpa_debug.c
 +++ b/src/utils/wpa_debug.c
-@@ -118,7 +118,7 @@ static int syslog_priority(int level)
+@@ -201,7 +201,7 @@ void wpa_debug_close_linux_tracing(void)
   *
   * Note: New line '\n' is added to the end of the text when printing to stdout.
   */
@@ -9,7 +9,7 @@
  {
        va_list ap;
  
-@@ -154,8 +154,8 @@ void wpa_printf(int level, const char *f
+@@ -248,8 +248,8 @@ void wpa_printf(int level, const char *f
  }
  
  
@@ -19,8 +19,8 @@
 +                size_t len, int show)
  {
        size_t i;
-       if (level < wpa_debug_level)
-@@ -262,20 +262,9 @@ static void _wpa_hexdump(int level, cons
+@@ -375,20 +375,9 @@ static void _wpa_hexdump(int level, cons
  #endif /* CONFIG_ANDROID_LOG */
  }
  
@@ -43,7 +43,7 @@
  {
        size_t i, llen;
        const u8 *pos = buf;
-@@ -363,19 +352,6 @@ static void _wpa_hexdump_ascii(int level
+@@ -495,19 +484,6 @@ static void _wpa_hexdump_ascii(int level
  }
  
  
@@ -63,7 +63,7 @@
  #ifdef CONFIG_DEBUG_FILE
  static char *last_path = NULL;
  #endif /* CONFIG_DEBUG_FILE */
-@@ -459,7 +435,7 @@ void wpa_msg_register_ifname_cb(wpa_msg_
+@@ -591,7 +567,7 @@ void wpa_msg_register_ifname_cb(wpa_msg_
  }
  
  
@@ -72,7 +72,7 @@
  {
        va_list ap;
        char *buf;
-@@ -493,7 +469,7 @@ void wpa_msg(void *ctx, int level, const
+@@ -625,7 +601,7 @@ void wpa_msg(void *ctx, int level, const
  }
  
  
index 7d8b1b5c8a99b324800e81df06cabf4326f1aba5..257928c7468a0b2ab5d33fa43b6bee88b30ecf40 100644 (file)
  #include "wpa_supplicant_i.h"
  #include "driver_i.h"
  
-@@ -140,7 +141,7 @@ int main(int argc, char *argv[])
-       wpa_supplicant_fd_workaround();
+@@ -145,7 +146,7 @@ int main(int argc, char *argv[])
  
        for (;;) {
--              c = getopt(argc, argv, "b:Bc:C:D:de:f:g:hH:i:KLNo:O:p:P:qstuvW");
-+              c = getopt(argc, argv, "b:Bc:C:D:de:f:g:hH:i:KLNo:O:p:P:qstuv::W");
+               c = getopt(argc, argv,
+-                         "b:Bc:C:D:de:f:g:hH:i:KLNo:O:p:P:qsTtuvW");
++                         "b:Bc:C:D:de:f:g:hH:i:KLNo:O:p:P:qsTtuv::W");
                if (c < 0)
                        break;
                switch (c) {
-@@ -227,8 +228,12 @@ int main(int argc, char *argv[])
+@@ -237,8 +238,12 @@ int main(int argc, char *argv[])
                        break;
  #endif /* CONFIG_DBUS */
                case 'v':
diff --git a/package/hostapd/patches/580-fix_bss_addr.patch b/package/hostapd/patches/580-fix_bss_addr.patch
new file mode 100644 (file)
index 0000000..fffa25e
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/drivers/driver_nl80211.c
++++ b/src/drivers/driver_nl80211.c
+@@ -7607,7 +7607,7 @@ static int i802_set_wds_sta(void *priv, 
+               if (!if_nametoindex(name)) {
+                       if (nl80211_create_iface(drv, name,
+                                                NL80211_IFTYPE_AP_VLAN,
+-                                               NULL, 1) < 0)
++                                               bss->addr, 1) < 0)
+                               return -1;
+                       if (bridge_ifname &&
+                           linux_br_add_if(drv->global->ioctl_sock,