add support for more network devices,
authorNicolas Thill <nico@openwrt.org>
Sun, 23 Oct 2005 23:45:39 +0000 (23:45 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 23 Oct 2005 23:45:39 +0000 (23:45 +0000)
start menuconfig reorg.

SVN-Revision: 2294

14 files changed:
openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-natsemi.control [deleted file]
openwrt/target/linux/control/kmod-net-3c59x.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-net-8139too.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-net-airo.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-net-hermes-pci.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-net-hermes-plx.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-net-hermes.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-net-natsemi.control [new file with mode: 0644]
openwrt/target/linux/control/kmod-net-prism54.control [new file with mode: 0644]
openwrt/target/linux/linux-2.4/Makefile
openwrt/target/linux/linux-2.4/config/x86
openwrt/target/linux/linux-2.4/config/x86.modules
openwrt/target/linux/linux-2.4/x86.mk

index 8a2799f32caff36fc1697794973eab898269f02e..c43f25d30e1eff38fb7905c4bb477b5d8c4b826b 100644 (file)
@@ -349,51 +349,202 @@ config BR2_PACKAGE_KMOD_SCHED
        help
          Kernel schedulers for IP traffic
 
+comment "Multimedia devices support ---"
+
+config BR2_PACKAGE_KMOD_VIDEODEV
+       tristate "kmod-videodev - Video (For Linux) kernel support"
+       default m
+
+config BR2_PACKAGE_KMOD_PWC
+       tristate "kmod-pwc - Kernel driver for USB Philips Cameras"
+       default m
+
+comment "Native language support ---"
+
 config BR2_PACKAGE_KMOD_NLS_BASE
-       tristate "basic native language support for filesystems"
+       tristate "kmod-nls-base - Basic native language support for filesystems"
        default m
        help
          Kernel native language support
 
 config BR2_PACKAGE_KMOD_NLS_CP437
-       tristate "code page 437"
+       tristate "kmod-nls-cp437 - Codepage 437 (United States, Canada)"
        default m
+       select BR2_PACKAGE_KMOD_NLS_BASE
        help
          Kernel native language support
 
 config BR2_PACKAGE_KMOD_NLS_CP850
-       tristate "code page 850"
+       tristate "kmod-nls-cp850 - Codepage 850 (Europe)"
        default m
+       select BR2_PACKAGE_KMOD_NLS_BASE
        help
          Kernel native language support
 
-config BR2_PACKAGE_KMOD_NLS_UTF8
-       tristate "utf8"
+config BR2_PACKAGE_KMOD_NLS_IS08859_1
+       tristate "kmod-nls-iso8859-1 -  NLS ISO 8859-1  (Latin 1; Western European Languages)"
        default m
+       select BR2_PACKAGE_KMOD_NLS_BASE
        help
          Kernel native language support
 
-config BR2_PACKAGE_KMOD_NLS_IS08859_1
-       tristate "iso8859-1"
+config BR2_PACKAGE_KMOD_NLS_IS08859_15
+       tristate "kmod-nls-iso8859-15 -  NLS ISO 8859-15  (Latin 15; Western European Languages with Euro)"
        default m
+       select BR2_PACKAGE_KMOD_NLS_BASE
        help
          Kernel native language support
 
-config BR2_PACKAGE_KMOD_VIDEODEV
-       tristate "Video (For Linux) kernel support"
+config BR2_PACKAGE_KMOD_NLS_UTF8
+       tristate "kmod-nls-utf8 - NLS UTF8"
        default m
+       select BR2_PACKAGE_KMOD_NLS_BASE
+       help
+         Kernel native language support
 
-config BR2_PACKAGE_KMOD_PWC
-       tristate "Kernel driver for USB Philips Cameras"
+comment "Network devices support ---"
+
+config BR2_PACKAGE_KMOD_NET_3C59X
+       tristate "kmod-net-3C59x - 3Com 3c590/3c900 series (592/595/597) \"Vortex/Boomerang\" Ethernet kernel support"
        default m
+       help
+         This option enables driver support for a large number of 10mbps and 
+         10/100mbps EISA, PCI and PCMCIA 3Com network cards:
+         
+          * "Vortex"    (Fast EtherLink 3c590/3c592/3c595/3c597) EISA and PCI
+          * "Boomerang" (EtherLink XL 3c900 or 3c905)            PCI
+          * "Cyclone"   (3c540/3c900/3c905/3c980/3c575/3c656)    PCI and Cardbus
+          * "Tornado"   (3c905)                                  PCI
+          * "Hurricane" (3c555/3cSOHO)                           PCI
+         
+         This package contains the 3c59x.o kernel module.
+         
 
-config BR2_PACKAGE_KMOD_NATSEMI
-       tristate "Soekris net4801 ethernet driver"
-       default y
-       depends BR2_LINUX_2_4_X86
+config BR2_PACKAGE_KMOD_NET_8139TOO
+       tristate "kmod-net-8139too - RealTek RTL-8139 PCI Fast Ethernet Adapter kernel support"
+       default m
        help
-         Driver for the National Semiconductor DP8381x series PCI Ethernet 
-         found on Soekris net4801 boards
+         This is a driver for the Fast Ethernet PCI network cards based on 
+         the RTL8139 chips.
+         
+         This package contains the 8139too.o and mii.o kernel modules.
+         
+
+config BR2_PACKAGE_KMOD_NET_AIRO
+       tristate "kmod-net-airo - Cisco/Aironet 34X/35X/4500/4800 ISA and PCI cards kernel support"
+       default m
+       help
+         This is the standard Linux driver to support Cisco/Aironet ISA and 
+         PCI 802.11 wireless cards.
+         It supports the new 802.11b cards from Cisco (Cisco 34X, Cisco 35X 
+         - with or without encryption) as well as card before the Cisco 
+         acquisition (Aironet 4500, Aironet 4800, Aironet 4800B).
+         
+         This driver support both the standard Linux Wireless Extensions 
+         and Cisco proprietary API, so both the Linux Wireless Tools and the 
+         Cisco Linux utilities can be used to configure the card.
+         
+         This package contains the airo.o kernel module.
+         
+
+config BR2_PACKAGE_KMOD_NET_HERMES
+       tristate "kmod-net-hermes - Hermes chipset 802.11b support (Orinoco/Prism2/Symbol) kernel support"
+       default m
+       help
+         A driver for 802.11b wireless cards based based on the "Hermes" or 
+         Intersil HFA384x (Prism 2) MAC controller.  This includes the vast 
+         majority of the PCMCIA 802.11b cards (which are nearly all rebadges) 
+         - except for the Cisco/Aironet cards.  Cards supported include the 
+         Apple Airport (not a PCMCIA card), WavelanIEEE/Orinoco, 
+         Cabletron/EnteraSys Roamabout, ELSA AirLancer, MELCO Buffalo, Avaya, 
+         IBM High Rate Wireless, Farralon Syyline, Samsung MagicLAN, Netgear 
+         MA401, LinkSys WPC-11, D-Link DWL-650, 3Com AirConnect, Intel 
+         PRO/Wireless, and Symbol Spectrum24 High Rate amongst others.
+         
+         This package contains the hermes.o and orinoco.o kernel modules.
+         
+
+config BR2_PACKAGE_KMOD_NET_HERMES_PCI
+       tristate "kmod-net-hermes-pci - Intersil Prism 2.5 PCI 802.11b adaptor support"
+       default m
+       depends BR2_PACKAGE_KMOD_NET_HERMES
+       help
+         Enable support for PCI and mini-PCI 802.11b wireless NICs based on 
+         the Prism 2.5 chipset.  These are true PCI cards, not the 802.11b 
+         PCMCIA cards bundled with PCI<->PCMCIA adaptors which are also 
+         common.  Some of the built-in wireless adaptors in laptops are of 
+         this variety.
+         
+         This package contains the orinoco_pci.o kernel module.
+         
+
+config BR2_PACKAGE_KMOD_NET_HERMES_PLX
+       tristate "kmod-net-hermes-plx - Hermes in PLX9052 based PCI adaptor (Netgear MA301, etc.) kernel support"
+       default m
+       depends BR2_PACKAGE_KMOD_NET_HERMES
+       help
+         Enable support for PCMCIA cards supported by the "Hermes" (aka 
+         orinoco_cs) driver when used in PLX9052 based PCI adaptors.  These 
+         adaptors are not a full PCMCIA controller but act as a more limited 
+         PCI <-> PCMCIA bridge.  Several vendors sell such adaptors so that 
+         802.11b PCMCIA cards can be used in desktop machines.  The Netgear 
+         MA301 is such an adaptor.
+         
+         This package contains the orinoco_plx.o kernel module.
+         
+
+config BR2_PACKAGE_KMOD_NET_NATSEMI
+       tristate "kmod-net-natsemi - National Semiconductor DP8381x series PCI Ethernet kernel support"
+       default m
+       help
+         This driver is for the National Semiconductor DP83810 series, 
+         which is used in cards from PureData, NetGear, Linksys 
+         and others, including the 83815 chip.
+         
+         This package contains the natsemi.o kernel module.
+         
+
+config BR2_PACKAGE_KMOD_NET_PRISM54
+       tristate "kmod-net-prism54 - Intersil Prism GT/Duette/Indigo PCI/PCMCIA cards kernel support"
+       default m
+       help
+         Enable PCI and Cardbus support for the following chipset based cards: 
+         
+          * ISL3880 - Prism GT       802.11 b/g
+          * ISL3877 - Prism Indigo   802.11 a
+          * ISL3890 - Prism Duette   802.11 a/b/g
+         
+         For a complete list of supported cards visit <http://prism54.org>.
+         Here is the latest confirmed list of supported cards: 
+         
+          * 3com OfficeConnect 11g Cardbus Card aka 3CRWE154G72
+          * Allnet ALL0271 PCI Card
+          * Compex WL54G Cardbus Card
+          * Corega CG-WLCB54GT Cardbus Card
+          * D-Link Air Plus Xtreme G A1 Cardbus Card aka DWL-g650
+          * I-O Data WN-G54/CB Cardbus Card
+          * Kobishi XG-300 aka Z-Com Cardbus Card
+          * Netgear WG511 Cardbus Card
+          * Ovislink WL-5400PCI PCI Card
+          * Peabird WLG-PCI PCI Card
+          * Sitecom WL-100i Cardbus Card
+          * Sitecom WL-110i PCI Card
+          * SMC2802W - EZ Connect g 2.4GHz 54 Mbps Wireless PCI Card
+          * SMC2835W - EZ Connect g 2.4GHz 54 Mbps Wireless Cardbus Card
+          * Z-Com XG-900 PCI Card
+          * Zyxel G-100 Cardbus Card
+         
+         If you enable this, you require a firmware file as well.
+         You will need to copy this to /usr/lib/hotplug/firmware/isl3890.
+         You can get this non-GPL'd firmware file from the Prism54 project page: 
+         <http://prism54.org>.
+         
+         Note: You need a motherboard with DMA support to use any of these cards.
+         
+         This package contains the prism54.o kernel module.
+         
+
+comment "Misc. device support ---"
 
 config BR2_PACKAGE_KMOD_WD1100
        tristate "Soekris net4801 watchdog"
@@ -403,4 +554,6 @@ config BR2_PACKAGE_KMOD_WD1100
          Driver for the NatSemi SC1x00 series Watchdog 
          found on Soekris net4801 boards
 
+comment "Additional kernel modules ---"
+
 source "target/linux/package/Config.in"
diff --git a/openwrt/target/linux/control/kmod-natsemi.control b/openwrt/target/linux/control/kmod-natsemi.control
deleted file mode 100644 (file)
index 70af8ce..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: kmod-natsemi
-Priority: optional
-Section: sys
-Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
-Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/target/linux/
-Description: National Semiconductor DP8381x series PCI Ethernet kernel support
diff --git a/openwrt/target/linux/control/kmod-net-3c59x.control b/openwrt/target/linux/control/kmod-net-3c59x.control
new file mode 100644 (file)
index 0000000..8d2b880
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-net-3c59x
+Priority: optional
+Section: sys
+Description: 3Com 3c590/3c900 series (592/595/597) "Vortex/Boomerang" cards kernel support
diff --git a/openwrt/target/linux/control/kmod-net-8139too.control b/openwrt/target/linux/control/kmod-net-8139too.control
new file mode 100644 (file)
index 0000000..a3ad9af
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-net-8139too
+Priority: optional
+Section: sys
+Description: RealTek RTL-8139 PCI Fast Ethernet Adapter kernel support
diff --git a/openwrt/target/linux/control/kmod-net-airo.control b/openwrt/target/linux/control/kmod-net-airo.control
new file mode 100644 (file)
index 0000000..3693df5
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-net-airo
+Priority: optional
+Section: sys
+Description: Cisco/Aironet 34X/35X/4500/4800 ISA and PCI cards kernel support
diff --git a/openwrt/target/linux/control/kmod-net-hermes-pci.control b/openwrt/target/linux/control/kmod-net-hermes-pci.control
new file mode 100644 (file)
index 0000000..911609d
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-net-hermes-pci
+Priority: optional
+Section: sys
+Description: Intersil Prism 2.5 PCI 802.11b adaptor support
diff --git a/openwrt/target/linux/control/kmod-net-hermes-plx.control b/openwrt/target/linux/control/kmod-net-hermes-plx.control
new file mode 100644 (file)
index 0000000..8df0727
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-net-hermes-plx
+Priority: optional
+Section: sys
+Description: Hermes in PLX9052 based PCI adaptor (Netgear MA301, etc.) kernel support
diff --git a/openwrt/target/linux/control/kmod-net-hermes.control b/openwrt/target/linux/control/kmod-net-hermes.control
new file mode 100644 (file)
index 0000000..7fa91a9
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-net-hermes
+Priority: optional
+Section: sys
+Description: Hermes chipset 802.11b support (Orinoco/Prism2/Symbol) kernel support
diff --git a/openwrt/target/linux/control/kmod-net-natsemi.control b/openwrt/target/linux/control/kmod-net-natsemi.control
new file mode 100644 (file)
index 0000000..740ade6
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-net-natsemi
+Priority: optional
+Section: sys
+Description: National Semiconductor DP8381x series PCI Ethernet kernel support
diff --git a/openwrt/target/linux/control/kmod-net-prism54.control b/openwrt/target/linux/control/kmod-net-prism54.control
new file mode 100644 (file)
index 0000000..2ba3111
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-net-prism54
+Priority: optional
+Section: sys
+Description: Intersil Prism GT/Duette/Indigo PCI/PCMCIA cards kernel support
index 2b8a186fc32e2f0265f96773b223c82cfd648d48..2fdf1ebb585d5a06fcff676fb03df5ac305e6466 100644 (file)
@@ -187,16 +187,53 @@ endif
 $(eval $(call KMOD_template,SCHED,sched,\
        $(MODULES_DIR)/kernel/net/sched/*.o \
 ,CONFIG_SCHED))
+
 $(eval $(call KMOD_template,VIDEODEV,videodev,\
        $(MODULES_DIR)/kernel/drivers/media/video/videodev.o \
-,CONFIG_VIDEO_DEV))
+,CONFIG_VIDEO_DEV,,62,videodev))
+
 $(eval $(call KMOD_template,PWC,pwc,\
        $(MODULES_DIR)/kernel/drivers/usb/pwc.o \
-,CONFIG_USB_PWC))
+,CONFIG_USB_PWC,kmod-videodev,63,pwc))
+
 $(eval $(call KMOD_template,AX25,ax25,\
        $(MODULES_DIR)/kernel/net/ax25/ax25.o \
        $(MODULES_DIR)/kernel/drivers/net/hamradio/mkiss.o \
-,CONFIG_AX25))
+,CONFIG_AX25,,90,ax25 mkiss))
+
+$(eval $(call KMOD_template,NET_3C59X,net-3c59x,\
+       $(MODULES_DIR)/kernel/drivers/net/3c59x.o \
+,CONFIG_VORTEX,,10,3c59x))
+
+$(eval $(call KMOD_template,NET_8139TOO,net-8139too,\
+       $(MODULES_DIR)/kernel/drivers/net/8139too.o \
+       $(MODULES_DIR)/kernel/drivers/net/mii.o \
+,CONFIG_VORTEX,,10,mii 8139too))
+
+$(eval $(call KMOD_template,NET_AIRO,net-airo,\
+       $(MODULES_DIR)/kernel/drivers/net/wireless/airo.o \
+,CONFIG_AIRO,,10,airo))
+
+$(eval $(call KMOD_template,NET_HERMES,net-hermes,\
+       $(MODULES_DIR)/kernel/drivers/net/wireless/hermes.o \
+       $(MODULES_DIR)/kernel/drivers/net/wireless/orinoco.o \
+,CONFIG_HERMES,,10,hermes orinoco))
+
+$(eval $(call KMOD_template,NET_HERMES_PCI,net-hermes-pci,\
+       $(MODULES_DIR)/kernel/drivers/net/wireless/orinoco_pci.o \
+,CONFIG_PCI_HERMES,kmod-net-hermes,11,orinoco_pci))
+
+$(eval $(call KMOD_template,NET_HERMES_PCI,net-hermes-plx,\
+       $(MODULES_DIR)/kernel/drivers/net/wireless/orinoco_plx.o \
+,CONFIG_PLX_HERMES,kmod-net-hermes,11,orinoco_plx))
+
+$(eval $(call KMOD_template,NET_NATSEMI,net-natsemi,\
+       $(MODULES_DIR)/kernel/drivers/net/natsemi.o \
+,CONFIG_NATSEMI,,10,natsemi))
+
+$(eval $(call KMOD_template,NET_PRISM54,net-prism54,\
+       $(MODULES_DIR)/kernel/drivers/net/wireless/prism54/prism54.o \
+,CONFIG_PRISM54,,10,prism54))
 
 $(TARGETS): $(PACKAGE_DIR)
 
index 92892b180eb650e90478c7c8ce265c0d9aa610d4..fbae7653b0382e59a4d0333093a5c3039dd3cdb3 100644 (file)
@@ -671,7 +671,17 @@ CONFIG_NET_ETHERNET=y
 # CONFIG_SUNBMAC is not set
 # CONFIG_SUNQE is not set
 # CONFIG_SUNGEM is not set
-# CONFIG_NET_VENDOR_3COM is not set
+CONFIG_NET_VENDOR_3COM=y
+# CONFIG_EL1 is not set
+# CONFIG_EL2 is not set
+# CONFIG_ELPLUS is not set
+# CONFIG_EL16 is not set
+# CONFIG_EL3 is not set
+# CONFIG_3C515 is not set
+# CONFIG_ELMC is not set
+# CONFIG_ELMC_II is not set
+CONFIG_VORTEX=m
+# CONFIG_TYPHOON is not set
 # CONFIG_LANCE is not set
 # CONFIG_NET_VENDOR_SMC is not set
 # CONFIG_NET_VENDOR_RACAL is not set
@@ -702,7 +712,7 @@ CONFIG_NATSEMI=m
 # CONFIG_NE3210 is not set
 # CONFIG_ES3210 is not set
 # CONFIG_8139CP is not set
-# CONFIG_8139TOO is not set
+CONFIG_8139TOO=m
 # CONFIG_8139TOO_PIO is not set
 # CONFIG_8139TOO_TUNE_TWISTER is not set
 # CONFIG_8139TOO_8129 is not set
@@ -754,11 +764,11 @@ CONFIG_NET_RADIO=y
 # CONFIG_AIRONET4500 is not set
 # CONFIG_AIRONET4500_NONCS is not set
 # CONFIG_AIRONET4500_PROC is not set
-# CONFIG_AIRO is not set
-# CONFIG_HERMES is not set
-# CONFIG_PLX_HERMES is not set
+CONFIG_AIRO=m
+CONFIG_HERMES=m
+CONFIG_PLX_HERMES=m
 # CONFIG_TMD_HERMES is not set
-# CONFIG_PCI_HERMES is not set
+CONFIG_PCI_HERMES=m
 
 #
 # Wireless Pcmcia cards support
@@ -770,7 +780,8 @@ CONFIG_NET_RADIO=y
 #
 # Prism54 PCI/PCMCIA GT/Duette Driver - 802.11(a/b/g)
 #
-# CONFIG_PRISM54 is not set
+CONFIG_PRISM54=m
+CONFIG_FW_LOADER=m
 CONFIG_NET_WIRELESS=y
 
 #
@@ -1079,10 +1090,10 @@ CONFIG_NLS=y
 # Native Language Support
 #
 CONFIG_NLS_DEFAULT="iso8859-1"
-# CONFIG_NLS_CODEPAGE_437 is not set
+CONFIG_NLS_CODEPAGE_437=m
 # CONFIG_NLS_CODEPAGE_737 is not set
 # CONFIG_NLS_CODEPAGE_775 is not set
-# CONFIG_NLS_CODEPAGE_850 is not set
+CONFIG_NLS_CODEPAGE_850=m
 # CONFIG_NLS_CODEPAGE_852 is not set
 # CONFIG_NLS_CODEPAGE_855 is not set
 # CONFIG_NLS_CODEPAGE_857 is not set
@@ -1102,7 +1113,7 @@ CONFIG_NLS_DEFAULT="iso8859-1"
 # CONFIG_NLS_ISO8859_8 is not set
 # CONFIG_NLS_CODEPAGE_1250 is not set
 # CONFIG_NLS_CODEPAGE_1251 is not set
-# CONFIG_NLS_ISO8859_1 is not set
+CONFIG_NLS_ISO8859_1=m
 # CONFIG_NLS_ISO8859_2 is not set
 # CONFIG_NLS_ISO8859_3 is not set
 # CONFIG_NLS_ISO8859_4 is not set
@@ -1112,10 +1123,10 @@ CONFIG_NLS_DEFAULT="iso8859-1"
 # CONFIG_NLS_ISO8859_9 is not set
 # CONFIG_NLS_ISO8859_13 is not set
 # CONFIG_NLS_ISO8859_14 is not set
-# CONFIG_NLS_ISO8859_15 is not set
+CONFIG_NLS_ISO8859_15=m
 # CONFIG_NLS_KOI8_R is not set
 # CONFIG_NLS_KOI8_U is not set
-# CONFIG_NLS_UTF8 is not set
+CONFIG_NLS_UTF8=m
 
 #
 # Multimedia devices
@@ -1401,4 +1412,4 @@ CONFIG_CRYPTO_MICHAEL_MIC=m
 # CONFIG_CRC32 is not set
 CONFIG_ZLIB_INFLATE=y
 CONFIG_ZLIB_DEFLATE=y
-# CONFIG_FW_LOADER is not set
+CONFIG_FW_LOADER=m
index 7fd95a5d381f311c6fe62e2a8e7438b0c2ec5515..8b137891791fe96927ad78e64b0aad7bded08bdc 100644 (file)
@@ -1 +1 @@
-natsemi
+
index 8b308a0a52a573486da502701d86384ee051dedf..0753b10cce568b6d42687a0b9e626f750a3d284c 100644 (file)
@@ -1,10 +1,7 @@
 # $Id$
 
-# soekris specific kmod packages
+# x86 specific kmod packages
 
-$(eval $(call KMOD_template,NATSEMI,natsemi,\
-       $(MODULES_DIR)/kernel/drivers/net/natsemi.o \
-,CONFIG_NATSEMI))
 $(eval $(call KMOD_template,WD1100,wd1100,\
        $(MODULES_DIR)/kernel/drivers/char/wd1100.o \
 ,CONFIG_WD1100))