wpa_supplicant has been upgraded and previous version
authorFelix Fietkau <nbd@openwrt.org>
Mon, 22 Dec 2008 19:09:12 +0000 (19:09 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 22 Dec 2008 19:09:12 +0000 (19:09 +0000)
0.6.3 doesn't exist anymore. This patch sets the version and
appropriate md5sum; it also updates all the patches. Note
that patch 130 has been deleted since it seems to be already
included in 0.6.6

Signed-off-by: Jose Vasconcellos <jvasco@verizon.net>
SVN-Revision: 13723

package/wpa_supplicant/Makefile
package/wpa_supplicant/patches/100-timestamp_check.patch
package/wpa_supplicant/patches/110-roaming.patch
package/wpa_supplicant/patches/130-scanning.patch
package/wpa_supplicant/patches/140-quality.patch

index ed6e45588e6bf66521974e1f6190c98ccfd3503b..de5607384da220bbc8d308969ea7cee276f0b1fe 100644 (file)
@@ -9,14 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wpa_supplicant
-PKG_VERSION:=0.6.3
+PKG_VERSION:=0.6.6
 PKG_RELEASE:=1
-PKG_MD5SUM:=b51b2975f21006f85f7297f3fb1acde1
+PKG_MD5SUM:=cd0b386bdf4b0b3b01516e36cb6977d1
 
 PKG_SOURCE_URL:=http://hostap.epitest.fi/releases
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
-PKG_BUILD_DEPENDS:=madwifi
+PKG_BUILD_DEPENDS:=PACKAGE_kmod-madwifi:madwifi
 
 include $(INCLUDE_DIR)/package.mk
 STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_kmod-madwifi CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK)
index d994a65ae9baf4825bf2601a8823c7170758c5dd..66f877f97295d365bcaacbff7ac2424be8ca6c63 100644 (file)
@@ -1,8 +1,8 @@
-Index: wpa_supplicant-0.6.3/src/tls/x509v3.c
+Index: wpa_supplicant-0.6.6/src/tls/x509v3.c
 ===================================================================
---- wpa_supplicant-0.6.3.orig/src/tls/x509v3.c 2008-02-23 03:45:24.000000000 +0100
-+++ wpa_supplicant-0.6.3/src/tls/x509v3.c      2008-07-09 12:47:19.000000000 +0200
-@@ -1551,8 +1551,11 @@
+--- wpa_supplicant-0.6.6.orig/src/tls/x509v3.c 2008-02-23 03:45:24.000000000 +0100
++++ wpa_supplicant-0.6.6/src/tls/x509v3.c      2008-07-09 12:47:19.000000000 +0200
+@@ -1591,8 +1591,11 @@
                if (chain_trusted)
                        continue;
  
index 8c6210da1dc0b8d932d5a3224cc3d32b2511fcd9..b552dfc425d84143efe76f392d15e96a403f2af9 100644 (file)
@@ -1,9 +1,9 @@
 This patch decreases the timeouts for assoc/auth to more realistic values. Improves roaming speed
-Index: wpa_supplicant-0.6.3/wpa_supplicant/events.c
+Index: wpa_supplicant-0.6.6/wpa_supplicant/events.c
 ===================================================================
---- wpa_supplicant-0.6.3.orig/wpa_supplicant/events.c  2008-02-23 03:45:24.000000000 +0100
-+++ wpa_supplicant-0.6.3/wpa_supplicant/events.c       2008-07-09 15:13:37.000000000 +0200
-@@ -762,7 +762,7 @@
+--- wpa_supplicant-0.6.6.orig/wpa_supplicant/events.c  2008-02-23 03:45:24.000000000 +0100
++++ wpa_supplicant-0.6.6/wpa_supplicant/events.c       2008-07-09 15:13:37.000000000 +0200
+@@ -807,7 +807,7 @@
                wpa_supplicant_set_state(wpa_s, WPA_COMPLETED);
        } else if (!ft_completed) {
                /* Timeout for receiving the first EAPOL packet */
@@ -12,11 +12,11 @@ Index: wpa_supplicant-0.6.3/wpa_supplicant/events.c
        }
        wpa_supplicant_cancel_scan(wpa_s);
  
-Index: wpa_supplicant-0.6.3/wpa_supplicant/scan.c
+Index: wpa_supplicant-0.6.6/wpa_supplicant/scan.c
 ===================================================================
---- wpa_supplicant-0.6.3.orig/wpa_supplicant/scan.c    2008-02-23 03:45:24.000000000 +0100
-+++ wpa_supplicant-0.6.3/wpa_supplicant/scan.c 2008-07-09 15:13:37.000000000 +0200
-@@ -144,6 +144,7 @@
+--- wpa_supplicant-0.6.6.orig/wpa_supplicant/scan.c    2008-02-23 03:45:24.000000000 +0100
++++ wpa_supplicant-0.6.6/wpa_supplicant/scan.c 2008-07-09 15:13:37.000000000 +0200
+@@ -145,6 +145,7 @@
                return;
        }
  
@@ -24,7 +24,7 @@ Index: wpa_supplicant-0.6.3/wpa_supplicant/scan.c
        if (wpa_s->use_client_mlme) {
                ieee80211_sta_set_probe_req_ie(wpa_s, extra_ie, extra_ie_len);
                ret = ieee80211_sta_req_scan(wpa_s, ssid ? ssid->ssid : NULL,
-@@ -156,7 +157,7 @@
+@@ -157,7 +158,7 @@
  
        if (ret) {
                wpa_printf(MSG_WARNING, "Failed to initiate AP scan.");
@@ -33,19 +33,20 @@ Index: wpa_supplicant-0.6.3/wpa_supplicant/scan.c
        }
  }
  
-Index: wpa_supplicant-0.6.3/wpa_supplicant/wpa_supplicant.c
+Index: wpa_supplicant-0.6.6/wpa_supplicant/wpa_supplicant.c
 ===================================================================
---- wpa_supplicant-0.6.3.orig/wpa_supplicant/wpa_supplicant.c  2008-02-23 03:45:24.000000000 +0100
-+++ wpa_supplicant-0.6.3/wpa_supplicant/wpa_supplicant.c       2008-07-09 15:13:37.000000000 +0200
-@@ -1092,9 +1092,9 @@
-               /* Timeout for IEEE 802.11 authentication and association */
-               int timeout;
-               if (assoc_failed)
--                      timeout = 5;
-+                      timeout = 2;
-               else if (wpa_s->conf->ap_scan == 1)
--                      timeout = 10;
-+                      timeout = 3;
-               else
-                       timeout = 60;
+--- wpa_supplicant-0.6.6/wpa_supplicant/wpa_supplicant.c-old   2008-09-20 22:37:09.000000000 -0400
++++ wpa_supplicant-0.6.6/wpa_supplicant/wpa_supplicant.c       2008-09-20 22:37:43.000000000 -0400
+@@ -1118,10 +1118,10 @@
+               if (assoc_failed) {
+                       /* give IBSS a bit more time */
+-                      timeout = ssid->mode ? 10 : 5;
++                      timeout = ssid->mode ? 5 : 2;
+               } else if (wpa_s->conf->ap_scan == 1) {
+                       /* give IBSS a bit more time */
+-                      timeout = ssid->mode ? 20 : 10;
++                      timeout = ssid->mode ? 7 : 3;
+               }
                wpa_supplicant_req_auth_timeout(wpa_s, timeout, 0);
+       }
index c5e252599358a2c994da89bc9ba13d3dbff667ac..4580cf941986325257bf749376878d5893c712c0 100644 (file)
@@ -17,7 +17,7 @@ Add a scan result cache to improve roaming speed if the driver gave us a backgro
         * If this is specified, %wpa_supplicant will open a control interface
 --- a/wpa_supplicant/config_file.c
 +++ b/wpa_supplicant/config_file.c
-@@ -312,6 +312,13 @@
+@@ -313,6 +313,13 @@
        return 0;
  }
  
@@ -31,7 +31,7 @@ Add a scan result cache to improve roaming speed if the driver gave us a backgro
  
  static int wpa_config_process_fast_reauth(struct wpa_config *config, char *pos)
  {
-@@ -445,6 +452,9 @@
+@@ -446,6 +453,9 @@
        if (os_strncmp(pos, "ap_scan=", 8) == 0)
                return wpa_config_process_ap_scan(config, pos + 8);
  
@@ -41,7 +41,7 @@ Add a scan result cache to improve roaming speed if the driver gave us a backgro
        if (os_strncmp(pos, "fast_reauth=", 12) == 0)
                return wpa_config_process_fast_reauth(config, pos + 12);
  
-@@ -810,6 +820,8 @@
+@@ -819,6 +831,8 @@
                fprintf(f, "eapol_version=%d\n", config->eapol_version);
        if (config->ap_scan != DEFAULT_AP_SCAN)
                fprintf(f, "ap_scan=%d\n", config->ap_scan);
@@ -52,7 +52,7 @@ Add a scan result cache to improve roaming speed if the driver gave us a backgro
  #ifdef EAP_TLS_OPENSSL
 --- a/wpa_supplicant/events.c
 +++ b/wpa_supplicant/events.c
-@@ -555,6 +555,9 @@
+@@ -601,6 +601,9 @@
        if (wpa_s->conf->ap_scan == 2 || wpa_s->disconnected)
                return;
  
@@ -62,7 +62,7 @@ Add a scan result cache to improve roaming speed if the driver gave us a backgro
        while (selected == NULL) {
                for (prio = 0; prio < wpa_s->conf->num_prio; prio++) {
                        selected = wpa_supplicant_select_bss(
-@@ -567,6 +570,7 @@
+@@ -613,6 +616,7 @@
                        wpa_printf(MSG_DEBUG, "No APs found - clear blacklist "
                                   "and try again");
                        wpa_blacklist_clear(wpa_s);
@@ -70,7 +70,7 @@ Add a scan result cache to improve roaming speed if the driver gave us a backgro
                } else if (selected == NULL) {
                        break;
                }
-@@ -594,10 +598,12 @@
+@@ -640,10 +644,12 @@
                rsn_preauth_scan_results(wpa_s->wpa, wpa_s->scan_res);
        } else {
                wpa_printf(MSG_DEBUG, "No suitable AP found.");
@@ -84,7 +84,7 @@ Add a scan result cache to improve roaming speed if the driver gave us a backgro
        return;
  
  req_scan:
-@@ -804,6 +810,9 @@
+@@ -847,6 +853,9 @@
        }
        if (wpa_s->wpa_state >= WPA_ASSOCIATED)
                wpa_supplicant_req_scan(wpa_s, 0, 100000);
@@ -97,14 +97,14 @@ Add a scan result cache to improve roaming speed if the driver gave us a backgro
 --- a/wpa_supplicant/wpa_supplicant_i.h
 +++ b/wpa_supplicant/wpa_supplicant_i.h
 @@ -334,6 +334,7 @@
-       struct wpa_client_mlme mlme;
-       int use_client_mlme;
-       int driver_4way_handshake;
+       struct wpa_client_mlme mlme;
+       int use_client_mlme;
+       int driver_4way_handshake;
 +      struct os_time last_scan_results;
- };
-@@ -381,6 +382,7 @@
+
+       int pending_mic_error_report;
+       int pending_mic_error_pairwise;
+@@ -385,6 +387,7 @@
  
  /* scan.c */
  void wpa_supplicant_req_scan(struct wpa_supplicant *wpa_s, int sec, int usec);
@@ -147,7 +147,7 @@ Add a scan result cache to improve roaming speed if the driver gave us a backgro
                           "first without requesting a new scan to speed up "
 --- a/wpa_supplicant/wpa_supplicant.c
 +++ b/wpa_supplicant/wpa_supplicant.c
-@@ -1417,6 +1417,9 @@
+@@ -1441,6 +1441,9 @@
  {
        struct wpa_supplicant *wpa_s = ctx;
  
index e5e8397c85345869b67257425f8316240986add5..e8c6abff7cd65a9f77c8f19d888f1eea1aa2f422 100644 (file)
@@ -1,8 +1,8 @@
-Index: wpa_supplicant-0.6.3/wpa_supplicant/wpa_supplicant.c
+Index: wpa_supplicant-0.6.6/wpa_supplicant/wpa_supplicant.c
 ===================================================================
---- wpa_supplicant-0.6.3.orig/wpa_supplicant/wpa_supplicant.c  2008-07-24 16:28:58.000000000 +0200
-+++ wpa_supplicant-0.6.3/wpa_supplicant/wpa_supplicant.c       2008-07-24 16:47:40.000000000 +0200
-@@ -1182,7 +1182,7 @@
+--- wpa_supplicant-0.6.6.orig/wpa_supplicant/wpa_supplicant.c  2008-07-24 16:28:58.000000000 +0200
++++ wpa_supplicant-0.6.6/wpa_supplicant/wpa_supplicant.c       2008-07-24 16:47:40.000000000 +0200
+@@ -1206,7 +1206,7 @@
  {
  #define SCAN_AP_LIMIT 128
        struct wpa_scan_result *results;
@@ -11,7 +11,7 @@ Index: wpa_supplicant-0.6.3/wpa_supplicant/wpa_supplicant.c
        struct wpa_scan_results *res;
  
        results = os_malloc(SCAN_AP_LIMIT * sizeof(struct wpa_scan_result));
-@@ -1279,6 +1279,21 @@
+@@ -1303,6 +1303,21 @@
                res->res[res->num++] = r;
        }