sync with whiterussian
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Wed, 14 Sep 2005 15:30:53 +0000 (15:30 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Wed, 14 Sep 2005 15:30:53 +0000 (15:30 +0000)
SVN-Revision: 1923

openwrt/package/busybox/patches/170-udhcp-options.patch [new file with mode: 0644]
openwrt/package/mtd/Config.in
openwrt/package/mtd/Makefile
openwrt/package/mtd/ipkg/mtd-static.control [new file with mode: 0644]

diff --git a/openwrt/package/busybox/patches/170-udhcp-options.patch b/openwrt/package/busybox/patches/170-udhcp-options.patch
new file mode 100644 (file)
index 0000000..b03810a
--- /dev/null
@@ -0,0 +1,15 @@
+diff -Nur busybox-1.00.orig/networking/udhcp/options.c busybox-1.00/networking/udhcp/options.c
+--- busybox-1.00.orig/networking/udhcp/options.c       2004-03-15 09:29:01.000000000 +0100
++++ busybox-1.00/networking/udhcp/options.c    2005-09-14 13:27:23.792609800 +0200
+@@ -39,8 +39,11 @@
+       {"dhcptype",    OPTION_U8,                              0x35},
+       {"serverid",    OPTION_IP,                              0x36},
+       {"message",     OPTION_STRING,                          0x38},
++      {"vendorclass", OPTION_STRING,                          0x3C},
++      {"clientid",    OPTION_STRING,                          0x3D},
+       {"tftp",        OPTION_STRING,                          0x42},
+       {"bootfile",    OPTION_STRING,                          0x43},
++      {"userclass",   OPTION_STRING,                          0x4D},
+       {"",            0x00,                           0x00}
+ };
index 6ddc33be4ea4df62a8172da3be88941a62577de8..a1b24a93588bf49133978dedae1cf1d339fe5a7c 100644 (file)
@@ -1,7 +1,12 @@
 config BR2_PACKAGE_MTD
-       tristate "mtd - flash utility (always needed)"
+       tristate "mtd - update utility for trx firmware images"
        default y
        help
-        flash utility for firmware images update. 
-        OpenWrt will not work correctly without it.
+        update utility for trx firmware images.
 
+config BR2_PACKAGE_MTD_STATIC
+       tristate "mtd - update utility for trx firmware images (statically linked)"
+       default n
+       help
+        update utility for trx firmware images (statically linked). To update
+        from other firmware or older OpenWrt releases.
index bfbb301e4c867fb2bc72440ac7e8421535a4deb9..18ebc903354362fe0738f6edb8767fd2170b9fbb 100644 (file)
@@ -3,13 +3,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME := mtd
-PKG_RELEASE := 1
+PKG_RELEASE := 2
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,MTD_STATIC,mtd-static,$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.prepared:
        mkdir -p $@
@@ -17,6 +18,7 @@ $(PKG_BUILD_DIR)/.prepared:
 
 $(PKG_BUILD_DIR)/.built:
        $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
+       $(TARGET_CC) -static $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd-static mtd.c
        touch $@
 
 $(IPKG_MTD): 
@@ -24,3 +26,9 @@ $(IPKG_MTD):
        install -m0755 $(PKG_BUILD_DIR)/mtd $(IDIR_MTD)/sbin
        $(RSTRIP) $(IDIR_MTD)/sbin/*
        $(IPKG_BUILD) $(IDIR_MTD) $(PACKAGE_DIR)
+
+$(IPKG_MTD_STATIC): 
+       install -d -m0755 $(IDIR_MTD_STATIC)/sbin
+       install -m0755 $(PKG_BUILD_DIR)/mtd-static $(IDIR_MTD_STATIC)/sbin
+       $(RSTRIP) $(IDIR_MTD_STATIC)/sbin/*
+       $(IPKG_BUILD) $(IDIR_MTD_STATIC) $(PACKAGE_DIR)
diff --git a/openwrt/package/mtd/ipkg/mtd-static.control b/openwrt/package/mtd/ipkg/mtd-static.control
new file mode 100644 (file)
index 0000000..5c73808
--- /dev/null
@@ -0,0 +1,6 @@
+Package: mtd-static
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developer <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Tool for modifying the flash chip (statically linked)