add ipkg to image builder
authorFelix Fietkau <nbd@openwrt.org>
Sat, 30 Apr 2005 19:54:58 +0000 (19:54 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 30 Apr 2005 19:54:58 +0000 (19:54 +0000)
SVN-Revision: 774

openwrt/package/Makefile
openwrt/package/sdk/Makefile

index 99c2c7248c356b551bab199b3d6cabd9ce0ea731..bf9d04f89ad63701c47de739c674d74b6039aa48 100644 (file)
@@ -76,7 +76,7 @@ package-$(BR2_PACKAGE_LIBPQ) += postgresql
 
 DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf uclibc++
 DEV_LIBS_COMPILE:=$(patsubst %,%-compile,$(DEV_LIBS))
-SDK_DEFAULT_PACKAGES:=busybox dnsmasq iptables wireless-tools dropbear bridge
+SDK_DEFAULT_PACKAGES:=busybox dnsmasq iptables wireless-tools dropbear bridge ipkg
 SDK_DEFAULT_COMPILE:=$(patsubst %,%-compile,$(SDK_DEFAULT_PACKAGES))
 
 all: compile install
index dba08cabfcd4fc749c66fd02e6fc5892214825e8..2345fcc2a6b14bef8f6c2513acd92ae63981d62a 100644 (file)
@@ -47,7 +47,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2:
        mkdir -p $(IB_BUILD_DIR)/include
        mkdir -p $(IB_BUILD_DIR)/packages
        (cd $(PACKAGE_DIR); \
-               cp busybox_* kmod-brcm-* kmod-wlcompat* dnsmasq_* iptables_* dropbear_* kmod-diag_* \
+               cp ipkg_* busybox_* kmod-brcm-* kmod-wlcompat* dnsmasq_* iptables_* dropbear_* kmod-diag_* \
                   wireless-tools_* zlib* bridge_* ppp_* ppp-pppoe* kmod-ppp* openwrt-utils* $(IB_BUILD_DIR)/packages/; \
        )
        egrep '^[^(include|prepare|compile|install)]' < $(TOPDIR)/target/jffs2/Makefile > $(IB_BUILD_DIR)/include/jffs2.mk