several fixes to ifxmips, getting ready for dsl driver merge
authorJohn Crispin <john@openwrt.org>
Mon, 24 Dec 2007 21:17:56 +0000 (21:17 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 24 Dec 2007 21:17:56 +0000 (21:17 +0000)
SVN-Revision: 9895

target/linux/ifxmips/files/include/asm-mips/ifxmips/ifxmips.h
target/linux/ifxmips/patches/110-drivers.patch

index 18e521b0ce0465f979f5b6fc19c8551d1f6077f6..21d72a2b9e7acb85b46dde6ad75607bf3511d22b 100644 (file)
 
 #define IFXMIPS_RCU_RST_REQ_DFE        (1 << 7)
 #define IFXMIPS_RCU_RST_REQ_AFE        (1 << 11)
-
+#define IFXMIPS_RCU_RST_REQ_ARC_JTAG   (1 << 20)
 
 /*------------ MCD */
 
 
 #define ETHERNET_PACKET_DMA_BUFFER_SIZE                0x600
 
-#define IFXMIPS_PPE32_MEM_MAP  (IFXMIPS_PPE32_BASE_ADDR + 0x10000 )
+#define IFXMIPS_PPE32_MEM_MAP  ((u32*)(IFXMIPS_PPE32_BASE_ADDR + 0x10000))
+#define IFXMIPS_PPE32_SRST             ((u32*)(IFXMIPS_PPE32_BASE_ADDR + 0x10080))
 
 #define MII_MODE 1
-
 #define REV_MII_MODE 2
 
 /* mdio access */
 #define MEI_XMEM_BAR15                 ((u32*)(IFXMIPS_MEI_BASE_ADDR + 0x0090))
 #define MEI_XMEM_BAR16                 ((u32*)(IFXMIPS_MEI_BASE_ADDR + 0x0094))
 
+
+/*------------ FUSE */
+
+#define IFXMIPS_FUSE_BASE_ADDR (KSEG1 + 0x1F107354)
+
+
 #endif
index effe6b287b6dbb76da3b5345d296798b725990ac..69c935650eee44be7170c71c50be56fc548c1133 100644 (file)
@@ -91,4 +91,4 @@ Index: linux-2.6.23/drivers/char/Makefile
 +obj-$(CONFIG_IFXMIPS_GPIO)    += ifxmips_gpio.o
 +obj-$(CONFIG_IFXMIPS_SSC)     += ifxmips_ssc.o
 +obj-$(CONFIG_IFXMIPS_EEPROM)  += ifxmips_eeprom.o
-+obj-$(CONFIG_IFXMIPS_MEI)     += ifxmips_mei_core.o ifxmips_mei_bsp.c ifxmips_mei_mib.c
++obj-$(CONFIG_IFXMIPS_MEI)     += ifxmips_mei_core.o ifxmips_mei_bsp.o ifxmips_mei_mib.o