[package] uhttpd: cope with variable number of spaces in header lines (#11079)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 4 Mar 2012 15:53:51 +0000 (15:53 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 4 Mar 2012 15:53:51 +0000 (15:53 +0000)
SVN-Revision: 30806

package/uhttpd/Makefile
package/uhttpd/src/uhttpd.c

index e0e567af45d1b43bc9bdedb3da2b3fb67e1011a9..5688073adda7901ebb306fd47e8ef3c378dfe54b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2011 Jo-Philipp Wich <xm@subsignal.org>
+# Copyright (C) 2010-2012 Jo-Philipp Wich <xm@subsignal.org>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=30
+PKG_RELEASE:=31
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index 3563d91d16ef92ad12ed55cae69b410cc5aa2e84..9b9608628d4d393dc654bfbe966d5bdc17cb48a7 100644 (file)
@@ -337,11 +337,14 @@ static struct http_request * uh_http_header_parse(struct client *cl, char *buffe
                        }
 
                        /* have name but no value and found a colon, start of value */
-                       else if( hdrname && !hdrdata && ((i+2) < buflen) &&
-                               (buffer[i] == ':') && (buffer[i+1] == ' ')
+                       else if( hdrname && !hdrdata &&
+                           ((i+1) < buflen) && (buffer[i] == ':')
                        ) {
                                buffer[i] = 0;
-                               hdrdata = &buffer[i+2];
+                               hdrdata = &buffer[i+1];
+
+                               while ((hdrdata + 1) < (buffer + buflen) && *hdrdata == ' ')
+                                       hdrdata++;
                        }
 
                        /* have no name and found [A-Za-z], start of name */