iptables: fix build error with linux 2.6.31
authorFelix Fietkau <nbd@openwrt.org>
Fri, 25 Sep 2009 14:10:42 +0000 (14:10 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 25 Sep 2009 14:10:42 +0000 (14:10 +0000)
SVN-Revision: 17721

package/iptables/Makefile

index 818e686d47b56d385920f19b4c6234c0a73de16e..b8164458ee78bdbfdc8117fb2a551780bcba4b1b 100644 (file)
@@ -247,7 +247,11 @@ define Package/libxtables
 endef
 
 
-TARGET_CPPFLAGS := -I$(PKG_BUILD_DIR)/include $(TARGET_CPPFLAGS)
+TARGET_CPPFLAGS := \
+       -I$(PKG_BUILD_DIR)/include \
+       -I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include \
+       $(TARGET_CPPFLAGS)
+
 TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += \
        --enable-shared \