Fix building when host and target systems are same arch
authorNicolas Thill <nico@openwrt.org>
Wed, 10 Aug 2005 16:06:24 +0000 (16:06 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 10 Aug 2005 16:06:24 +0000 (16:06 +0000)
SVN-Revision: 1597

openwrt/package/bluez-libs/Makefile
openwrt/package/glib/Makefile
openwrt/package/libosip2/Makefile
openwrt/package/openldap/Makefile
openwrt/package/snort/Makefile

index 6a65590842b9abe1ae25e56a622b1ef6e9ceb3a6..17ac5a1164aa17825c732760769d8c1383e6524b 100644 (file)
@@ -27,7 +27,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
                sys_lib_dlsearch_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
                sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
                ./configure \
@@ -81,6 +81,7 @@ $(STAGING_DIR)/usr/lib/libbluetooth.so: $(PKG_BUILD_DIR)/.built
 install-dev: $(STAGING_DIR)/usr/lib/libbluetooth.so
 
 uninstall-dev:
+       rm -rf $(STAGING_DIR)/usr/include/bluetooth
        rm -rf $(STAGING_DIR)/usr/lib/libbluetooth.{a,so*}
 
 compile: install-dev
index 473e8b6354f0df58e5838c5a64a7aa60cafd2a6f..cbbd48678f834c696f9d074d79c5a3b9b1565b7d 100644 (file)
@@ -48,6 +48,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
                glib_cv_byte_contents_gmutex="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0" \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
+               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
                ./configure \
                  --target=$(GNU_TARGET_NAME) \
                  --host=$(GNU_TARGET_NAME) \
index d4e6d61518d3a4da1c9fde8f6133599eca4678d4..bf7a224f0c7579f908c64201787a87f01172967e 100644 (file)
@@ -26,7 +26,7 @@ $(PKG_BUILD_DIR)/.configured:
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(strip $(TARGET_CFLAGS))" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
                ./configure \
                  --target=$(GNU_TARGET_NAME) \
                  --host=$(GNU_TARGET_NAME) \
index 35a15b37e29c980f6cd7e081f23a938ff357638a..20179b27194a0a3dc639c64043662f0ba527cc61 100644 (file)
@@ -78,7 +78,7 @@ $(PKG_BUILD_DIR)/.built:
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
                ac_cv_func_memcmp_clean="yes" \
                ./configure \
                  --target=$(GNU_TARGET_NAME) \
@@ -128,7 +128,7 @@ $(STAGING_DIR)/usr/lib/libldap.so: $(PKG_BUILD_DIR)/.built
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib/
        cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(STAGING_DIR)/usr/lib/
-       touch $(STAGING_DIR)/usr/lib/libldap.so
+       touch $@
        
 install-dev: $(STAGING_DIR)/usr/lib/libldap.so
 
index c58fa75e8dd9dbda8008d618ac8e17aec6dd7ad7..630ac127ec61c88fcfee1d0b2f482f2411133279 100644 (file)
@@ -100,7 +100,7 @@ $(PKG_BUILD_DIR)/$(2): $(PKG_BUILD_DIR)/.prepared
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/include/mysql" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/mysql" \
+               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/mysql" \
                ./configure \
                  $(PKG_CONFIGURE_OPTS) \
                  $$($(1)_CONFIGURE_OPTS) \