package/ar7-atm: move configuration in submenu
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 10:48:09 +0000 (10:48 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 10:48:09 +0000 (10:48 +0000)
SVN-Revision: 20914

package/ar7-atm/Config.in
package/ar7-atm/Makefile

index 395755c594a2a6fbbaa8151536421ee30d9b0cf0..479b7ad072c06b8bb5557ad2220b4fefe3009cbb 100644 (file)
@@ -1,6 +1,8 @@
+menu "Configuration"
+       depends on (PACKAGE_kmod-sangam-atm-annex-a || PACKAGE_kmod-sangam-atm-annex-b)
+
 choice
        prompt "Firmware version"
-       depends on (PACKAGE_kmod-sangam-atm-annex-a || PACKAGE_kmod-sangam-atm-annex-b)
        default AR7_ATM_FW_VERSION_704
        help
                This option allows you to switch between firmware/driver versions which
@@ -16,3 +18,5 @@ config AR7_ATM_FW_VERSION_703
        bool "D7.03.01.00"
 
 endchoice
+
+endmenu
index e5cef079101c70748ce10c69bd8467054e7cab9f..fc8b5771241fb56181e3a24c6cbe49da462974ec 100644 (file)
@@ -42,6 +42,7 @@ define KernelPackage/sangam-atm/Default
   TITLE:=AR7 ADSL driver
   FILES:=$(PKG_BUILD_DIR)/tiatm.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,tiatm)
+  MENU:=1
 endef
 
 define KernelPackage/sangam-atm/config