[ramips] add common setup code
authorGabor Juhos <juhosg@openwrt.org>
Mon, 31 Aug 2009 18:53:22 +0000 (18:53 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 31 Aug 2009 18:53:22 +0000 (18:53 +0000)
SVN-Revision: 17453

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/common.h
target/linux/ramips/files/arch/mips/ralink/common/Makefile
target/linux/ramips/files/arch/mips/ralink/common/setup.c [new file with mode: 0644]
target/linux/ramips/files/arch/mips/ralink/rt288x/setup.c
target/linux/ramips/files/arch/mips/ralink/rt305x/setup.c

index a04508758e3a0941ce89d63b6464767613c16373..240951bb1b760b4185b1a42f785bd8494734787f 100644 (file)
@@ -13,4 +13,6 @@ void __init ramips_intc_irq_init(unsigned intc_base, unsigned irq,
                                 unsigned irq_base);
 u32 ramips_intc_get_status(void);
 
+void __init ramips_soc_setup(void);
+
 #endif /* __ASM_MACH_RALINK_COMMON_H */
index 24f67ea6c3bd39d23271a6262bc504fc72887350..96f348a5a1c633fa58698be09536e01f8cfbc717 100644 (file)
@@ -7,6 +7,6 @@
 # under the terms of the GNU General Public License version 2 as published
 # by the Free Software Foundation.
 
-obj-y  := intc.o gpio.o
+obj-y  := setup.o intc.o gpio.o
 
 obj-$(CONFIG_RALINK_DEV_GPIO_LEDS)     += dev-gpio-leds.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/common/setup.c b/target/linux/ramips/files/arch/mips/ralink/common/setup.c
new file mode 100644 (file)
index 0000000..6440ccb
--- /dev/null
@@ -0,0 +1,24 @@
+/*
+ * Ralink SoC common setup
+ *
+ * Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/io.h>
+
+#include <asm/addrspace.h>
+#include <asm/mach-ralink/common.h>
+
+void __init plat_mem_setup(void)
+{
+       set_io_port_base(KSEG1);
+
+       ramips_soc_setup();
+}
index d0258524cc74d932106764f0d8b33c66bbddbf36..fe94126e5d1d189181ce03f5ddb3b7ca07594570 100644 (file)
@@ -21,6 +21,7 @@
 #include <asm/reboot.h>
 #include <asm/time.h>
 
+#include <asm/mach-ralink/common.h>
 #include <asm/mach-ralink/rt288x.h>
 #include <asm/mach-ralink/rt288x_regs.h>
 
@@ -100,10 +101,8 @@ unsigned int __cpuinit get_c0_compare_irq(void)
        return CP0_LEGACY_COMPARE_IRQ;
 }
 
-void __init plat_mem_setup(void)
+void __init ramips_soc_setup(void)
 {
-       set_io_port_base(KSEG1);
-
        rt288x_sysc_base = ioremap_nocache(RT2880_SYSC_BASE, RT2880_SYSC_SIZE);
        rt288x_memc_base = ioremap_nocache(RT2880_MEMC_BASE, RT2880_MEMC_SIZE);
 
index d574ef650e8cc86206bc19457b9d8a478aa3a0f9..70eaae4254e5c0e28bae01c854f62e70546c977e 100644 (file)
@@ -20,6 +20,7 @@
 #include <asm/reboot.h>
 #include <asm/time.h>
 
+#include <asm/mach-ralink/common.h>
 #include <asm/mach-ralink/rt305x.h>
 #include <asm/mach-ralink/rt305x_regs.h>
 
@@ -99,10 +100,8 @@ unsigned int __cpuinit get_c0_compare_irq(void)
        return CP0_LEGACY_COMPARE_IRQ;
 }
 
-void __init plat_mem_setup(void)
+void __init ramips_soc_setup(void)
 {
-       set_io_port_base(KSEG1);
-
        rt305x_sysc_base = ioremap_nocache(RT305X_SYSC_BASE, PAGE_SIZE);
        rt305x_memc_base = ioremap_nocache(RT305X_MEMC_BASE, PAGE_SIZE);