fix flac build when arch != mipsel
authorNicolas Thill <nico@openwrt.org>
Tue, 18 Oct 2005 01:39:00 +0000 (01:39 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 18 Oct 2005 01:39:00 +0000 (01:39 +0000)
SVN-Revision: 2169

openwrt/package/flac/Makefile
openwrt/package/flac/patches/no_encoder.patch

index 9baa0da852dfb3990012d6a9c7db011f9b8c29fc..281b2c47ee34844b8ebe6d0727775965d7aecb4b 100644 (file)
@@ -26,6 +26,7 @@ $(PKG_BUILD_DIR)/.built:
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.lite \
                $(TARGET_CONFIGURE_OPTS) \
+               RELEASE_CFLAGS="$(TARGET_CFLAGS)" \
                libFLAC
        touch $@
 
index 64666e803471a64f8564bf7b4499d52fbac7cae5..f1d6fe277a660f0fd92cfab532d60cecec6d2e76 100644 (file)
@@ -6,7 +6,7 @@ diff -ru flac-1.1.2.OLD/build/lib.mk flac-1.1.2.NEW/build/lib.mk
  debug   : CFLAGS = -g -O0 -DDEBUG $(CONFIG_CFLAGS) $(DEBUG_CFLAGS) -Wall -W -DVERSION=$(VERSION) $(DEFINES) $(INCLUDES)
  valgrind: CFLAGS = -g -O0 -DDEBUG $(CONFIG_CFLAGS) $(DEBUG_CFLAGS) -DFLAC__VALGRIND_TESTING -Wall -W -DVERSION=$(VERSION) $(DEFINES) $(INCLUDES)
 -release : CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -finline-functions -DNDEBUG $(CONFIG_CFLAGS) $(RELEASE_CFLAGS) -Wall -W -Winline -DFLaC__INLINE=__inline__ -DVERSION=$(VERSION) $(DEFINES) $(INCLUDES)
-+release : CFLAGS = -Os -pipe -mips32 -mtune=mips32 -fomit-frame-pointer -funroll-loops -finline-functions -DNDEBUG $(CONFIG_CFLAGS) $(RELEASE_CFLAGS) -Wall -W -Winline -DFLaC__INLINE=__inline__ -DVERSION=$(VERSION) $(DEFINES) $(INCLUDES)
++release : CFLAGS = -fomit-frame-pointer -funroll-loops -finline-functions -DNDEBUG $(CONFIG_CFLAGS) $(RELEASE_CFLAGS) -Wall -W -Winline -DFLaC__INLINE=__inline__ -DVERSION=$(VERSION) $(DEFINES) $(INCLUDES)
  
  LFLAGS  = -L$(LIBPATH)