[busybox] make init and logread depend on !PROCD_INIT
authorJohn Crispin <john@openwrt.org>
Wed, 13 Mar 2013 18:11:31 +0000 (18:11 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 13 Mar 2013 18:11:31 +0000 (18:11 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 36005

package/busybox/Makefile
package/busybox/config/init/Config.in
package/busybox/config/sysklogd/Config.in

index 7aaaf6cb173ccbc9410b444fe273f889824044a3..f4553c0ffe13f7563adf158c212c205e0ef69161 100644 (file)
@@ -17,6 +17,7 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
 PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
 
+PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
 PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
 PKG_BUILD_PARALLEL:=1
 
@@ -112,6 +113,7 @@ define Package/busybox/install
                $(INSTALL_BIN) ./files/$$$$tmp $(1)/etc/init.d/$$$$tmp; \
        done
        -rm -rf $(1)/lib64
+       $(if $(CONFIG_PROCD_INIT),rm -f $(1)/sbin/init $(1)/sbin/logread)
 endef
 
 $(eval $(call BuildPackage,busybox))
index 61c20140b7e604ef1f700b5ac25fdf317a68f151..4b3c8dd1606152ff822850076827d9ea75a82709 100644 (file)
@@ -73,6 +73,7 @@ config BUSYBOX_CONFIG_INIT
        bool "init"
        default y
        select BUSYBOX_CONFIG_FEATURE_SYSLOG
+       depends on !PROCD_INIT
        help
          init is the first program run when the system boots.
 
index 20e1aff063b34a3e4ef6962cc5e458e93ee9a0f8..087a5b4e50e19fca509e4d530d1a1659ce7d7e6e 100644 (file)
@@ -96,7 +96,7 @@ config BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG_BUFFER_SIZE
 config BUSYBOX_CONFIG_LOGREAD
        bool "logread"
        default y
-       depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG
+       depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG && !PROCD_INIT
        help
          If you enabled Circular Buffer support, you almost
          certainly want to enable this feature as well. This