kernel: usb.mk: enable chipidea udc mode
authorJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:42:41 +0000 (12:42 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:42:41 +0000 (12:42 +0000)
The chipidea USB OTG controller is dual-role and supports both host and device
modes. Enable device mode.

Tested on Gateworks Ventana imx6 board with g_ether.

Are there any other targets out there that use the CHIPIDEA controller? If so
testing is needed for those.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
SVN-Revision: 40905

package/kernel/linux/modules/usb.mk

index 096d55aa8e7e7ef8baeb92e3fa88cc4e7ac44c0b..e137515487f826eb8970444e0c17293614ea3199 100644 (file)
@@ -1336,7 +1336,7 @@ define KernelPackage/usb-chipidea
   KCONFIG:=\
        CONFIG_USB_CHIPIDEA \
        CONFIG_USB_CHIPIDEA_HOST=y \
-       CONFIG_USB_CHIPIDEA_UDC=n \
+       CONFIG_USB_CHIPIDEA_UDC=y \
        CONFIG_USB_CHIPIDEA_DEBUG=y
 ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.11.0)),1)
   FILES:=\
@@ -1347,9 +1347,10 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.11.0)),1)
 else
   FILES:=\
        $(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc.ko \
+       $(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/gadget/udc-core.ko) \
        $(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc_imx.ko) \
        $(if $(CONFIG_OF),$(LINUX_DIR)/drivers/usb/chipidea/usbmisc_imx.ko)
-  AUTOLOAD:=$(call AutoLoad,51,ci_hdrc $(if $(CONFIG_OF),ci_hdrc_imx usbmisc_imx),1)
+  AUTOLOAD:=$(call AutoLoad,51,ci_hdrc $(if $(CONFIG_OF),ci_hdrc_imx usbmisc_imxudc-core),1)
 endif
   $(call AddDepends/usb)
 endef