This patch is for broadcom 96348GW-11 boards, to get USB and Ethernet working. Also...
authorFlorian Fainelli <florian@openwrt.org>
Sat, 15 Nov 2008 11:30:22 +0000 (11:30 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 15 Nov 2008 11:30:22 +0000 (11:30 +0000)
SVN-Revision: 13213

target/linux/brcm63xx/files/drivers/mtd/maps/bcm963xx-flash.c
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-2.6.27/011-add_preliminary_board_support.patch

index 504dfac8495cb45709f1db78a302a01bc1b02ccd..9543c172a4e8838f774fdefe51450213d3016040 100644 (file)
@@ -177,13 +177,14 @@ static int bcm963xx_detect_cfe(struct mtd_info *master)
 {
        int idoffset = 0x4e0;
        static char idstring[8] = "CFE1CFE1";
-       char buf[8];
+       char buf[9];
        int ret;
        size_t retlen;
 
        ret = master->read(master, idoffset, 8, &retlen, (void *)buf);
+       buf[retlen] = 0;
        printk("bcm963xx: Read Signature value of %s\n", buf);
-       return strcmp(idstring,buf);
+       return strncmp(idstring,buf,8);
 }
 
 static int __init bcm963xx_mtd_init(void)
index e64d2c8c3f0774260c4775c8a0d079e8e1ddbbc5..203277679c75c533c15039a1e887447fb5d30599 100644 (file)
@@ -75,6 +75,8 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96345GW2,6345)
        # Neufbox4
        $(call Image/Build/CFE,$(1),96358VW,6358)
+       # Comtrend 536
+       $(call Image/Build/CFE,$(1),96348GW-11,6348)
 endef
 
 $(eval $(call BuildImage))
index 3726cb5bbc49c74c8bc37e4488618b4554179768..1d8789fd7a6f2e6c60c0a50e2834e756682e511e 100644 (file)
@@ -56,7 +56,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
 +obj-$(CONFIG_BOARD_BCM963XX)          += board_bcm963xx.o
 --- /dev/null
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -0,0 +1,328 @@
+@@ -0,0 +1,353 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive
@@ -109,6 +109,30 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
 +      },
 +};
 +
++static struct board_info __initdata board_96348gw_11 = {
++      .name                           = "96348GW-11",
++      .expected_cpu_id                = 0x6348,
++
++      .has_enet0                      = 1,
++      .has_enet1                      = 1,
++      .has_pci                        = 1,
++
++      .enet0 = {
++              .has_phy                = 1,
++              .use_internal_phy       = 1,
++      },
++
++      .enet1 = {
++              .force_speed_100        = 1,
++              .force_duplex_full      = 1,
++      },
++
++
++      .has_ohci0 = 1,
++      .has_pccard = 1,
++      .has_ehci0 = 1,
++};
++
 +static struct board_info __initdata board_96348gw = {
 +      .name                           = "96348GW",
 +      .expected_cpu_id                = 0x6348,
@@ -159,6 +183,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
 +#ifdef CONFIG_BCM63XX_CPU_6348
 +      &board_96348r,
 +      &board_96348gw,
++      &board_96348gw_11,
 +#endif
 +
 +#ifdef CONFIG_BCM63XX_CPU_6358