[package] broadcom-wl: add "assoclist" command to wlc
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 6 Aug 2009 12:02:50 +0000 (12:02 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 6 Aug 2009 12:02:50 +0000 (12:02 +0000)
SVN-Revision: 17144

package/broadcom-wl/Makefile
package/broadcom-wl/src/wlc/wlc.c

index ebc8287f44c08643a8901912a80bd60d1e7ae7d2..5ce37ff313abf29774460f2fd512766bdbf8dbad 100644 (file)
@@ -10,8 +10,8 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=broadcom-wl
 PKG_VERSION:=4.150.10.5.3
-PKG_RELEASE:=5
-WLC_VERSION:=0.1
+PKG_RELEASE:=6
+WLC_VERSION:=0.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
index 790bdfff519353e2f12eb5d78a5bdef6a61bb947..3f3130de87033d820601ca8beb0f3c8ced061ddd 100644 (file)
@@ -905,6 +905,13 @@ static const struct wlc_call wlc_calls[] = {
                .handler = wlc_ioctl,
                .desc = "Desired BSSID"
        },
+       {
+               .name = "assoclist",
+               .param = STRING,
+               .data.num = (WLC_GET_ASSOCLIST << 16),
+               .handler = wlc_maclist,
+               .desc = "MACs of associated stations"
+       },
 };
 #define wlc_calls_size (sizeof(wlc_calls) / sizeof(struct wlc_call))