[package] firewall: do not check for module availability, let iptables fail if a...
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 22 Oct 2011 19:50:35 +0000 (19:50 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 22 Oct 2011 19:50:35 +0000 (19:50 +0000)
SVN-Revision: 28525

package/firewall/Makefile
package/firewall/files/lib/fw.sh

index 597a37e140489a657c0009224a425f8fdd448869..749f04a4b1b7768c7682a0a5c451ccb86423fdb1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=35
+PKG_RELEASE:=36
 
 include $(INCLUDE_DIR)/package.mk
 
index a13eb7eb13ff782faadf07ae5f97701dc135a255..bf7156e8cefebd4499bbc0534d9fb00922e09188 100644 (file)
@@ -74,21 +74,7 @@ fw__exec() { # <action> <family> <table> <chain> <target> <position> { <rules> }
                        fw__rc $(($? & 1))
                        return
                fi
-               local mod
-               eval "mod=\$FW_${fam#G}_${tab}"
-               if [ "$mod" ]; then
-                       fw__rc $mod
-                       return
-               fi
-               case "$fam" in
-                       *4) mod=iptable_${tab} ;;
-                       *6) mod=ip6table_${tab} ;;
-                       *) mod=. ;;
-               esac
-               grep -q "^${mod} " /proc/modules
-               mod=$?
-               export FW_${fam}_${tab}=$mod
-               fw__rc $mod
+               fw__rc 0
        }
 
        fw__err() {