brcm63xx: Add support for Plusnet 2704N
authorJonas Gorski <jogo@openwrt.org>
Wed, 5 Aug 2015 13:55:37 +0000 (13:55 +0000)
committerJonas Gorski <jogo@openwrt.org>
Wed, 5 Aug 2015 13:55:37 +0000 (13:55 +0000)
BCM6318: add support for Plusnet / Sagem 2704N (V1)
Signed-off-by: Matt Goring <matt.goring@googlemail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46562

target/linux/brcm63xx/base-files/etc/diag.sh
target/linux/brcm63xx/base-files/etc/uci-defaults/01_leds
target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/dts/fast2704n.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.18/571-board_fast2704n.patch [new file with mode: 0644]
target/linux/brcm63xx/patches-4.1/571-board_fast2704n.patch [new file with mode: 0644]
target/linux/brcm63xx/profiles/sagem.mk

index 1b0d26d6162ffcca0a5b9decfff737f588af18c8..7916ac26e27b5c3d11d52285cb14060c8cf730a7 100644 (file)
@@ -70,6 +70,9 @@ set_state() {
        fast2504n)
                status_led="fast2504n:green:ok"
                ;;
+       fast2704n)
+               status_led2="F@ST2704N:red:power"
+               ;;
        fast2704v2)
                status_led="F@ST2704V2:green:power"
                ;;
index b964bdb229cd68e5955cdd28a7bacf85e4c88ce3..bdb3dada33001f6ba3037f4b8bfbd4e28f86ab84 100644 (file)
@@ -22,6 +22,9 @@ dgnd3700v1_dgnd3800b)
        ucidef_set_led_usbdev "usb1" "USB1" "DGND3700v1_3800B:green:usb-back" "1-1"
        ucidef_set_led_usbdev "usb2" "USB2" "DGND3700v1_3800B:green:usb-front" "1-2"
        ;;
+fast2704n)
+       ucidef_set_led_netdev "wan" "WAN" "F@ST2704N:green:inet" "eth0.2"
+       ;;
 fast2704v2)
        ucidef_set_led_usbdev "usb" "USB" "F@ST2704V2:green:usb" "1-1"
        ;;
index e5880eb414c43447c6b7182ca8c7a2fb0c41c52d..2ff9e45860edc35197dd7e07d412037db0851717 100644 (file)
@@ -114,6 +114,7 @@ wap-5831n)
        ucidef_add_switch_vlan "eth0" "2" "4 5t"
        ;;
 
+fast2704n |\
 dgnd3700v1_dgnd3800b)
        ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
        ucidef_add_switch "eth0" "1" "1"
index 0eb9a750ca3cee62380d59e45ddca0b0fce01bda..92fa5f2bdb7d949bed5ca65afee09d66cd63b4c7 100755 (executable)
@@ -198,6 +198,9 @@ brcm63xx_dt_detect() {
        "Sagem F@ST2604")
                board_name="fast2604"
                ;;
+       "Sagem F@ST2704N")
+               board_name="fast2704n"
+               ;;
        "Sagem F@ST2704V2")
                board_name="fast2704v2"
                ;;
diff --git a/target/linux/brcm63xx/dts/fast2704n.dts b/target/linux/brcm63xx/dts/fast2704n.dts
new file mode 100644 (file)
index 0000000..232d4d1
--- /dev/null
@@ -0,0 +1,84 @@
+/dts-v1/;
+
+#include "bcm6318.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+       model = "Sagem F@ST2704N";
+       compatible = "sagem,f@st2704n", "brcm,bcm6318";
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               debounce-interval = <60>;
+
+               wlan {
+                       label = "wlan";
+                       gpios = <&gpio0 1 0>;
+                       linux,code = <KEY_WLAN>;
+               };
+               wps {
+                       label = "wps";
+                       gpios = <&gpio1 1 1>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+               reset {
+                       label = "reset";
+                       gpios = <&gpio1 2 1>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               wps_green {
+                       label = "F@ST2704N:green:wps";
+                       gpios = <&gpio0 2 1>;
+               };
+               lan1_green {
+                       label = "F@ST2704N:green:lan1";
+                       gpios = <&gpio0 4 1>;
+               };
+               lan2_green {
+                       label = "F@ST2704N:green:lan2";
+                       gpios = <&gpio0 5 1>;
+               };
+               lan3_green {
+                       label = "F@ST2704N:green:lan3";
+                       gpios = <&gpio0 6 1>;
+               };
+               lan4_green {
+                       label = "F@ST2704N:green:lan4";
+                       gpios = <&gpio0 7 1>;
+               };
+               inet_green {
+                       label = "F@ST2704N:green:inet";
+                       gpios = <&gpio0 8 1>;
+               };
+               inet_red {
+                       label = "F@ST2704N:red:inet";
+                       gpios = <&gpio0 9 1>;
+               };
+               dsl_green {
+                       label = "F@ST2704N:green:dsl";
+                       gpios = <&gpio0 10 1>;
+               };
+               power_red {
+                       label = "F@ST2704N:red:power";
+                       gpios = <&gpio0 11 1>;
+               };
+               power_green {
+                       label = "F@ST2704N:green:power";
+                       gpios = <&gpio1 15 1>;
+                       default-state = "on";
+               };
+               usb_green {
+                       label = "F@ST2704N:green:usb";
+                       gpios = <&gpio1 17 1>;
+               };
+       };
+};
index 8e148aa79488dcdae4365f7d1946b72605318e67..4a52a41a36168c426abaea3a15e231aa0fa63094 100755 (executable)
@@ -623,6 +623,8 @@ $(eval $(call bcm63xxCfe,FAST2404,F@ST2404,fast2404,F@ST2404,6348))
 $(eval $(call bcm63xxCfe,FAST2504n,F@ST2504n,fast2504n,F@ST2504n,6362))
 # Sagem F@ST2604
 $(eval $(call bcm63xxCfe,FAST2604,F@ST2604,fast2604,F@ST2604,6348))
+# Sagem F@ST2704N V1 / Plusnet F@ST2704N V1
+$(eval $(call bcm63xxCfe,FAST2704N,FAST2704N,fast2704n,F@ST2704N,6318,--pad 4))
 # Sagem F@ST2704V2
 $(eval $(call bcm63xxCfe,FAST2704V2,F@ST2704V2,fast2704v2,F@ST2704V2,6328))
 # SFR Neufbox 4
diff --git a/target/linux/brcm63xx/patches-3.18/571-board_fast2704n.patch b/target/linux/brcm63xx/patches-3.18/571-board_fast2704n.patch
new file mode 100644 (file)
index 0000000..7b8b727
--- /dev/null
@@ -0,0 +1,65 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -225,6 +225,46 @@ static struct board_info __initdata board_dsl_2751b_d1 = {
+               .num_board_fixups               = ARRAY_SIZE(dsl2751b_e1_fixups),
+       },
+ };
++
++static struct board_info __initdata board_FAST2704N = {
++      .name                           = "F@ST2704N",
++      .expected_cpu_id                = 0x6318,
++
++      .has_uart0                      = 1,
++      .has_pci                        = 1,
++      .use_fallback_sprom             = 1,
++
++      .has_enetsw                     = 1,
++
++      .has_ohci0                      = 1,
++      .has_ehci0                      = 1,
++      .num_usbh_ports                 = 1,
++
++      .enetsw = {
++              .used_ports = {
++                      [0] = {
++                              .used   = 1,
++                              .phy_id = 1,
++                              .name   = "Port 1",
++                      },
++                      [1] = {
++                              .used   = 1,
++                              .phy_id = 2,
++                              .name   = "Port 2",
++                      },
++                      [2] = {
++                              .used   = 1,
++                              .phy_id = 3,
++                              .name   = "Port 3",
++                      },
++                      [3] = {
++                              .used   = 1,
++                              .phy_id = 4,
++                              .name   = "Port 4",
++                      },
++              },
++      },
++};
+ #endif /* CONFIG_BCM63XX_CPU_6318 */
+ /*
+@@ -2352,6 +2392,7 @@ static const struct board_info __initconst *bcm963xx_boards[] = {
+       &board_96318ref,
+       &board_96318ref_p300,
+       &board_dsl_2751b_d1,
++      &board_FAST2704N,
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6328
+       &board_96328avng,
+@@ -2449,6 +2490,7 @@ static struct of_device_id const bcm963xx_boards_dt[] = {
+       { .compatible = "brcm,bcm96318ref", .data = &board_96318ref, },
+       { .compatible = "brcm,bcm96318ref_p300", .data = &board_96318ref_p300, },
+       { .compatible = "d-link,dsl-275xb-d", .data = &board_dsl_2751b_d1, },
++      { .compatible = "sagem,f@st2704n", .data = &board_FAST2704N, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6328
+       { .compatible = "adb,a4001n", .data = &board_A4001N, },
diff --git a/target/linux/brcm63xx/patches-4.1/571-board_fast2704n.patch b/target/linux/brcm63xx/patches-4.1/571-board_fast2704n.patch
new file mode 100644 (file)
index 0000000..7b8b727
--- /dev/null
@@ -0,0 +1,65 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -225,6 +225,46 @@ static struct board_info __initdata board_dsl_2751b_d1 = {
+               .num_board_fixups               = ARRAY_SIZE(dsl2751b_e1_fixups),
+       },
+ };
++
++static struct board_info __initdata board_FAST2704N = {
++      .name                           = "F@ST2704N",
++      .expected_cpu_id                = 0x6318,
++
++      .has_uart0                      = 1,
++      .has_pci                        = 1,
++      .use_fallback_sprom             = 1,
++
++      .has_enetsw                     = 1,
++
++      .has_ohci0                      = 1,
++      .has_ehci0                      = 1,
++      .num_usbh_ports                 = 1,
++
++      .enetsw = {
++              .used_ports = {
++                      [0] = {
++                              .used   = 1,
++                              .phy_id = 1,
++                              .name   = "Port 1",
++                      },
++                      [1] = {
++                              .used   = 1,
++                              .phy_id = 2,
++                              .name   = "Port 2",
++                      },
++                      [2] = {
++                              .used   = 1,
++                              .phy_id = 3,
++                              .name   = "Port 3",
++                      },
++                      [3] = {
++                              .used   = 1,
++                              .phy_id = 4,
++                              .name   = "Port 4",
++                      },
++              },
++      },
++};
+ #endif /* CONFIG_BCM63XX_CPU_6318 */
+ /*
+@@ -2352,6 +2392,7 @@ static const struct board_info __initconst *bcm963xx_boards[] = {
+       &board_96318ref,
+       &board_96318ref_p300,
+       &board_dsl_2751b_d1,
++      &board_FAST2704N,
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6328
+       &board_96328avng,
+@@ -2449,6 +2490,7 @@ static struct of_device_id const bcm963xx_boards_dt[] = {
+       { .compatible = "brcm,bcm96318ref", .data = &board_96318ref, },
+       { .compatible = "brcm,bcm96318ref_p300", .data = &board_96318ref_p300, },
+       { .compatible = "d-link,dsl-275xb-d", .data = &board_dsl_2751b_d1, },
++      { .compatible = "sagem,f@st2704n", .data = &board_FAST2704N, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6328
+       { .compatible = "adb,a4001n", .data = &board_A4001N, },
index 5afb2b725915f56fdba1ed27c3ca2e6d9d842ece..7d9a160ede16aaeb9b2dee445b8224efa8fd2c96 100644 (file)
@@ -32,6 +32,16 @@ define Profile/FAST2604/Description
 endef
 $(eval $(call Profile,FAST2604))
 
+define Profile/FAST2704N
+  NAME:=Sagem F@ST2704N
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci
+endef
+define Profile/FAST2704N/Description
+  Package set optimized for F@ST2704N.
+endef
+$(eval $(call Profile,FAST2704N))
+
 define Profile/FAST2704V2
   NAME:=Sagem F@ST2704V2
   PACKAGES:=kmod-b43 wpad-mini\