[package] comgt: add usb hotplug handler to bring up 3g ifaces on boot or when the...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 4 Jul 2010 18:11:34 +0000 (18:11 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 4 Jul 2010 18:11:34 +0000 (18:11 +0000)
SVN-Revision: 22061

package/comgt/Makefile
package/comgt/files/3g.usb [new file with mode: 0644]

index a7c45c558a863e4777ae2abb6d70ed61f1ac9a5a..253e12af0e036503a7584da8bfe6bdb611b8f31a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
@@ -54,6 +54,8 @@ define Package/comgt/install
        $(INSTALL_DATA) ./files/3g.button $(1)/etc/hotplug.d/button/05-3g
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
        $(INSTALL_DATA) ./files/3g.iface $(1)/etc/hotplug.d/iface/05-3g
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/usb
+       $(INSTALL_DATA) ./files/3g.usb $(1)/etc/hotplug.d/usb/30-3g
        $(INSTALL_DIR) $(1)/etc/gcom
        $(INSTALL_DATA) ./files/setpin.gcom $(1)/etc/gcom/setpin.gcom
        $(INSTALL_DATA) ./files/setmode.gcom $(1)/etc/gcom/setmode.gcom
diff --git a/package/comgt/files/3g.usb b/package/comgt/files/3g.usb
new file mode 100644 (file)
index 0000000..c52646b
--- /dev/null
@@ -0,0 +1,43 @@
+#!/bin/sh
+
+. /etc/functions.sh
+
+log() {
+       logger -t 3g-hotplug "$@"
+}
+
+find_3g_iface() {
+       local cfg="$1"
+       local tty="$2"
+
+       local proto
+       config_get proto "$cfg" proto
+
+       [ "$proto" = 3g ] && {
+               local auto
+               config_get_bool auto "$cfg" auto 1
+               [ "$auto" = 1 ] || return 0
+
+               local dev
+               config_get dev "$cfg" device
+
+               if [ "${dev##*/}" = "${tty##*/}" ]; then
+                       log "Starting interface $cfg for device ${tty##*/}"
+                       ( sleep 1; /sbin/ifup "$cfg" ) &
+               fi
+       }
+}
+
+
+if [ "$ACTION" = add ]; then
+       case "$DEVICENAME" in
+               *-*:*.*) config_load network;;
+               *) exit 0;;
+       esac
+
+       local tty
+       for tty in /sys/$DEVPATH/ttyUSB*; do
+               [ -d "$tty" ] || break
+               config_foreach find_3g_iface interface "$tty"
+       done
+fi