kernel: update to kernel version 2.6.37.3
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Mar 2011 17:14:08 +0000 (17:14 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Mar 2011 17:14:08 +0000 (17:14 +0000)
SVN-Revision: 26126

22 files changed:
include/kernel-version.mk
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/patches-2.6.37/022-USB-Add-ehci-ssb-driver.patch
target/linux/brcm47xx/patches-2.6.37/023-usb_ehci_ohci.patch
target/linux/brcm47xx/patches-2.6.37/700-ssb-gigabit-ethernet-driver.patch
target/linux/brcm47xx/patches-2.6.37/830-tg3_add_pci_ids.patch
target/linux/brcm47xx/patches-2.6.37/977-ssb_export_fallback_sprom.patch
target/linux/gemini/Makefile
target/linux/generic/patches-2.6.37/010-debloat_lzma.patch
target/linux/generic/patches-2.6.37/281-solos_uniform_vpi_vci.patch
target/linux/generic/patches-2.6.37/980-vm_exports.patch
target/linux/ixp4xx/Makefile
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/orion/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile
target/linux/xburst/Makefile

index ae06f0b5253aebb197a1622a62ece6f9af5e1e2b..7d343a6688a37759a715ca757fa4782e12cdee5e 100644 (file)
@@ -20,8 +20,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.36.4)
   LINUX_KERNEL_MD5SUM:=c05dd941d0e249695e9f72568888e1bf
 endif
-ifeq ($(LINUX_VERSION),2.6.37.1)
-  LINUX_KERNEL_MD5SUM:=07d3b1868a67c1a7ddcf1d54444cb5d1
+ifeq ($(LINUX_VERSION),2.6.37.3)
+  LINUX_KERNEL_MD5SUM:=b32fc95037e4e114fcfb33075bb30f46
 endif
 
 # disable the md5sum check for unknown kernel versions
index 858996fed66fcdeaa025da561f585112520231dd..e2cbc12eeb44d047735755e03ba2557db6f1d4e0 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
 
 include $(INCLUDE_DIR)/target.mk
 
index b0b096a2fe449dda8fb0543dbb97a6e4625fe3b1..4414177deb104a7b99be57c3210d3d20122cf4be 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
 
 include $(INCLUDE_DIR)/target.mk
 
index dabd71988c0220b67127bc097ca99295cc80bf2d..e9e8ec381497dc89249681241eac2b337b465332 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 23379b9d79974e7c48de96153822bae95ac070ad..5fdea90ee20200b79a3f09b22e6e9a41448a11b6 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
index d0570a68f8a9a107b8fb615166b65cb1c19af066..4d544bd782f3b06990c75934af264121c2fab7c0 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 6d15783b1c087277253ee7191d89c902e9776db0..0f9a800949147f60ee46bfac584df856699e18e0 100644 (file)
@@ -37,7 +37,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
        depends on USB
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1216,9 +1216,14 @@ MODULE_LICENSE ("GPL");
+@@ -1229,9 +1229,14 @@ MODULE_LICENSE ("GPL");
  #define PLATFORM_DRIVER               ehci_octeon_driver
  #endif
  
@@ -53,7 +53,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
  #error "missing bus glue for ehci-hcd"
  #endif
  
-@@ -1278,10 +1283,20 @@ static int __init ehci_hcd_init(void)
+@@ -1291,10 +1296,20 @@ static int __init ehci_hcd_init(void)
        if (retval < 0)
                goto clean4;
  #endif
@@ -75,7 +75,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
  clean4:
  #endif
  #ifdef OF_PLATFORM_DRIVER
-@@ -1312,6 +1327,9 @@ module_init(ehci_hcd_init);
+@@ -1325,6 +1340,9 @@ module_init(ehci_hcd_init);
  
  static void __exit ehci_hcd_cleanup(void)
  {
index 0d264d70c5cfdf5b6be3cb8eceb16d784718bb3b..2f6bbfe1d2c05d9245952f76874a5a752635aad4 100644 (file)
 +#endif
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1284,17 +1284,21 @@ static int __init ehci_hcd_init(void)
+@@ -1297,17 +1297,21 @@ static int __init ehci_hcd_init(void)
                goto clean4;
  #endif
  
  #ifdef XILINX_OF_PLATFORM_DRIVER
        of_unregister_platform_driver(&XILINX_OF_PLATFORM_DRIVER);
  clean4:
-@@ -1327,9 +1331,11 @@ module_init(ehci_hcd_init);
+@@ -1340,9 +1344,11 @@ module_init(ehci_hcd_init);
  
  static void __exit ehci_hcd_cleanup(void)
  {
index 2915e3e9b8fc3cf25df56a202a692b67e8a68142..7d9c8f8e309300ba24a2580676f52dabfaff7f12 100644 (file)
        if (tg3_nvram_read(tp, 0, &magic) != 0)
                return -EIO;
  
-@@ -11169,7 +11230,7 @@ static int tg3_ioctl(struct net_device *
+@@ -11171,7 +11232,7 @@ static int tg3_ioctl(struct net_device *
                        return -EAGAIN;
  
                spin_lock_bh(&tp->lock);
                spin_unlock_bh(&tp->lock);
  
                data->val_out = mii_regval;
-@@ -11185,7 +11246,7 @@ static int tg3_ioctl(struct net_device *
+@@ -11189,7 +11250,7 @@ static int tg3_ioctl(struct net_device *
                        return -EAGAIN;
  
                spin_lock_bh(&tp->lock);
                spin_unlock_bh(&tp->lock);
  
                return err;
-@@ -11830,6 +11891,12 @@ static void __devinit tg3_get_5717_nvram
+@@ -11834,6 +11895,12 @@ static void __devinit tg3_get_5717_nvram
  /* Chips other than 5700/5701 use the NVRAM for fetching info. */
  static void __devinit tg3_nvram_init(struct tg3 *tp)
  {
        tw32_f(GRC_EEPROM_ADDR,
             (EEPROM_ADDR_FSM_RESET |
              (EEPROM_DEFAULT_CLOCK_PERIOD <<
-@@ -12093,6 +12160,9 @@ static int tg3_nvram_write_block(struct
+@@ -12097,6 +12164,9 @@ static int tg3_nvram_write_block(struct
  {
        int ret;
  
        if (tp->tg3_flags & TG3_FLAG_EEPROM_WRITE_PROT) {
                tw32_f(GRC_LOCAL_CTRL, tp->grc_local_ctrl &
                       ~GRC_LCLCTRL_GPIO_OUTPUT1);
-@@ -13518,6 +13588,11 @@ static int __devinit tg3_get_invariants(
+@@ -13522,6 +13592,11 @@ static int __devinit tg3_get_invariants(
              GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5701)))
                tp->tg3_flags |= TG3_FLAG_SRAM_USE_CONFIG;
  
        /* Get eeprom hw config before calling tg3_set_power_state().
         * In particular, the TG3_FLG2_IS_NIC flag must be
         * determined before calling tg3_set_power_state() so that
-@@ -13916,6 +13991,10 @@ static int __devinit tg3_get_device_addr
+@@ -13920,6 +13995,10 @@ static int __devinit tg3_get_device_addr
        }
  
        if (!is_valid_ether_addr(&dev->dev_addr[0])) {
  #ifdef CONFIG_SPARC
                if (!tg3_get_default_macaddr_sparc(tp))
                        return 0;
-@@ -14432,6 +14511,7 @@ static char * __devinit tg3_phy_string(s
+@@ -14436,6 +14515,7 @@ static char * __devinit tg3_phy_string(s
        case TG3_PHY_ID_BCM5704:        return "5704";
        case TG3_PHY_ID_BCM5705:        return "5705";
        case TG3_PHY_ID_BCM5750:        return "5750";
        case TG3_PHY_ID_BCM5752:        return "5752";
        case TG3_PHY_ID_BCM5714:        return "5714";
        case TG3_PHY_ID_BCM5780:        return "5780";
-@@ -14643,6 +14723,13 @@ static int __devinit tg3_init_one(struct
+@@ -14647,6 +14727,13 @@ static int __devinit tg3_init_one(struct
                tp->msg_enable = tg3_debug;
        else
                tp->msg_enable = TG3_DEF_MSG_ENABLE;
index 7166794a89693328084f29dfce4294de58f7f8c5..6bb25b9b1f4eb5ec2e4e204a71f52336c88ab1ad 100644 (file)
@@ -23,7 +23,7 @@ Date:   Thu Dec 16 20:01:17 2010 +0100
        {PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, PCI_DEVICE_ID_TIGON3_5752)},
 --- a/include/linux/pci_ids.h
 +++ b/include/linux/pci_ids.h
-@@ -2067,6 +2067,7 @@
+@@ -2068,6 +2068,7 @@
  #define PCI_DEVICE_ID_NX2_57711E      0x1650
  #define PCI_DEVICE_ID_TIGON3_5705     0x1653
  #define PCI_DEVICE_ID_TIGON3_5705_2   0x1654
@@ -31,7 +31,7 @@ Date:   Thu Dec 16 20:01:17 2010 +0100
  #define PCI_DEVICE_ID_TIGON3_5721     0x1659
  #define PCI_DEVICE_ID_TIGON3_5722     0x165a
  #define PCI_DEVICE_ID_TIGON3_5723     0x165b
-@@ -2080,11 +2081,13 @@
+@@ -2081,11 +2082,13 @@
  #define PCI_DEVICE_ID_TIGON3_5754M    0x1672
  #define PCI_DEVICE_ID_TIGON3_5755M    0x1673
  #define PCI_DEVICE_ID_TIGON3_5756     0x1674
index 2a22a3a38f215a2344a00847ec94a77ef9dc034f..b13563d69db5c98765d8f8aa3e4ccbc4b5afae1f 100644 (file)
@@ -10,7 +10,7 @@
  bool ssb_is_sprom_available(struct ssb_bus *bus)
 --- a/include/linux/ssb/ssb.h
 +++ b/include/linux/ssb/ssb.h
-@@ -401,6 +401,7 @@ extern bool ssb_is_sprom_available(struc
+@@ -408,6 +408,7 @@ extern bool ssb_is_sprom_available(struc
  /* Set a fallback SPROM.
   * See kdoc at the function definition for complete documentation. */
  extern int ssb_arch_set_fallback_sprom(const struct ssb_sprom *sprom);
index ef0cf4b3603111878313f6aa88651e903fd076df..f939c0edd18755fea08d42cd56914082dd970f03 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -funit-at-a-time
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 18e4a51ee35b7226321708364bfa5466ab5c38cd..1e41661ebb60fdbfa7e0ba613e236e4e0d94405a 100644 (file)
  /* LzmaDecode
 --- a/lib/lzma/LzmaDec.c
 +++ b/lib/lzma/LzmaDec.c
-@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p, 
+@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
    p->needFlush = 0;
  }
  
  {
    CLzmaProps propNew;
    RINOK(LzmaProps_Decode(&propNew, props, propsSize));
-@@ -944,7 +944,7 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p, 
+@@ -944,7 +944,7 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
    return SZ_OK;
  }
  
  void MatchFinder_Construct(CMatchFinder *p);
  
  /* Conditions:
-@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p, 
+@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
      UInt32 keepAddBufferBefore, UInt32 matchMaxLen, UInt32 keepAddBufferAfter,
      ISzAlloc *alloc);
  void MatchFinder_Free(CMatchFinder *p, ISzAlloc *alloc);
index 06d3f8c08c11f7d8af391f87131f41549547c035..a3a49bb31a9bcffe2c4425cfdefe7972eb813541 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.37/drivers/atm/solos-pci.c
-===================================================================
---- linux-2.6.37.orig/drivers/atm/solos-pci.c  2011-03-05 21:46:26.136023697 +0100
-+++ linux-2.6.37/drivers/atm/solos-pci.c       2011-03-05 21:48:49.046598163 +0100
+--- a/drivers/atm/solos-pci.c
++++ b/drivers/atm/solos-pci.c
 @@ -710,8 +710,8 @@ void solos_bh(unsigned long card_arg)
                                               le16_to_cpu(header->vci));
                                if (!vcc) {
index 8d8638be318c807f593ae7ccc0a456a1a90b1f32..2a965b22fdf59b27be91b68b1eee1bb9e0297758 100644 (file)
@@ -94,7 +94,7 @@
  
  /**
   * zap_vma_ptes - remove ptes mapping the vma
-@@ -2614,6 +2615,7 @@ int vmtruncate_range(struct inode *inode
+@@ -2616,6 +2617,7 @@ int vmtruncate_range(struct inode *inode
  
        return 0;
  }
index ac2e7ef53896b302e82d428892ac81a7e86b4860..7429c2be38f78abcb5cfc1b5ff92359458346691 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
 
 include $(INCLUDE_DIR)/target.mk
 
index f9a4e0f9a4e965e858e839e6258809ba648e6985..14c24813c6b6db90828ed37baf1be7d3f703067e 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
 FEATURES:=squashfs jffs2
 SUBTARGETS:=falcon xway
 
-LINUX_VERSION:=2.6.37.2
+LINUX_VERSION:=2.6.37.3
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
index 32e193ecce41bf573ffeda73e19e1896a9c71518..e690518d730bc77154bf5fa91b100fbb5db05fcd 100644 (file)
@@ -12,7 +12,7 @@ CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
 
 include $(INCLUDE_DIR)/target.mk
 
index a2dd84bb0050abb350f97178a12ed9e5e6195cc3..aeb47a4f113f2f12005ff3a90548951e56f254f1 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
 CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 00b7a331a996de508490b568c8d0f813104c7035..add1a11696848639babaa523b6abc1880bee69fa 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=ARM Ltd. Realview board (qemu)
 FEATURES:=squashfs jffs2 fpu
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time
 
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 2c039f4f23915d130092745e746c984edacc4f0d..f5abf461fcbafc776264edf91ba06a0a36ad3242 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
 
 include $(INCLUDE_DIR)/target.mk
 
index c58242a1be9a644f6665098f7e2117985ff7741c..21fe6452db5cb2c00898219840399602965ca9e7 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
 
 DEVICE_TYPE=other