dnsmasq: initscript: fix bool options handling, bump release number
authorNicolas Thill <nico@openwrt.org>
Sat, 17 Jul 2010 13:36:13 +0000 (13:36 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 17 Jul 2010 13:36:13 +0000 (13:36 +0000)
SVN-Revision: 22251

package/dnsmasq/Makefile
package/dnsmasq/files/dnsmasq.init

index 852b126fcc4606e1e6ef6d7cc05d43dcc1605b35..977e1097097545aacda8e8acecebd2a5caf19e58 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.55
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index 49291a5c8ab7b50f063b78f171345dae8bcdff05..e2f35e8aad0aff4e33fbd1c624b36dfe7cce647b 100644 (file)
@@ -23,8 +23,8 @@ append_bool() {
        local option="$2"
        local value="$3"
        local _loctmp
-       config_get_bool _loctmp "$section" "$option"
-       [ "$_loctmp" -gt 0 ] && append args "$value"
+       config_get_bool _loctmp "$section" "$option" 0
+       [ $_loctmp -gt 0 ] && append args "$value"
 }
 
 append_parm() {
@@ -274,7 +274,7 @@ dhcp_add() {
 
        #check for an already active dhcp server on the interface, unless 'force' is set
        config_get_bool force "$cfg" force 0
-       [ "$force" -gt 0 ] || {
+       [ $force -gt 0 ] || {
                udhcpc -n -q -s /bin/true -t 1 -i $ifname >&- && return 0
        }