moved root.tar.gz to sources/openwrt/root
authorMike Baker <mbm@openwrt.org>
Thu, 12 Aug 2004 06:43:18 +0000 (06:43 +0000)
committerMike Baker <mbm@openwrt.org>
Thu, 12 Aug 2004 06:43:18 +0000 (06:43 +0000)
SVN-Revision: 135

obsolete-buildroot/Makefile
obsolete-buildroot/make/openwrt.mk

index 3f0164afd40421406be4c9ff64defd5fc8c8b1d1..7b60dd519550e344a85c9bdfb7a6b408b17f3f46 100644 (file)
@@ -98,9 +98,9 @@ INSTALL_LIBGCJ:=false
 # The list of stuff to build for the target filesystem
 #
 #############################################################
-TARGETS:=host-sed gcc3_3 ipkg-utils openwrt-base openwrt-code.bin
+TARGETS:=host-sed openwrt-code.bin
 
-PACKAGES:=oidentd iproute2 sched-modules wshaper
+PACKAGES:=oidentd iproute2 sched-modules wshaper zlib openssl openssh pppoecd
 
 #############################################################
 #
@@ -194,7 +194,10 @@ OPENWRT_IPK_DIR=$(SOURCE_DIR)/openwrt/ipkg
 $(BUILD_DIR)/Packages : $(PACKAGES_IPK)
        (cd $(BUILD_DIR) ; $(IPKG_MAKE_INDEX) . > Packages)
 
-world: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) $(TARGETS) $(PACKAGES_IPK) $(BUILD_DIR)/Packages
+world: $(DL_DIR) $(TARGETS_SOURCE) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) $(TARGETS)
+       @echo "ALL DONE."
+
+packages: ipkg-utils $(PACKAGES_IPK) $(BUILD_DIR)/Packages
        @echo "ALL DONE."
 
 .PHONY: all world clean dirclean distclean source $(TARGETS) \
@@ -223,9 +226,9 @@ $(STAGING_DIR):
        ln -fs ../$(REAL_GNU_TARGET_NAME)/include $(STAGING_DIR)/usr/include
 
 
-$(TARGET_DIR): $(DL_DIR)/$(OPENWRT_ROOT_SKEL)
+$(TARGET_DIR):
        rm -rf $(TARGET_DIR)
-       zcat $(DL_DIR)/$(OPENWRT_ROOT_SKEL) | tar -C $(BUILD_DIR) -xf -
+       cp -a $(SOURCE_DIR)/openwrt/root/ $(TARGET_DIR)
        -find $(TARGET_DIR) -type d -name CVS -exec rm -rf {} \; > /dev/null 2>&1
 
 source: $(TARGETS_SOURCE)
index e839a0a5cb8e02b494edabee6d40a9d8178ae358..5867046a7f87181f59070fae0d1dd124529c0d60 100644 (file)
@@ -23,7 +23,7 @@
 # Currently the dependencies are not all handled.  But that's true of
 # our buildroot in general, since it wasn't really set up for end users.
 
-OPENWRT_TARGETS:= openwrt-linux openwrt-kmodules.tar.bz2 \
+OPENWRT_TARGETS:= gcc3_3 openwrt-linux openwrt-kmodules.tar.bz2 \
        openwrt-shared openwrt-mtd openwrt-nvram openwrt-wlconf \
        bridge dnsmasq1 iptables wtools busybox \
        openwrt-rootprep
@@ -34,8 +34,6 @@ openwrt-base: $(OPENWRT_TARGETS)
 
 ######################################################################
 
-ifneq ($(filter $(TARGETS),openwrt-base),)
-
 WRT54G_SOURCE=wrt54gs.2.07.1.tgz
 WRT54G_SITE=http://www.linksys.com/support/opensourcecode/wrt54gs/2.07.1
 WRT54G_DIR=$(BUILD_DIR)/WRT54GS
@@ -204,7 +202,7 @@ openwrt-rootprep:
 
 ######################################################################
 
-openwrt-prune: 
+openwrt-prune: openwrt-base
        -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
        # remove unneeded uClibc libs
        rm -rf $(TARGET_DIR)/lib/libthread_db*
@@ -237,4 +235,3 @@ openwrt-g-code.bin: openwrt-gs-code.bin
 openwrt-code.bin: openwrt-gs-code.bin openwrt-g-code.bin
 
 ######################################################################
-endif