added a init.d script to fonera-mp3d
authorJohn Crispin <john@openwrt.org>
Mon, 10 Sep 2007 21:19:21 +0000 (21:19 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 10 Sep 2007 21:19:21 +0000 (21:19 +0000)
SVN-Revision: 8734

package/fonera-mp3/Makefile
package/fonera-mp3/files/mp3d.init [new file with mode: 0644]

index d7431ff4d0a3d22457159d2c812e7f9555a25705..1cdbd4c51cc9cabeee75ce5c1ae62ba62546223f 100644 (file)
@@ -57,6 +57,8 @@ define Package/fonera-mp3d/install
        ln -sf mp3.cgi $(1)/www/cgi-bin/mp3_remote.cgi 
        $(INSTALL_DIR) $(1)/www/local
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/cgi/{stylesheet.css,json.js} $(1)/www/local/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/mp3d.init $(1)/etc/init.d/mp3d
 endef
 
 $(eval $(call BuildPackage,fonera-mp3d))
diff --git a/package/fonera-mp3/files/mp3d.init b/package/fonera-mp3/files/mp3d.init
new file mode 100644 (file)
index 0000000..9935a06
--- /dev/null
@@ -0,0 +1,12 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2007 OpenWrt.org
+
+START=90
+
+start() {
+       /usr/bin/mp3d
+}
+
+stop() {
+       killall mp3d 
+}