Convert monit to new packaging style
authorNicolas Thill <nico@openwrt.org>
Sat, 14 May 2005 22:09:24 +0000 (22:09 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 14 May 2005 22:09:24 +0000 (22:09 +0000)
SVN-Revision: 901

openwrt/package/monit/Makefile
openwrt/package/monit/files/monit.init [new file with mode: 0644]
openwrt/package/monit/ipkg/monit.conffiles [new file with mode: 0644]
openwrt/package/monit/ipkg/monit.control [new file with mode: 0644]
openwrt/package/monit/monit.control [deleted file]

index 393d4493314ca75f1ff651eb6b7bddf5ad9b1c4d..df51b3d3d9897b617e250191a8676146fc239340 100644 (file)
@@ -9,59 +9,57 @@ PKG_MD5SUM:=0f054ac39822b4be71789d49e4813754
 
 PKG_SOURCE_URL:=http://www.tildeslash.com/monit/dist/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
-$(DL_DIR)/$(PKG_SOURCE):
-        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
 
-$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       touch $(PKG_BUILD_DIR)/.unpacked
+$(eval $(call PKG_template,MONIT,monit,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                ./configure \
-               --target=$(GNU_TARGET_NAME) \
-               --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --prefix=/usr \
-               --exec-prefix=/usr \
-               --bindir=/usr/bin \
-               --sbindir=/usr/sbin \
-               --libexecdir=/usr/lib \
-               --sysconfdir=/etc \
-               --datadir=/usr/share \
-               --localstatedir=/var \
-               --mandir=/usr/man \
-               --infodir=/usr/info \
-               --without-ssl \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/sbin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --without-ssl \
        );
        touch $(PKG_BUILD_DIR)/.configured
 
-$(PKG_BUILD_DIR)/monit: $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+       touch $(PKG_BUILD_DIR)/.built
 
-$(PKG_IPK): $(PKG_BUILD_DIR)/monit
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(PKG_IPK_DIR)/usr/sbin
-       cp $(PKG_BUILD_DIR)/monit $(PKG_IPK_DIR)/usr/sbin/
-       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
-       mkdir -p $(PACKAGE_DIR)
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/monit.list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.unpacked
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/monit.list
-
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+$(IPKG_MONIT):
+       install -d -m0755 $(IDIR_MONIT)/etc
+       install -m0600 $(PKG_BUILD_DIR)/monitrc $(IDIR_MONIT)/etc/
+       install -d -m0755 $(IDIR_MONIT)/etc/init.d
+       install -m0755 ./files/monit.init $(IDIR_MONIT)/etc/init.d/monit
+       install -d -m0755 $(IDIR_MONIT)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/monit $(IDIR_MONIT)/usr/sbin/
+       $(RSTRIP) $(IDIR_MONIT)
+       $(IPKG_BUILD) $(IDIR_MONIT) $(PACKAGE_DIR)
diff --git a/openwrt/package/monit/files/monit.init b/openwrt/package/monit/files/monit.init
new file mode 100644 (file)
index 0000000..d1d6ce6
--- /dev/null
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+BIN=monit
+DEFAULT=/etc/default/$BIN
+RUN_D=/var/run
+PID_F=$RUN_D/$BIN.pid
+[ -f $DEFAULT ] && . $DEFAULT
+
+case $1 in
+ start)
+  mkdir -p $RUN_D
+  $BIN $OPTIONS
+  ;;
+ stop)
+  [ -f $PID_F ] && kill $(cat $PID_F)
+  ;;
+ *)
+  echo "usage: $0 (start|stop)"
+  exit 1
+esac
+exit $?
diff --git a/openwrt/package/monit/ipkg/monit.conffiles b/openwrt/package/monit/ipkg/monit.conffiles
new file mode 100644 (file)
index 0000000..365679c
--- /dev/null
@@ -0,0 +1 @@
+/etc/monitrc
diff --git a/openwrt/package/monit/ipkg/monit.control b/openwrt/package/monit/ipkg/monit.control
new file mode 100644 (file)
index 0000000..e3a4f2c
--- /dev/null
@@ -0,0 +1,7 @@
+Package: monit
+Priority: optional
+Section: admin
+Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
+Source: buildroot internal
+Description: an utility for system services monitoring
+Depends: libpthread
diff --git a/openwrt/package/monit/monit.control b/openwrt/package/monit/monit.control
deleted file mode 100644 (file)
index 87892ad..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-Package: monit
-Priority: optional
-Section: net
-Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
-Depends: libpthread
-Source: buildroot internal
-Description: utility for monitoring services on a Unix system